Welcome, Guest. Please login or register.
April 17, 2014, 06:41:56 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

  Show Posts
Pages: 1 2 3 [4]
46  Assistance / Pardus for beginners / Re: Disable Avahi Service - cannot resolve .local dns zones on: March 03, 2010, 19:53:12 PM
Well atolboo, that wasn't exactly what I was looking for but it worked!

I edited /etc/avahi/avahi-daemon.conf:
sudo nano /etc/avahi/avahi-daemon.conf
and then I made the following changes:

Now the service doesn't even start! Even after a reboot the service appears to be stopped and disabled.

Again, not what I was expecting but if no one has a cleaner solution for this then I guess I'll take it.

47  Assistance / Pardus for beginners / Re: Disable Avahi Service - cannot resolve .local dns zones on: March 03, 2010, 17:16:29 PM
Ah, if it could only be that simple...

What I meant to say is I cannot permanently disable the avahi service.

Simply stopping the service is not a permanent fix as avahi will automatically start the next time the computer reboots.

Also just to clear things up I am also unable to uninstall avahi because it is a dependency of too many system critical packages.
48  Assistance / Pardus for beginners / [solved]Disable Avahi Service - cannot resolve .local dns zones on: March 03, 2010, 15:13:21 PM
I am surprised I cannot find any Pardus specific information on this but here goes.

I have had a problem with Pardus since the first time I've tried it but I have let it go until now. I have to admit for a home user it's not that big of a deal but when using on a medium to large size network this is a big problem.

I'd also like to say that I LOVE pardus 2009.1! It is by far the most USABLE Linux I have ever seen. It seems to have excellent hardware support and probably the best feature is the custom network-manager which is by far the best I have ever seen especially when managing multiple wireless profiles. Even the package management is fantastic and I think that pisi plus the new mudur initialization system help make Pardus much more stable than any other Linux desktop I have ever used.

Anyways I'll get to it. I cannot disable the Avahi service! The reason why I need to disable it is crucial. As per the FAQ: http://avahi.org/wiki/Avah4users#FAQ on the avahi website: I installed Avahi and now I cannot resolve hosts from my unicast DNS zone .local!

And it specifically says: mDNS/DNS-SD is inherently incompatible with unicast DNS zones .local. We strongly recommend not to use Avahi or nss-mdns in such a network setup.

It took me quite a bit of troubleshooting just to figure out that the problem was caused by the avahi service but as soon as I stop avahi (service avahi stop) the problem goes away.

What happens is if I leave the avahi service running, then I am unable to resolve hostnames that belong within a dns naming space that ends in .local. I also am unable to browse such networks using the smb browser built-in to KDE 4.

Now of course I have tried to disable the service to no avail. If I simply run "service avahi off" the system reports that the service will no longer start at boot, but it still starts at boot. Also I have verified that when I turn the service off it actually adds itself to /etc/mudur/services/disabled but it still starts automatically.

I am beginning to see that pardus maintains itself very differently than your average linux distro and it seems to have some sort of templating system similar to a distro called SME Server (formally e-smith). For example to permanently change the hostname in pardus you must modify an environment variable template file called /etc/env.d/01hostname. I also had to get rid of the default dns entries that pardus comes with and so I discovered the only permanent way is to remove (or comment out) the 3 entries in another template file called /usr/share/baselayout/resolv.conf

So my guess is that the fix for my problem is somewhat in-depth considering pardus is configured this way and if I had the full documentation (in English) for how this system works I would be much more comfortable with pardus in general.

And one more thing. When I type 'service list' at the command line I notice that it is color coded. The notable thing is that there are three services that are colored in bright neon green and those services are: avahi, microcode_ctl, and wpa_supplicant.

When I look in the 'Service Manager' gui I can see that these are the only three services that do not have the 'Run-on start' checkbox checked, yet all three of these services start automatically at boot...

Pages: 1 2 3 [4]

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!