Welcome, Guest. Please login or register.
April 21, 2014, 16:57:53 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

  Show Posts
Pages: [1]
1  Assistance / Laptop / nVidia Optimus / Bumblebee in Pardus? on: July 13, 2011, 23:26:44 PM
Does anyone has experience in using Bumblebee in Pardus? I'm going to get a new laptop shortly and it has the Optimus crap Wink Looking at the github page it seems that it's not so easy to use it in "any distro you like".

* https://github.com/MrMEEE/bumblebee
2  General / General topics / Re: Pardus 2011.1 on: July 12, 2011, 11:42:11 AM
Anyone needs Wine under x86_64? Wink



Devs made a nice menu for Wine with all its tools. Something you don't see often in other distros.
3  General / The Pub / Re: Will Linux ever get 2 % ? on: July 09, 2011, 00:55:41 AM
Well if Linux instead of new major release of a desktop environment would got stable release of Adobe CS 5/6, or other proprietary and business essential for some application then it would have bigger adoption rate. Adobe did think about it, but it seems it got dropped at some point. I can use Linux for my work (codding), but my company (custom publishing) can't. I can't also use it for my hobby - astrophotography Wink

Success of free and no-free/non-open apps in Android or iPhone/iPad show that both type of apps are desired, required by the users.
4  General / The Pub / Re: Will Linux ever get 2 % ? on: July 08, 2011, 12:12:15 PM
I did like KDE3 a lot. Now KDE4 and even more things like Unity/GNOME3 make me angry/annoyed at the desktop. I've seen people switch to Mac annoyed by the "changes" in the Linux desktop section Wink
5  Assistance / News & Announcements / Re: Pardus 2011.1 Beta on: July 03, 2011, 19:02:08 PM
That is already installed  Wink but still compared to a rolling release Gentoo  some apps are older or missing (like wine under x86_64).
6  Assistance / News & Announcements / Re: Pardus 2011.1 Beta on: July 03, 2011, 03:17:08 AM
I've played with the beta in Virtualbox and it did work nicely, although Polish support was quite low Wink
7  Assistance / Pardus for beginners / Re: Network Error with Wine on: August 21, 2007, 18:30:10 PM
wine has limited networking support, are there reports that this game should work on wine over network?
8  Assistance / Software / Re: klibido. on: July 19, 2007, 12:38:40 PM
looks like the code has one ISO standard bug - " error: ISO C++ forbids declaration of `Db' with no type" - you would have to edit all those files and fix the declaration.

I tested this on Gentoo with GCC 4.1 and it compiles, but they use a patch:
Code:
diff -U 4 -H -b -w -B -E -d -i -r klibido-0.2.5-orig/src/nntpthreadsocket.h klibido-0.2.5/src/nntpthreadsocket.h
--- klibido-0.2.5-orig/src/nntpthreadsocket.h 2006-10-10 13:43:13.000000000 +0200
+++ klibido-0.2.5/src/nntpthreadsocket.h 2006-10-10 13:44:52.000000000 +0200
@@ -233,9 +233,9 @@
  bool getBody(QString group, int artnum); //Unimplemented
  bool getHead(QString group, int artnum); //Unimplemented
  int m_getError() {return error;}
      const char *m_getErrorDesc() {return (const char *) errorString;}
- char * NntpThreadSocket::m_findEndLine( char * start, char * end );
+ char * m_findEndLine( char * start, char * end );
  void setHost(NntpHost *nh);
  bool m_sendCmd( QString& cmd, int response );
  QTime prevTime, currentTime;
 
diff -U 4 -H -b -w -B -E -d -i -r klibido-0.2.5-orig/src/yydecoder.h klibido-0.2.5/src/yydecoder.h
--- klibido-0.2.5-orig/src/yydecoder.h 2006-10-10 13:43:13.000000000 +0200
+++ klibido-0.2.5/src/yydecoder.h 2006-10-10 13:46:02.000000000 +0200
@@ -86,9 +86,9 @@
  void crcInit();
 
 private:
 
- inline void yyDecoder::charCRC(const unsigned char *c);
+ inline void charCRC(const unsigned char *c);
 
  QStringList m_fileParts;
  QStringList::Iterator fileIterator;
 
It may not fix GCC 3.4 problems.
9  General / Wish list / [packages] nozomi driver and kadu on: July 19, 2007, 01:27:20 AM
- Nozomi 2.21alpha_060917-1 - kernel driver for some WiFi modems (Globtrotter), [hard to compile (GCC 4.1 Gentoo x86 and x86_64 failed, only on Pardus it compiles  Roll Eyes)] see driver forums
- Kadu 0.5.0-1 - client for Polish Gadu-Gadu network Smiley




Here are the build files, comments welcomed as I'm new to this Wink
NOZOMI
actions.py
Code:
#!/usr/bin/python
# -*- coding: utf-8 -*-
#
# Copyright 2006 TUBITAK/UEKAE
# Licensed under the GNU General Public License, version 2.
# See the file http://www.gnu.org/copyleft/gpl.txt.

from pisi.actionsapi import autotools
from pisi.actionsapi import pisitools
from pisi.actionsapi import get

NoStrip = "/"
WorkDir = 'nozomi_2.21alpha_060917/'

def build():
    autotools.make()

def install():
    pisitools.doexe("nozomi.ko", "/lib/modules/%s/kernel/drivers/pci/hotplug/" % get.curKERNEL())
    pisitools.dodoc("readme", "todo", "CHANGELOG")

pspec.xml
Code:
<?xml version="1.0" ?>
<!DOCTYPE PISI SYSTEM "http://www.pardus.org.tr/projeler/pisi/pisi-spec.dtd">
<PISI>
    <Source>
        <Name>nozomi</Name>
        <Homepage>http://www.pharscape.org</Homepage>
        <Packager>
            <Name>Piotr Maliński</Name>
            <Email>riklaunim@gmail.com</Email>
        </Packager>
        <License>GPL-2</License>
        <IsA>library</IsA>
        <Summary>Driver for some WiFi modems</Summary>
<Archive sha1sum="6f3d15f2cb4511b36647941353b16ff518bafb4a" type="targz">http://www.pharscape.org/index2.php?option=com_forum&amp;Itemid=68&amp;page=download&amp;id=18</Archive>
        <BuildDependencies>
            <Dependency release="86">kernel-source</Dependency>
        </BuildDependencies>
    </Source>

    <Package>
        <Name>nozomi</Name>
        <RuntimeDependencies>
            <Dependency release="86">kernel</Dependency>
        </RuntimeDependencies>
        <Files>
            <Path fileType="library" permanent="true">/lib/modules</Path>
            <Path fileType="doc">/usr/share/doc</Path>
        </Files>
    </Package>

    <History>
        <Update release="1">
            <Date>2007-07-18</Date>
            <Version>2.21alpha_060917</Version>
            <Comment>First release.</Comment>
            <Name>Piotr Maliński</Name>
            <Email>riklaunim@gmail.com</Email>
        </Update>
    </History>
</PISI>


KADU
actions.py
Code:
#!/usr/bin/python
# -*- coding: utf-8 -*-
#
# Copyright 2006 TUBITAK/UEKAE
# Licensed under the GNU General Public License, version 2.
# See the file http://www.gnu.org/copyleft/gpl.txt.

from pisi.actionsapi import autotools
from pisi.actionsapi import pisitools
from pisi.actionsapi import perlmodules
from pisi.actionsapi import get

WorkDir = 'kadu'


def setup():
    autotools.configure("--prefix=/usr")

def build():
    autotools.make()

def install():
    autotools.rawInstall("DESTDIR=%s" % get.installDIR())

pspec.xml
Code:
<?xml version="1.0" ?>
<!DOCTYPE PISI SYSTEM "http://www.pardus.org.tr/projeler/pisi/pisi-spec.dtd">
<PISI>
    <Source>
        <Name>kadu</Name>
        <Homepage>http://www.kadu.net</Homepage>
        <Packager>
            <Name>Piotr Maliński</Name>
            <Email>riklaunim@gmail.com</Email>
        </Packager>
        <License>GPL-2</License>
        <IsA>app:gui</IsA>
        <Summary>Gadu-Gadu QT client</Summary>
        <Archive sha1sum="8483d68c954c83baa9c3c73eecb808a20bd90b31" type="tarbz2">http://www.kadu.net/download/stable/kadu-0.5.0.tar.bz2</Archive>
        <BuildDependencies>
            <Dependency>qt</Dependency>
        </BuildDependencies>
    </Source>

    <Package>
        <Name>kadu</Name>
        <RuntimeDependencies>
            <Dependency>qt</Dependency>
        </RuntimeDependencies>
        <Files>
            <Path fileType="executable">/usr/bin</Path>
            <Path fileType="library">/usr/lib</Path>
            <Path fileType="header">/usr/include</Path>
            <Path fileType="localedata">/usr/share/locale</Path>
            <Path fileType="man">/usr/share/man</Path>
    <Path fileType="data">/usr/share</Path>
     <Path fileType="data">/usr/share/pixmaps</Path>
            <Path fileType="doc">/usr/share/doc</Path>
        </Files>
<AdditionalFiles>
<AdditionalFile owner="root" permission="0644" target="/usr/kde/3.5/share/applications/kde/kadu.desktop">kadu.desktop</AdditionalFile>
        </AdditionalFiles>
    </Package>

    <History>
        <Update release="1">
            <Date>2007-07-18</Date>
            <Version>0.5.0</Version>
            <Comment>First release.</Comment>
            <Name>Piotr Maliński</Name>
            <Email>riklaunim@gmail.com</Email>
        </Update>
    </History>
</PISI>
10  Assistance / News & Announcements / Re: Nice review of 2007.2 final on: July 19, 2007, 01:17:31 AM
http://polishlinux.org/linux/pardus/pardus-20072-new-cat-in-town/
http://simplyjat.blogspot.com/2007/07/pardus-linux-20072-review.html
11  Assistance / Software / Re: GCC4 ? on: July 19, 2007, 01:16:46 AM
I use GCC 4.1.1 on Gentoo amd64 and compile problems are very rare (not with popular software) Smiley
12  Assistance / Pardus for beginners / Re: change back to english on: July 14, 2007, 19:42:53 PM
edit Pardus->/boot/grub/menu.lst from pardus partition and add PCLinuxOS entry. You can copy it from PCLinux->/boot/grub/menu.lst partition.

From command line you can use nano (as root), under KDE use for example "kdesu kate"

Also if you want to set the default language for Pardus you can edit /etc/env.d/03locale and or setting "language" in /etc/conf.d/mudur [I don't know if it's "the right way"]
Pages: [1]


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!