Welcome, Guest. Please login or register.
April 24, 2014, 11:02:18 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  Backing up KMail to a USB stick with FAT32
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Backing up KMail to a USB stick with FAT32  (Read 1876 times)
RMP
Newbie
*
Gender: Male
Posts: 3


View Profile
« on: May 27, 2007, 20:27:38 PM »

Hi

I am trying to make a backup of my kmail folder.  If I copy it into a folder on my desktop or my second hard drive using ext3 there is no problem, but if I then try to copy the folder to a USB stick using FAT32 there are certain files that will not copy across.  I am not sure if it is a problem with the length of the file names, the files themselves are not compatable with FAT32 or it is a permission problem with certain files contained in the kmail folder. 

Any help would be appreciated.

Richard
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #1 on: May 28, 2007, 17:10:08 PM »

RMP,

I tried to duplicate your problem on my own system so I could try to help you figure it out.  All of my Kmail files copied without a problem onto my FAT32 usb stick.  When I've had problems copying or moving files in the past,  I have always received error messages which told me why it failed to copy--usually permission problems.  Does your system give any error messages when you try to copy the fles?  Also,  this post has some good step by step information about priveleges if that is what the problem is:  http://worldforum.pardus-linux.nl/index.php/topic,917.0.html  Hopefully,  this information will help you.

Marty
Logged
RMP
Newbie
*
Gender: Male
Posts: 3


View Profile
« Reply #2 on: May 28, 2007, 21:26:03 PM »

Marty

I have looked at all the permissions for the files in kmail that will copy and the ones that will not and they are all the same likewise with the USB stick.

However, the files that won't copy have a strange file extension that ends with :2.S and I think this is where the problem lies.  I don't know if kmail is saving the files in the wrong format and I need to change a setting or if I am doing something wrong.

Thanks

Richard
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #3 on: May 28, 2007, 23:58:58 PM »

Richard,

In my experience with Liinux,  I have been able to copy every file type onto devices no matter which filesystem they use.  I could not find any files in my Kmail directory with 2.S extension,  so I can't really tell what the problem is.  What I did to duplicate the problem was to browse to my Kmail directory (located in the directory /home/msull/.kde/share/apps) and copy it by dragging and dropping it into my usb flash directory with Fat32 file system.  I selected the "Show Hidden Files" tab from the View menu in Konqueror so I could see if there were any files with unusual extensions.  For me,  the directory /home/msull/.kde/share/apps/kmail contains all of my settings for kmail and all of my mail folders.  Maybe I backed up the wrong directory.  Did you find your kmail folder in the same place that I did?  The only part that should be different between your system and mine should be the "/msull" part because that is my local user name.  Your local user name would replace "msull" on your system.  Let me know if you backed up a different Kmail folder so I can try to reproduce the problem on my system and help work it out.

Marty
Logged
RMP
Newbie
*
Gender: Male
Posts: 3


View Profile
« Reply #4 on: May 29, 2007, 11:31:18 AM »

Marty

I think I have the answer.  If you use maildir to store your e-mail in kmail it uses file names that includes a : which is not compatable with fat32.  If you use Mbox to store your e-mail then there is not a problem writing these files to fat32. 

The file I backup is a hidden folder in your home folder called .Mail.  I know this is correct because I have copied it to a ext3 USB stick and imported all the e-mails onto my second machine.

Maildir seems to be the default in kmail but you can change to mbox if needed.  I don't know which is the best to use it seems both have good and bad points.

Just on another point, on the ext3 partition there are .Trash folders that have the same user id number as users on the machine but if you remove a user how do you delete these .Trash folders?

Thanks for all the help.

Richard
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #5 on: May 29, 2007, 19:20:09 PM »

Richard,

I think you can just right click the .Trash files and select Delete to get rid of them.  If that fails due to permissions,  open up a terminal by selecting the Tools menu and clicking Open Terminal.  This will open the terminal with the correct path.  Then type su and your password to get root permissions.  Then,  just type: rm .Trash

Marty
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #6 on: May 29, 2007, 21:52:19 PM »

Richard,

I think I made a mistake in my last post.  If you cannot just right click and delete the .Trash folder,  you can open a terminal from the Konqueror tools menu from the folder where the .Trash folder is located as I described above.  The correct command would be " rmdir .Trash" without the quotes.  The command I gave above only works for files,  not folders.  Sorry about the confusion.

Marty
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!