Welcome, Guest. Please login or register.
April 20, 2014, 12:48:11 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Installing Pardus
| | |-+  problems with X700, again
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: problems with X700, again  (Read 2167 times)
Klenje
Pardus fellow craft
**
Posts: 32


View Profile
« on: July 14, 2007, 10:22:39 AM »

Well, I had trouble already installing Pardus 2007 in my laptop with a Ati x700. Now after an update to 2007.2 it doesn't start anymore. It's not a big deal, since it's just a testing system, anyway the problem is that I can't install 2007.2
I've tried both standard mode and safe graphics mode, but when the screen after the first phase becomes black, I'm not able to get back to console... I've tried Ctrl+Alt+F1, Alt+F2 and others, but without success... anyone can help me? I know this is a really bad graphic card, but still I wonder if it should be detected successfully after 2 years... didn't they have time to add a patch to Xorg? Huh?
Logged
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #1 on: July 18, 2007, 13:02:16 PM »

http://worldforum.pardus-linux.nl/index.php/topic,581.msg2228.html#msg2228
Logged
Klenje
Pardus fellow craft
**
Posts: 32


View Profile
« Reply #2 on: July 19, 2007, 16:36:26 PM »

thanks, with xorg=safe I can at least boot. But I don't get the proper resolution....well I suppose this is normal since they are generic drivers. But if I try to switch back to "ati" driver, I get the usual black screen. Could it be that there are problems with this ati driver version? this could explain everything.
note that I didn't added any other options to xorg (besides that needed for this stupid X700)
Logged
Kavani
Guest
« Reply #3 on: July 20, 2007, 16:21:43 PM »

Have you tried reinstalling the fglrx driver?  Jan had a post here somewhere on setting it up once you did.
Logged
Erkan Yilmaz
Newbie
*
Posts: 9


View Profile WWW
« Reply #4 on: July 20, 2007, 18:38:19 PM »

Hello Klenje,

I had the same two problems.

What helped me with the resolution was:
go in terminal mode (e.g. ctrl+alt+f1)
stop kde with: service kdebase stop

then in the directory /etc/X11
rename your original xorg.conf (so you can restore again, if this does not work)

execute zorg (this detects now your hardware)

after that in your xorg.conf change
in:
Section "Device"

        Driver      "ati"

to:

        Driver      "fglrx"


in: Section "Screen"
change Modes and Depth as you wish

service kdebase start

and now I wish you all luck :-)


Sincerely,
Erkan YILMAZ
blog: www.Iaskquestions.com

« Last Edit: July 20, 2007, 19:40:58 PM by Erkan Yilmaz » Logged
Klenje
Pardus fellow craft
**
Posts: 32


View Profile
« Reply #5 on: July 20, 2007, 19:09:37 PM »

well, I guess fglrx drivers works... but I wanted to use the open source drivers, so I could use easily beryl and all that stuff. I think that this new release of open source drivers is buggy. Well, I won't connect too much in the next weeks, since I'm going back home where I don't have broadband. Hopefully in September everything will work again  Grin
thanks for your help anyway  Smiley
Logged
Erkan Yilmaz
Newbie
*
Posts: 9


View Profile WWW
« Reply #6 on: July 20, 2007, 19:37:49 PM »

Hello Klenje,

I understand.
Well, then I hope future readers can use this info then.

Have a nice day,
Erkan YILMAZ
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!