Welcome, Guest. Please login or register.
April 24, 2014, 22:55:51 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  change back to english
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: change back to english  (Read 2134 times)
fxdwg
Newbie
*
Posts: 6


View Profile
« on: July 14, 2007, 06:47:46 AM »

I installed Pardus last night and when it built the boot loader it didn't recognize my PClinux partition. So today i redid the grub loader for PClinux and added Pardus. Now Pardus does not start in english, Turkish I guess but I don't know how to change it back to English. I know very little about Linux, need to know if there is a simple fix for a novice like me.
Logged
Willem
M.D.
Administrator
Pardus Guru
*****
Gender: Male
Posts: 1020



View Profile WWW
« Reply #1 on: July 14, 2007, 08:15:54 AM »

You can change the boot proces easily, just go to Tasma;
Boot management (under system);
Choose the latest entry and choose edit;

In the longest line with kernel parameters:
Quote
root=/dev/hda1 video=vesafb:nomtrr,pmipal,ywrap,1024x768-32@60 splash=silent,fadein,theme:pardus console=tty2 mudur=language:nl quiet

is where you can change the language of the boot proces.
Logged

For freedom...
fxdwg
Newbie
*
Posts: 6


View Profile
« Reply #2 on: July 14, 2007, 08:36:09 AM »

It boots in a language I don't understand! I am using the grub from pclinux
Logged
Willem
M.D.
Administrator
Pardus Guru
*****
Gender: Male
Posts: 1020



View Profile WWW
« Reply #3 on: July 14, 2007, 10:53:22 AM »

that Language is probably Turkish as it is the default language for Pardus.
But are you saying that Grub is in a strange language or that Pardus itself is not English?
If you mean Pardus, then you can just press the Pardus button, Select "Tasma" fiddle around for the icon with flags on it (Turkish flag up front) here you can change the language settings to English (or dutch or whatever).
Logged

For freedom...
fxdwg
Newbie
*
Posts: 6


View Profile
« Reply #4 on: July 14, 2007, 17:14:57 PM »

I am using the PCLINUX boot loader
which loads Pardus
That starts in a non English language
That I can't change because its not in English.
Sorry I didn't make that clear enough.
Logged
Willem
M.D.
Administrator
Pardus Guru
*****
Gender: Male
Posts: 1020



View Profile WWW
« Reply #5 on: July 14, 2007, 17:22:18 PM »

Ok then you probably didnt make a proper Grub entry for Pardus.
The Pardus version of grub has a lot more options, and PSLinixOS probably just made a default entry for Pardus.

The Pardus entry of grub should be something like:
Quote
root=/dev/hda1 video=vesafb:nomtrr,pmipal,ywrap,1024x768-32@60 splash=silent,fadein,theme:pardus console=tty2 mudur=language:nl quiet
You can find grub in your default system via
/boot/grub/
sudo nano grub.conf

But I would advise to install Pardus with the Pardus grub, since Pardus also uses a graphical boot manager, and it will be updated automaticaly with each kernel update.
Logged

For freedom...
fxdwg
Newbie
*
Posts: 6


View Profile
« Reply #6 on: July 14, 2007, 18:03:48 PM »

I'm afaid this is too complicated for my limited skills. I need to have my PCLINUX . When I install Pardus and use the Pardus grub it does not find my PCLINUX partition so PCLINUX is not in the grub loader.
I don't know how to manually install PCLINUX in the Pardus boot loader. 
Thank-you for the help
Logged
riklaunim
Newbie
*
Posts: 12


View Profile
« Reply #7 on: July 14, 2007, 19:42:53 PM »

edit Pardus->/boot/grub/menu.lst from pardus partition and add PCLinuxOS entry. You can copy it from PCLinux->/boot/grub/menu.lst partition.

From command line you can use nano (as root), under KDE use for example "kdesu kate"

Also if you want to set the default language for Pardus you can edit /etc/env.d/03locale and or setting "language" in /etc/conf.d/mudur [I don't know if it's "the right way"]
Logged
fxdwg
Newbie
*
Posts: 6


View Profile
« Reply #8 on: July 15, 2007, 02:17:06 AM »

Too much for me , guess I'll wait till next version and maybe it will be able to recognize other distro's. Thank-you
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #9 on: July 19, 2007, 14:23:49 PM »

fxdwg,

the problem is not Pardus. No Linux distro currently will recognize another distro on the same system and automatically make a grub entry for it. Waiting for the next release won't help...

You can however, as you already do, use the PCLinuxOS boot loader to start Pardus. You will have to edit the configuration file /boot/grub/menu.lst on PCLinuxOS manually to tell it to start Pardus in English.

The key line in this file is the one which loads the kernel for Pardus. Here you'll have to add

Code:
mudur=language:en

to get the system to start in English.

If you are not comfortable making the change, just come back here and we'll "talk" you through it, OK?



Logged
fxdwg
Newbie
*
Posts: 6


View Profile
« Reply #10 on: July 21, 2007, 22:50:28 PM »

thank-you for the offer. I got it going in english but firefox and most of the sub menu's are in turkish. I'm going to do a new install without grub and may come back for help then.
Logged
Kavani
Guest
« Reply #11 on: July 22, 2007, 16:52:48 PM »

thank-you for the offer. I got it going in english but firefox and most of the sub menu's are in turkish. I'm going to do a new install without grub and may come back for help then.

I think you're on the right track.  I just did a multiboot system and the grub installer on the other distro recognized Pardus off the bat.  Good luck and let us know how it turns out!
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!