Welcome, Guest. Please login or register.
April 18, 2014, 20:38:45 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  PISI don't work after upgrade to 2007.2
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: PISI don't work after upgrade to 2007.2  (Read 2295 times)
klaus54
Newbie
*
Posts: 9


View Profile
« on: August 16, 2007, 17:00:13 PM »

Hi! I've ugrade my distro to kurulan,but now when i try to run pisi,the shell give me this error:"program terminated,no command given".How i can reinstall pisi or patch this problem?thank you!
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #1 on: August 16, 2007, 17:13:13 PM »

"pisi" is a command line tool and it seems to work on your system Smiley I think you say a GUI, you can start it by writting "package-manager" on console or clicking it in the menu.
Logged
klaus54
Newbie
*
Posts: 9


View Profile
« Reply #2 on: August 16, 2007, 17:16:02 PM »

i've just tried: the answer from shell is this: "Traceback (most recent call last):
  File "/usr/kde/3.5/bin/package-manager", line 1024, in ?
    main()
  File "/usr/kde/3.5/bin/package-manager", line 1019, in main
    LocaleData.setSystemLocale()
  File "/usr/kde/3.5/share/apps/package-manager/LocaleData.py", line 39, in setSystemLocale
    locale.setlocale(locale.LC_ALL, systemlocale)
  File "/usr/lib/python2.4/locale.py", line 381, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
ERROR: Communication problem with package-manager, it probably crashed."
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #3 on: August 16, 2007, 17:20:08 PM »

Could you reply the out of this command?

Code:
echo $LC_ALL
Logged
klaus54
Newbie
*
Posts: 9


View Profile
« Reply #4 on: August 16, 2007, 17:26:05 PM »

this: "tr_TR.UTF-8"
I'm italian,now my distro is half turkish and half Italian....what's happen?Huh?Huh?Huh? Huh? Huh?
Logged
klaus54
Newbie
*
Posts: 9


View Profile
« Reply #5 on: August 16, 2007, 17:43:06 PM »

this is the solution?i've read that italian localisation have a conflict (why? :'(). This is the patch?
locales = {
    "tr" : "tr_TR.UTF8",
    "en_US" : "en_US.UTF-8",
    "nl" : "nl_NL.UTF-8",
    "de" : "de_DE.UTF-8",
    "fr" : "fr_FR.UTF-8",
    "it" : "it_IT.UTF-8",
    }
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #6 on: August 16, 2007, 18:06:46 PM »

Could you try this commands?

Code:
sudo pisi it glibc-locales-it
Code:
export LC_ALL=it_IT.UTF-8
Code:
package-manager
Logged
klaus54
Newbie
*
Posts: 9


View Profile
« Reply #7 on: August 16, 2007, 20:46:09 PM »

thank you so much,my firend!now the cat run good!but the turkish remain in system language (on firefox,shell and other program!)
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #8 on: August 16, 2007, 20:52:58 PM »

Code:
echo LC_ALL=it_IT.UTF-8 >> ~/.bashrc

After this command, please login and logout Smiley
Logged
klaus54
Newbie
*
Posts: 9


View Profile
« Reply #9 on: August 17, 2007, 02:27:39 AM »

thank you again,i've ever think that the turkish are nice! I've add also to mi kernel line "murdur:it",now all work in Italian (open office say maccheroni,not english "macaroni" Tongue). Congratulation for the distribution,i've install this in the place of...UBUNTU! I hope that pardus can spread in my country!
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #10 on: August 17, 2007, 06:19:21 AM »

Great, enjoy your Pardus Wink)
Logged
babily
Guest
« Reply #11 on: November 21, 2007, 14:43:15 PM »

Hi, i am a new user of Pardus. Yesterday i updated glibc 2.3.6 to glibc 2.6.1 and today my PISI doesn't work. When i type package-manager in console an error message is revealed as:
package-manager
Quote
Traceback (most recent call last):
  File "/usr/kde/3.5/bin/package-manager", line 1024, in ?
    main()
  File "/usr/kde/3.5/bin/package-manager", line 1010, in main
    myapp = MainApplication()
  File "/usr/kde/3.5/bin/package-manager", line 912, in __init__
    self.mainwidget = MainApplicationWidget(self)
  File "/usr/kde/3.5/bin/package-manager", line 166, in __init__
    self.command = Commander.Commander(self)
  File "/usr/kde/3.5/share/apps/package-manager/Commander.py", line 34, in __init__
    pisi.api.init(database=True, write=False)
  File "/usr/lib/pardus/pisi/api.py", line 107, in init
    shelve.init_dbenv(write=write)
  File "/usr/lib/pardus/pisi/lockeddbshelve.py", line 75, in init_dbenv
    if os.access(pisi.context.config.db_dir(), os.R_OK):
  File "/usr/lib/pardus/pisi/config.py", line 96, in db_dir
    return self.subdir(self.values.dirs.db_dir)
  File "/usr/lib/pardus/pisi/config.py", line 86, in subdir
    pisi.util.check_dir(subdir)
  File "/usr/lib/pardus/pisi/util.py", line 273, in check_dir
    os.makedirs(d)
  File "/usr/lib/python2.4/os.py", line 159, in makedirs
    mkdir(name, mode)
OSError: [Errno 13] Permission denied: '/var/db/pisi'
ERROR: Communication problem with package-manager, it probably crashed.]

Then i typed
sudo pisi rebuild-db
result is

Quote
System Error: Program ended.
unsupported locale setting
For Help please use 'pisi help' command.
************* please --debug *********.

Please help Cheesy
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #12 on: November 21, 2007, 14:53:21 PM »

Could you enter a command blow and post output of it?

Code:
ls -al /var/db
Code:
ls -al /var/db/pisi
Logged
babily
Guest
« Reply #13 on: November 21, 2007, 15:00:59 PM »

ls -al /var/db
Quote
total 12
drwxr-xr-x  3 root root 4096 Nov 21 12:08 .
drwxr-xr-x 13 root root 4096 Nov 15 12:14 ..
drwx------  3 root root 4096 Nov 21 12:28 comar

ls -al /var/db/pisi
Quote
total 512
drwxr-xr-x  2 root root   4096 Nov 19 15:59 .
drwxr-xr-x 13 root root   4096 Nov 15 12:14 ..
-rw-r--r--  1 root root  13967 Nov 19 15:59 files.xml
-rw-r--r--  1 root root 348160 Nov 19 15:59 install.tar
-rw-r--r--  1 root root 127707 Nov 19 15:59 install.tar.lzma
-rw-r--r--  1 root root   9892 Nov 19 15:59 metadata.xml


I still don't know the problem :S
« Last Edit: November 21, 2007, 15:09:07 PM by babily » Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #14 on: November 21, 2007, 15:20:18 PM »

Could you enter command below and re-try opening the package-manager?

Code:
sudo chmod 755 /var/db/pisi
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!