Welcome, Guest. Please login or register.
April 21, 2014, 16:44:53 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  The damn same old ATI Drivers
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: The damn same old ATI Drivers  (Read 2844 times)
Night
Pardus fellow craft
**
Posts: 45


View Profile
« on: September 06, 2007, 16:01:51 PM »

ok i thought about giving Pardus a try after Ubuntu started to mess up things with Ati driver stuff.

And so i did, now installing the 3rd time the distro because everytime i install ati drivers package it wont work. still is using mesa.
then i try to edit the xorg.conf by the instructions found in this forum.

well after messing up and trying with it few times i start to get only black screen when booting Pardus.

and nothing works after that....   any way to boot to console from Grub.?  ubuntu had that.... so if the xorg gets broken i can fix it without having to install the whole thing all over again.

the card is Ati radeon x700

and plz post good and clear instructions on how to install the drivers for it and instructions that work... there are like 1000 guides to do it and many are so different from each other.
Logged

SakJur
Pardus fellow craft
**
Posts: 64



View Profile
« Reply #1 on: September 06, 2007, 16:14:03 PM »

According to Zinden, start the Konsole:
Code:
sudo pisi it http://paketler.pardus.org.tr/pardus-2007-test/ati-drivers-8.40.4-21-24.pisi
Logged

Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #2 on: September 06, 2007, 16:41:11 PM »

display: :0.0  screen: 0
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX+/3DNow!+/SSE2 TCL
OpenGL version string: 1.3 Mesa 7.0

yes i can install the driver package but after that....
Logged

Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #3 on: September 08, 2007, 09:07:17 AM »

any command to force driver fglrx..?
Logged

Eidos
Newbie
*
Posts: 5


View Profile
« Reply #4 on: September 08, 2007, 12:25:14 PM »

if you have already set fglrx as driver in xorg

try this :

remplace the options in this line on your /etc/fstab
Code:
tmpfs                /dev/shm         tmpfs     nodev,nosuid,noexec  0 0

by
Code:
tmpfs                /dev/shm         tmpfs     defaults  0 0
(don't forget to make a backup of this file)

and reboot

that works with the ati-driver from the stable tree (didn't try with the last one, i will wait the next)

hope it will work for you
Logged
Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #5 on: September 09, 2007, 08:32:19 AM »

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X700
OpenGL version string: 2.0.6747 (8.40.4

That really worked.. THANKS  Grin

now i can use pardus instead of sabayonlinux  Wink
i like that pardus is so simple.
Logged

Kavani
Guest
« Reply #6 on: September 10, 2007, 22:39:41 PM »

AMD just announced that they are opening up the ATi drivers for open source.  So, we may see a few more packages before too long.
Logged
Eidos
Newbie
*
Posts: 5


View Profile
« Reply #7 on: September 10, 2007, 23:08:53 PM »

it's some very good news, but they will open the drivers only for R500/R600 series

the best news for me (i've got some old card) is that the new driver seems to be suitable (i don't find the word : "is not shit" as it was) and will integrate AIGLX soon (i've dreamt about it for a very long time)

Night, I am so glad, you are the first people i've helpt in my new linux life Cheesy
but do you have any freeze ? I've got some but i don't know where it comes
Logged
Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #8 on: September 11, 2007, 16:42:17 PM »

Works fine except that cant make compiz work...
Logged

Kavani
Guest
« Reply #9 on: September 11, 2007, 18:33:27 PM »

Check your xorg.conf.  See if you have 3d support and this line in it:
Code:
Section "Extensions"
    Option "Composite" "enable"
EndSection

Type compiz in Konsole and it might tell you that you're missing files.  You might have to edit your path via your /etc/profile.env file by adding this line at the end of it:
Code:
export LD_LIBRARY_PATH=/usr/lib

Hopefully that'll work.
Logged
Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #10 on: September 11, 2007, 20:31:20 PM »


(core) - Fatal: GLX_EXT_texture_from_pixmap is missing
(core) - Error: Failed to manage screen: 0
(core) - Fatal: No manageable screens found on display :0.0

tried that too...   compiz just wont start...
Logged

Zinden
Pardus Master
***
Gender: Male
Posts: 167


www.Pardus-linux.se


View Profile WWW
« Reply #11 on: September 11, 2007, 20:39:52 PM »

Dont he need GLX session for ATI cards to ba able to use ATI drivers with compiz?
Logged

Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!