Welcome, Guest. Please login or register.
April 24, 2014, 11:05:23 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  General
| |-+  Wish list
| | |-+  Grub menu - add recovery mode
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: Grub menu - add recovery mode  (Read 3549 times)
Zinden
Pardus Master
***
Gender: Male
Posts: 167


www.Pardus-linux.se


View Profile WWW
« on: September 06, 2007, 18:39:44 PM »

Would be great to have a line that you can start the computer in textmode too.
not only pardus regular....

I think this would be high priority, if you fucked up pardus then you cant enter pardus...if you are new in linux.
Logged

Willem
M.D.
Administrator
Pardus Guru
*****
Gender: Male
Posts: 1020



View Profile WWW
« Reply #1 on: September 06, 2007, 18:59:48 PM »

If you are new to Linux, you wont have any advantage in entering Pardus in the Text-mode, since you are not used to the commands, however I agree that there should be an easy option to boot Pardus in text mode only
Logged

For freedom...
Lloyd De Jongh
Newbie
*
Gender: Male
Posts: 23


View Profile
« Reply #2 on: September 09, 2007, 19:44:46 PM »

Would be great to have a line that you can start the computer in textmode too.
not only pardus regular....

Pardus is a Desktop system, rather than a server-based distribution. I would imagine a server-oriented version would have a different approach and follow the standard whereby servers generally have Gnome/KDE disabled or removed and init 3 being default run level.

That being said, is there any info on the Pardus init system? I am not referring to Mudur's boot-up scheme, but rather the run-levels as in init 5 and init 3. I don't have my laptop here with me for reference but it didn't look like the inittab had too much in common with RH.

Logged

"In theory, there is no difference between theory and practice. But, in practice, there is." -- Jan L.A. van de Snepscheut
Zinden
Pardus Master
***
Gender: Male
Posts: 167


www.Pardus-linux.se


View Profile WWW
« Reply #3 on: September 10, 2007, 08:21:14 AM »

like just 5 mins ago...i installed ati drivers. just as i always done. And im pretty good to get those drivers in.
what happened?
Well, black screen when i was just getting to see the login screen.
What now? i cant change from fglrx drivers to ati again, as i cant go into textmode somehow....as i dont know how now.
But that would work if i had recovery mode to enter and change back the driver in xorg........


But for me i could put in my nvidia card and boot it up and change driver....thank god.


This is just 1 issue i want to get solved.
« Last Edit: September 10, 2007, 21:26:19 PM by Zinden » Logged

Kavani
Guest
« Reply #4 on: September 11, 2007, 11:55:55 AM »

No it's different, my inittab tells me that Pardus starts in init 3 not init 5.  Which I thought was odd, but it works.  The login and KDE come up like they should.
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #5 on: September 11, 2007, 12:44:53 PM »

There doesn't seem to be a difference between runlevels 3 through 5 with Pardus.

(taken from /etc/inittab, the defaulr runleven being 3):

Code:
# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/mudur.py boot

l0:0:wait:/sbin/mudur.py shutdown
l1:S1:wait:/sbin/mudur.py single
l2:2:wait:/sbin/mudur.py nonetwork
l3:3:wait:/sbin/mudur.py default
l4:4:wait:/sbin/mudur.py default
l5:5:wait:/sbin/mudur.py default
l6:6:wait:/sbin/mudur.py reboot
#z6:6:respawn:/sbin/sulogin

If you want the system to boot into text mode, use either 1 or 2. However you might have to start any daemons that you need manually, since they won't come up automatically in that case.

I'm looking forward to the Pardus server version which should be due out by the end of the year / early 2008 as I've heard.
Logged
Zinden
Pardus Master
***
Gender: Male
Posts: 167


www.Pardus-linux.se


View Profile WWW
« Reply #6 on: September 16, 2007, 16:07:26 PM »

here is my boot line:
Code:
root=/dev/hdc1 video=vesafb:nomtrr,pmipal,ywrap,1024x768-32@60 splash=silent,fadein,theme:pardus console=tty2 mudur=language:en quiet resume=/dev/sda5

How can i make it to start in textmode only without booting X?
Logged

Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #7 on: September 16, 2007, 19:13:28 PM »

i agree on the recovery mode it is sure needed.
i have had troubles in many distros installing ati drivers and the only thing that saves me from reinstall the whole distro is recovery mode.

but as for pardus i doubt it would help me as i cant even see console with ctrl + alt + F2 its a black screen with that everytime no matter if i have ati drivers installed or not. (works fine on sabayon and ubuntu)

but for other ppl with similiar graphics driver installation issues the recovery mode would be a big help.
Logged

roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #8 on: September 17, 2007, 07:16:50 AM »

Zinden,

you make the system boot into text mode by setting the runlevel in /etc/inittab as described above.
Logged
Zinden
Pardus Master
***
Gender: Male
Posts: 167


www.Pardus-linux.se


View Profile WWW
« Reply #9 on: September 17, 2007, 07:56:14 AM »

There must be another way than change in file initab?
Logged

roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #10 on: September 17, 2007, 08:12:43 AM »

Grub is for loading the kernel and setting boot parameters like framebuffer mode, (no-)dma and so on.
The init-system takes care of what happens *after" that, e.g.  if X should be started or not and what other services / daemons should run automatically.
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #11 on: September 17, 2007, 08:32:25 AM »

Ah, just thought of something...

If you do this (as root)

Code:
service kdebase off

you will effectively prevent kde (and thus X) from starting automatically in the future.
This way you will boot to a text console.
« Last Edit: September 17, 2007, 08:35:56 AM by roverrat » Logged
Zinden
Pardus Master
***
Gender: Male
Posts: 167


www.Pardus-linux.se


View Profile WWW
« Reply #12 on: September 17, 2007, 08:39:42 AM »

the pardus developer told me that maybe "xorg=false" can do the trick to add in grub line.....
or was it "xorg=off" ?
Atleast there seems to be a way to create a boot manager that will only start in textmode.
Logged

roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #13 on: September 17, 2007, 08:55:48 AM »

Aha, that sounds promising  Smiley I'll have a try with "xorg=off" and see if it does what it promises to do  Wink
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #14 on: September 17, 2007, 10:20:51 AM »

Yes, it does indeed  Smiley

After adding xorg=off to Pardus' kernel line in grub.conf my system now starts in text mode.
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!