Welcome, Guest. Please login or register.
April 16, 2014, 18:05:23 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  Need Help configuring Tablet PC
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Need Help configuring Tablet PC  (Read 1228 times)
stormbolter
Newbie
*
Posts: 3


View Profile
« on: November 19, 2007, 23:01:00 PM »

I have a TC1100 and Pardus 2007.3 detected and configured correctly most of the hardware. The main exception is the wacom tablet that is integrated in this laptop.

Tutorials on the web ask for modprobing wacom-acpi and wacom modules, but pardus doesn't have wacom-acpi. Any idea on how to proceed?
Logged
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #1 on: November 20, 2007, 06:04:24 AM »

Pardus has wacom module by default install, all you have to do is to configure your xorg.conf. Here's a tutorial:
http://www.shallowsky.com/linux/wacom.html
Logged
stormbolter
Newbie
*
Posts: 3


View Profile
« Reply #2 on: November 20, 2007, 22:15:19 PM »

I beg to differ. Altought the wacom module is present, is not currently usable. Trying to modprobe the wacom module results in an error, and I found the following lines in the xorg log:

(EE) Failed to load module "wacom" (module does not exit, 0)
(EE) No Input driver matching 'wacom'

Anything I can provide to help solving this problem?  Wink

Thanks for the fast reply!

NOTE: The only distro that succesfully detected and configured my tablet was Ubuntu (Freespire too, but is Ubuntu based). I cannot reproduce the configuration, as they create a /dev/input/wacom. Also they seem to detect more serial ports.
Logged
stormbolter
Newbie
*
Posts: 3


View Profile
« Reply #3 on: November 20, 2007, 22:48:30 PM »

I downloaded the latest linuxwacom package and manually copied the following files:
/prebuilt/32/wacom_drv.o to /usr/lib/xorg/modules/input/
/prebuilt/32/wacom_drv.so to /usr/lib/xorg/modules/drivers/

Note that automatic configuration won't work. At least in my case it didn't.

More Info:
xorg.conf Modifications
Add the following Lines to /etc/X11/xorg.conf
in Section "module"
     Load "wacom"

in its own sections:

Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/ttyS0" // NOTE: It may vary in your laptop, is different from distro to distro
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4"
    Option "Mode" "Absolute"
    Option "Button2" "3"
EndSection

Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/ttyS0"
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4"
    Option "Mode" "Absolute"
    Option "Button2" "3"
EndSection

Finally, in ServerLayout
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "stylus" "SendCoreEvents"



Configuring the GIMP
First of all, figure out where it is  Cheesy  for some reason GIMP is not in my programs menu, so I accessed it through command Line: gimp

Open "File"/"Preferences" (it may be different, mine is in Spanish). Section "input devices", click on "Configure Extended Input Devices". Select Device "stylus" and change its status from "disabled" to "screen". That will enable pressure sensitivity.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!