Welcome, Guest. Please login or register.
April 20, 2014, 19:34:51 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  enabling compiz
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: enabling compiz  (Read 2399 times)
pettersolberg
Newbie
*
Gender: Male
Posts: 28


View Profile
« on: October 22, 2007, 14:53:37 PM »

Hi,
I've installed following this: http://tr.pardus-wiki.org/NASIL:Compiz_Fusion_Kurulumu
It managed on my i810 laptop and it does "just-so-well".
During the install though, I've must have done something wrong, because it doesn't start automatically with the system. KWin is disabled, and I have to start compiz manually.
How to enable compiz to launch automatically?
Any help?
Thanks
Logged
Kavani
Guest
« Reply #1 on: October 22, 2007, 18:05:15 PM »

I don't think it's you petters.  I've got the same problem on my i945.  I've a question for you.  Is you driver "None" or "intel"?  Mine is "None" although intel is in my xorg.conf file.  Fresh install last night.
Logged
Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #2 on: October 22, 2007, 21:02:03 PM »

Code:
  Vendor:  Intel Corporation
  Model:   82852/855GM Integrated Graphics Device
  Driver:   i810 (3D Support)

i cant start compiz autom. either but i dont even want to as it dont run so well  Smiley
Logged

Kavani
Guest
« Reply #3 on: October 22, 2007, 23:10:08 PM »

Maybe we can find the intel driver from source?  Tongue  Or try recompiling compiz.
Logged
pettersolberg
Newbie
*
Gender: Male
Posts: 28


View Profile
« Reply #4 on: October 23, 2007, 12:41:36 PM »

In addition to the above problem, some icons which should appear in the system tray, beside the clock, are floating on the screen (in small windows).

Those are the "KPowersave",  "klipper" and "pisi" icons, while the Network applet and Kadu (a polish IM client) are OK.

A strange issue.
Logged
Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #5 on: October 23, 2007, 20:36:14 PM »

an easy way to start compiz and other apps is to install "autostart" or was it in Tasma extras.
anyway it installs new options in Tasma like Autostart for kde.
There you just add the app you want to start on login.  Wink
Logged

Kavani
Guest
« Reply #6 on: October 23, 2007, 20:42:42 PM »

I think autostart is there from the start.  My autostart problems are either not starting or freezing the computer.   Huh?  Oh well.  Tongue
Logged
Night
Pardus fellow craft
**
Posts: 45


View Profile
« Reply #7 on: October 23, 2007, 20:49:49 PM »

Well i think that is just the Great and powerful Intel graphics card  Grin
Logged

Kavani
Guest
« Reply #8 on: October 25, 2007, 05:05:43 AM »

Too funny!
Logged
pettersolberg
Newbie
*
Gender: Male
Posts: 28


View Profile
« Reply #9 on: October 25, 2007, 08:20:42 AM »

It seems that running fusion-icon does the job: it let's you change the window manager either kwin or compiz, and the changes last.

You can put this,  to have fusion-icon run automagically with every KDE start:

cd ~/.kde/Autostart
ln -s /usr/bin/fusion-icon

Cheers
Logged
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #10 on: November 01, 2007, 13:57:26 PM »

I just translated above page to English. Feel free to improve it Smiley
http://en.pardus-wiki.org/HOWTO:Compiz_Fusion
Logged
Kavani
Guest
« Reply #11 on: November 01, 2007, 14:08:32 PM »

Thanks jnmbk!
Logged
jaideep_jdof
Pardus fellow craft
**
Gender: Male
Posts: 104



View Profile
« Reply #12 on: November 01, 2007, 21:14:54 PM »

With compiz fusion when i play any movie, the audio is there but no video. I have installed compiz using the above howto and installed all the package except for unsupported plugins.

And another problem, I have two virtual desktops enabled, but with compiz it becomes 8.
Logged
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #13 on: November 02, 2007, 06:42:36 AM »

With compiz fusion when i play any movie, the audio is there but no video. I have installed compiz using the above howto and installed all the package except for unsupported plugins.

And another problem, I have two virtual desktops enabled, but with compiz it becomes 8.
You need to do some tricks to have the video:
For kaffeine:
*Go to Options>xine engine parameters>video
*select xshm as driver
For MPlayer
* Right click the movie and select Tercihler>Video
* Select (Ximage/shm) here.
Now the video should work as expected.

Compiz doesn't really create 8 virtual desktops. After exitting compiz click 5th desktop and click 1st desktop again. New desktops should disappear after doing that.
Logged
jaideep_jdof
Pardus fellow craft
**
Gender: Male
Posts: 104



View Profile
« Reply #14 on: November 02, 2007, 13:56:41 PM »

How do I restrict this virtual desktop creation to 4. Your trick for virtual desktops didn't work. Hey one more thing, firefox feels bit choppy.
« Last Edit: November 02, 2007, 14:01:32 PM by jaideep_jdof » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!