Welcome, Guest. Please login or register.
April 19, 2014, 09:08:23 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  can not connect to repository - same old problems
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: can not connect to repository - same old problems  (Read 3316 times)
baboo
Guest
« on: November 03, 2007, 01:10:40 AM »

Same old problem: check your network connection and try again.

I've been using slackware 12 for the last 5 months. What a stable OS. But I've been working on it as a server. So, up at work I told alot of people about pardus and we all downloaded 2007.2 and installed.

Every single install had the same issue. After installation, even though networking is enabled and working you can not connect to repositories. No, there is no proxy involved. Straight through on to internet.

We tried pisi rdb. Nada

I posted here back in the spring about this same problem and no one responded with a solution. It is very hard for me to believe that if we are experiencing this problem - then there must be quite a few out there.

Has anyone heard of a solution?

and why don't they fix this?
Logged
Kavani
Guest
« Reply #1 on: November 03, 2007, 05:12:31 AM »

I'm not sure if anyone is having any issues with the repos at the moment.  Can you post the addresses of your repos?
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #2 on: November 03, 2007, 07:56:00 AM »

Weird, the problem may be caused by DNS adresses. Do you use custom DNS adress? Please post the output of below commands;

Code:
cat /etc/resolv.conf
Code:
pisi lr

Remember that "rebuild-db (rdb)" is not generally used, if you come across some problem, don't try rebuilding pisi database. It's only used when database version is changed. Of course, there won't be any problem if you rebuild database, but it's only wasting time Smiley
Logged
baboo
Guest
« Reply #3 on: November 04, 2007, 15:04:37 PM »

I am using the repo that comes standard with the install:

http://paketler.pardus.org.tr/pardus-2007.2/pisi-index.xml.bz2

/etc/resolv.conf:
installer@pardus ~ $ cat /etc/resolv.conf
nameserver 192.168.0.1
nameserver 205.171.3.65

pisi lr:p
http://paketler.pardus.org.tr/pardus-2007.2/pisi-index.xml.bz2

First, let me say thanks for the repsonses. That actually comes as a pleasant surprise.

I am not doing anything custom. Since January I have installed Pardus over a hundred times. No matter whose machine I have a problem with connecting to repo and get the timed out error message. The only thing I have found that works, and this is really lame, is to re-install Pardus 2-3 times and usually after one of the installs it takes. Then I can connect to repo. The problem is after a reboot I might loose it again.

I have posted in the past many times. Others have said they are having similiar problems that sometimes it works and other times it doesn't. So, it becomes frustrating.

I really appreciate you two taking the time to respond. I am always open to suggestions.

thanks
Logged
Kavani
Guest
« Reply #4 on: November 05, 2007, 13:40:30 PM »

Here is a post from Eren about the addresses.  You just need to remove the .2 from pardus-2007.2.  Good luck!

2007


2007-test


Contrib


These are official repositories, I don't know mirrors, I think Willem knows mirror adresses, Willem?

Note that, please use 2007 or 2007-test as main repository, you can't use both. You can add 2007 and Contrib or 2007-test and Contrib.
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #5 on: November 05, 2007, 14:43:39 PM »

No, you don't need to remove .2, pardus-2007.2 or pardus-2007 repositories are the same. That was an old post  Smiley

Again, it seems that this is a DNS problem and you're not using Pardus's default dns adresses. Could you enter commands below with root privileges and retry connecting repository?

Code:
echo 'nameserver 193.140.100.210' > /etc/resolv.conf
echo 'nameserver 193.140.100.215' >> /etc/resolv.conf
echo 'nameserver 193.140.100.220' >> /etc/resolv.conf
Logged
baboo
Guest
« Reply #6 on: November 05, 2007, 19:24:02 PM »

thanks kavani and eren:

I removed the .2 and now repo works. I don't know why my search of forums failed to turn up that tidbit.

thanks again for your help
Logged
Eren.Turkay
Global Moderator
Pardus Master
*****
Posts: 262



View Profile WWW
« Reply #7 on: November 06, 2007, 04:12:28 AM »

Ops?? Just removing .2 from repository and add new "pardus-2007" repository solves your problem? Or you have entered the command I wrote? If you did former, it maybe a bug in Pardus servers. Could you write an output of commands below?

Code:
pisi lr
cat /etc/resolv.conf
Logged
Bandito
Pardus fellow craft
**
Posts: 50


View Profile
« Reply #8 on: November 06, 2007, 10:28:40 AM »

Hello!

I also have similar problems just like baboo. The difference is, I`m living in a campus like facility (30 rooms) and I think I`m connected trough router. Pardus firewall is also on with no exceptions.
When I try to install/update/uninstall any package the progress box just dissapears afer a couple of seconds and nothing happens.

My other computer at home, does not have that kind of problems at all and works perfectly, but there is no router involved.

I solved most of applications issues by compiling applications from source. The only thing that is giving me trouble is amsn, I use kopete instead but I still prefer amsn.


pingo@pingvinmaschin ~ $ pisi lr
pardus-2007.2
   http://paketler.pardus.org.tr/pardus-2007.2/pisi-index.xml.bz2
Contrib
   http://packages.pardus.org.tr/contrib-2007/pisi-index.xml.bz2
pingo@pingvinmaschin ~ $ cat /etc/resolv.conf
nameserver 193.140.100.210
nameserver 193.140.100.215
nameserver 193.140.100.220
pingo@pingvinmaschin ~ $

Any help is appreciated

Regards, Bandito
« Last Edit: November 06, 2007, 10:36:18 AM by Bandito » Logged
Kavani
Guest
« Reply #9 on: November 06, 2007, 14:59:21 PM »

Hey Bandito, are the results of pisi lr the same on both computers?
Logged
Bandito
Pardus fellow craft
**
Posts: 50


View Profile
« Reply #10 on: November 06, 2007, 17:43:42 PM »

yes, the results of pisi lr match for sure, but for the results of /etc/resolv.conf i can`t say for sure becouse I`m not at my primary address at the moment.
Logged
Kavani
Guest
« Reply #11 on: November 06, 2007, 17:46:26 PM »

All I can say is try baboo's fix, but let us know.  We might have a bug in the making.   Tongue
Logged
Bandito
Pardus fellow craft
**
Posts: 50


View Profile
« Reply #12 on: November 06, 2007, 17:56:05 PM »

baboos fix unfortunately didn`t work for me neither did rebulid-db command.

pingo@pingvinmaschin ~ $ su
Password:
pingvinmaschin pingo # pisi install amsn
A database operation has been aborted. You should run pisi
again for normal DB recovery procedure. Make sure you have free disk space.
You have to run rebuild-db only when there is file corruption and database upgrades.
(-30978, 'DB_RUNRECOVERY: Fatal error, run database recovery -- PANIC: DB_RUNRECOVERY: Fatal error, run database recovery')
Please use 'pisi help' for general help.
Use --debug to see a traceback.
pingvinmaschin pingo # pisi rebuild-db --debug
DEBUG: PiSi API initialized
Rebuild PiSi databases? (yes/no)y
A database operation has been aborted. You should run pisi
again for normal DB recovery procedure. Make sure you have free disk space.
You have to run rebuild-db only when there is file corruption and database upgrades.
bsddb3.db.DBRunRecoveryError: (-30978, 'DB_RUNRECOVERY: Fatal error, run database recovery -- PANIC: DB_RUNRECOVERY: Fatal error, run database recovery')
Please use 'pisi help' for general help.
Use --debug to see a traceback.
DEBUG: PiSi API finalized
pingvinmaschin pingo #                     

I don`t think it is a bug, maybe it has someting to do with the router settings.
Logged
Kavani
Guest
« Reply #13 on: November 06, 2007, 18:04:55 PM »

Well we can try a mirror of the repo and see if the router won't block it.

Hello,

I've found following mirrors of the official Pardus repository and would like to share them with you. I presume you know how to add them to your system.

regards
H.E.


USA mirrors:
---------------
http://paketler.pardusdepo.org/pardus-2007/pisi-index.xml.bz2


DUTCH mirrors:
-------------------
http://ftp.nluug.nl/pub/os/Linux/distr/pardusrepo/2007/pisi-index.xml.bz2

http://ftp.surfnet.nl/pub/os/Linux/distr/pardusrepo/2007/pisi-index.xml.bz2
Logged
Bandito
Pardus fellow craft
**
Posts: 50


View Profile
« Reply #14 on: November 06, 2007, 18:21:05 PM »

I did add all 3 of them just like I added the contrib afer the fresh install.

this is what I get out of pisi lr

pingo@pingvinmaschin ~ $ pisi lr
pardus-2007.2
   http://paketler.pardus.org.tr/pardus-2007.2/pisi-index.xml.bz2
Contrib
   http://packages.pardus.org.tr/contrib-2007/pisi-index.xml.bz2
pingo@pingvinmaschin ~ $

I also restarted the pc, just like in windows, but I was shocked becouse after the login, the 3 fresh added repos were completely gone, also from package manager gui.

Ty Kavani for all your help

Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!