Welcome, Guest. Please login or register.
April 17, 2014, 23:38:43 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  internal mic doesn't work
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: internal mic doesn't work  (Read 1641 times)
highenergy
Pardus fellow craft
**
Gender: Male
Posts: 134


View Profile
« on: November 18, 2007, 16:13:41 PM »

Hello,

I have a notebook which has a build-in cam&mic. Cam started to work after installing linux-uvc driver package. But microphone still doesn't work. Anyone having same difficulty?

regards
H.E.
Logged

Acer Aspire 5520G-402G16, AMD Turion 64 x2 TL-58 1.9GHz, Nvidia Geforce 8400M G 128MB
Willem
M.D.
Administrator
Pardus Guru
*****
Gender: Male
Posts: 1020



View Profile WWW
« Reply #1 on: November 18, 2007, 21:33:52 PM »

My internal mic is also not woking (Acer Aspire 3680)
Logged

For freedom...
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #2 on: November 20, 2007, 06:13:40 AM »

Did you select mic in KMix? And there's also another configuration in TASMA Sound settings. Select Full duplex from hardware tab. If those don't work, we should look into dmesg command output...
Logged
highenergy
Pardus fellow craft
**
Gender: Male
Posts: 134


View Profile
« Reply #3 on: November 20, 2007, 19:41:51 PM »

Did you select mic in KMix? And there's also another configuration in TASMA Sound settings. Select Full duplex from hardware tab. If those don't work, we should look into dmesg command output...

I have checked these settings you told about too. Nothing happens. Full duplex was selected in default. I am attaching dmesg output. I wish it helps.


regards
H.E.

* dmesg.txt (23.73 KB - downloaded 72 times.)
Logged

Acer Aspire 5520G-402G16, AMD Turion 64 x2 TL-58 1.9GHz, Nvidia Geforce 8400M G 128MB
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #4 on: November 21, 2007, 03:35:26 AM »

I found two links about it, hope they help:
http://wiki.kainhofer.com/kubuntuonaceraspire5630
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/127588
Logged
highenergy
Pardus fellow craft
**
Gender: Male
Posts: 134


View Profile
« Reply #5 on: November 21, 2007, 17:40:02 PM »

Well I tried alsamixer trick before but it didn't work :'(. Today I have tried again alsamixer trick and this time it worked  Shocked. I now understand that In order to get sound from internal mic

1- Set     "CAPTURE" from alsamixer cmd line utility.
2- Unset "CAPTURE" from Kmix Input tab.
3- Select  "Front Mic" but not  "Mic" from Kmix keys tab.

When I did these things I could record sound from KRec.

regards
H.E.
« Last Edit: November 21, 2007, 18:32:58 PM by highenergy » Logged

Acer Aspire 5520G-402G16, AMD Turion 64 x2 TL-58 1.9GHz, Nvidia Geforce 8400M G 128MB
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!