Welcome, Guest. Please login or register.
April 21, 2014, 16:43:12 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  [Solved] How to read a midi file ?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [Solved] How to read a midi file ?  (Read 2611 times)
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« on: January 20, 2008, 14:36:19 PM »

Hello,

My Pardus 2007.3 fails to open a midi file.

First attempt with timidity :
Code:
timidity cgam.mid
current/timidity.cfg: No such file or directory
timidity: Can't read any configuration file.
Please check /usr/share/timidity/timidity.cfg

Second attempt with Kmid.
Error message : "cannot open /dev/sequencer. Another program may be using it."
In order to know what program was using /dev/sequencer, I used fuser :
Code:
fuser /dev/sequencer
Cannot stat /dev/sequencer: No such file or directory

KInfoCenter informs me that Mixer is not enabled and Audio, Midi and Synth devices are not enabled in alsa config

[additionnal informations]
sound driver : alsa 1.0.15
sound modules : snd_hda_intel (snd_hda_intel, snd_pcm, snd_timer, snd_hwdep)
sound chipset : HDA Intel
Midi devices : none

« Last Edit: March 08, 2008, 18:32:02 PM by PhiX » Logged

Team Pardus-fr - French Pardus tools translator
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #1 on: January 21, 2008, 20:20:23 PM »

Try starting timidity service first:
Go to TASMA>System>Service Manager then start timidity
Then go to Sound System settings in TASMA and choose timidity as midi device
« Last Edit: January 21, 2008, 20:25:07 PM by jnmbk » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #2 on: January 22, 2008, 15:29:38 PM »

I started timidity in Service Manager, but couldn't choose timidity as midi device because the "Select the Midi device" list was empty for some reason.

Nevertheless, timidity now plays midi files successfully Smiley
Thank you jnmbk !

The next thing, will be to configure Kmid, which complains that /dev/sequencer cannot be opened because another program is using it.
Maybe timidity and Kmid cannot be used at the same time ?
The strange thing is that there is no such file as /dev/sequencer, even in /dev/snd/*.
Logged

Team Pardus-fr - French Pardus tools translator
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #3 on: March 08, 2008, 18:31:35 PM »

Quote
The strange thing is that there is no such file as /dev/sequencer, even in /dev/snd/*.

I got an explanation for this.
Special device files used by ALSA and those used by OSS are actually different. The special device file /dev/sequencer is related to an OSS configuration, not to an ALSA's like mine.
Logged

Team Pardus-fr - French Pardus tools translator
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!