Welcome, Guest. Please login or register.
April 24, 2014, 10:59:54 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  X Server randomly won't start with Intel 945GM
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: X Server randomly won't start with Intel 945GM  (Read 807 times)
CaptainCookie
Pardus fellow craft
**
Posts: 93


View Profile WWW
« on: February 01, 2009, 20:57:39 PM »

Hi,

I have mentioned this before in an old topic, but with the upcoming release of 2008.2 I hope there is a solution for this yet.

If I boot my laptop (Toshiba Satellite A100) with an Intel 945GM graphics chip, the X server randomly won't start. I'm left with a blinking cursor, without any error messages. I guess there will be a log file somewhere, but I don't know where.

This problem exists since 2008.0; 2008.1 didn't solve anything and 2008.2 beta stopped the X server from crashing while it was already running, so it's a start Tongue

I noticed that I have a really better chance of getting the X server to start if I select 'Opnieuw koppelen' (Dutch) in the GRUB menu with F3, which is the 3th option, next to 'Standard' and 'Failsafe'

Does anyone have a solution?  Undecided
Logged

PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #1 on: February 01, 2009, 21:51:12 PM »

According to this bug report, it could be related to cpufreq.
http://bugs.pardus.org.tr/show_bug.cgi?id=7659
Logged

Team Pardus-fr - French Pardus tools translator
tuxedup
Pardus Developer
Pardus fellow craft
*****
Gender: Male
Posts: 65



View Profile
« Reply #2 on: February 07, 2009, 03:41:42 AM »

Indeed it is.  Cpufreq screws things up for me.

Adding    Option "FramebufferCompression" "false"   to device section of xorg.conf fixes things;

sudo nano /etc/X11/xorg.conf

look for [device]

add the line to the bottom of the section.

Press ctrl x and enter y followed by enter.

Now reboot and you should be ok.
Logged

Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!