Welcome, Guest. Please login or register.
April 17, 2014, 00:04:14 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  [solved]Nvidia Graficcard 7050
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [solved]Nvidia Graficcard 7050  (Read 2604 times)
Andreas
Guest
« on: May 10, 2008, 07:14:36 AM »

Hello,

I have a problem to configurate my Nvidia Graficcard 7050.

All the Nvidia-Package, which I found in the Paketmanager, doesn`t work.

Here the output of the xorg.conf , with which the X-Server doesn`t start:

Quote
Section "Device"

    # BusID      "PCI:0:18:0"
    Identifier     "VideoCard0"
    Driver         "nvidia"
    VendorName     "None"
    BoardName      "None"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "VideoCard0"
    Monitor        "Monitor0"
    DefaultDepth    16
    Option         "AllowGLXWithComposite" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DamageEvents" "True"
    Option         "DynamicTwinView" "False"
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Greetings
Andreas


* Nvidia.png (97.34 KB, 1024x768 - viewed 50 times.)
« Last Edit: May 13, 2008, 13:50:29 PM by Andreas » Logged
Andreas
Guest
« Reply #1 on: May 10, 2008, 07:41:32 AM »

Hello,

with the following xorg.conf the Nvidia Graficcard works, but I have not 3D-Effects.

Quote
Section "Device"
    Screen 0
    Identifier "VideoCard0"
    Driver     "vesa"
    VendorName "None"
    BoardName  "None"
    # BusID      "PCI:0:18:0"
EndSection

Greetings
Andreas


Logged
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #2 on: May 10, 2008, 10:41:50 AM »

I suggest removing all nvidia drivers you installed and only install nvidia-tools-new package with its dependencies. Then if you remove /etc/X11/xorg.conf, Pardus will create a new one using installed nvidia drivers for you. (remove it with sudo rm /etc/X11/xorg.conf then restart X with CTRL+ALT+BACKSPACE)
Logged
Andreas
Guest
« Reply #3 on: May 10, 2008, 12:17:32 PM »

I suggest removing all nvidia drivers you installed and only install nvidia-tools-new package with its dependencies. Then if you remove /etc/X11/xorg.conf, Pardus will create a new one using installed nvidia drivers for you. (remove it with sudo rm /etc/X11/xorg.conf then restart X with CTRL+ALT+BACKSPACE)

That was not a good idea. After I have done it so, the X-Server doesn`t startet enymore and I must install Pardus new.

Greetings
Andreas
« Last Edit: May 10, 2008, 12:23:28 PM by Andreas » Logged
Andreas
Guest
« Reply #4 on: May 11, 2008, 16:35:54 PM »

Hello,

can someone post his xorg.conf here, when one has a Nvidia-Graficcard.

Thanks.
Andreas
« Last Edit: May 11, 2008, 16:40:08 PM by Andreas » Logged
Andreas
Guest
« Reply #5 on: May 12, 2008, 10:08:05 AM »

This is my VGA-Controller:

Quote
VGA compatible controller nVidia Corporation nVidia Corporation 12
pci@0000:00:12.0 a2 64 66000000       Power Management Message Signalled
Interrupts VGA graphical framebuffer bus mastering PCI capabilities listing   
Host bridge K8 [Athlon64/Opteron]

The Graficcard works only with vesa but they must also run with the
nvidia-drivers.

When I installed the nvidia-drivers, the Card doesn`t work and the X-Server
doesn`t started.

Greetings
Andreas
Logged
Andreas
Guest
« Reply #6 on: May 12, 2008, 16:04:22 PM »

Hello,

the Graficcard runs only with vesa-driver, what I don` t understand. Shocked

Greetings
Andreas
Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #7 on: May 12, 2008, 21:30:01 PM »

It should be better with "nv" instead of "vesa" in your xorg.conf file. You will get full 2D and a minimal 3D.

To have full 3D support, with "nvidia" in xorg.conf, you have to install the following packages :

  • nvidia-glx-new
  • nvidia-kernel-new
« Last Edit: May 12, 2008, 21:39:57 PM by PhiX » Logged

Team Pardus-fr - French Pardus tools translator
Andreas
Guest
« Reply #8 on: May 13, 2008, 07:25:34 AM »

It should be better with "nv" instead of "vesa" in your xorg.conf file. You will get full 2D and a minimal 3D.

To have full 3D support, with "nvidia" in xorg.conf, you have to install the following packages :

  • nvidia-glx-new
  • nvidia-kernel-new

Hello,

that all tried, but than the X-Server doesn`t started.

Greetings
Andreas
Logged
Andreas
Guest
« Reply #9 on: May 13, 2008, 13:52:55 PM »

Hello,

I have installed today nvidia-glx-new, nvidia-kernel-new and nvidia-tools-new and now 3D runs.

This is now my xorg.conf:

Quote
Section "Device"

    # BusID      "PCI:0:18:0"
    Identifier     "VideoCard0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "Nvidia Geforce 7050"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "VideoCard0"
    Monitor        "Monitor0"
    DefaultDepth    16
    Option         "AllowGLXWithComposite" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DamageEvents" "True"
    Option         "DynamicTwinView" "True"
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

I am happy. Smiley

Greetings
Andreas
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!