Welcome, Guest. Please login or register.
April 17, 2014, 18:44:30 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Bugs
| | |-+  Skype
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Skype  (Read 3477 times)
caber
Pardus fellow craft
**
Gender: Male
Posts: 85



View Profile WWW
« on: June 12, 2008, 21:55:19 PM »

 Skype will not pick up sound from my mic . I'm running Pardus 2008 RC1 and skype_static-2.0.0.68 . Krec displays the same bug , but I don't think I've ever used it Wink . I've enabled duplex in Tasma's sound options , enabled extra features in the pulse audio settings , played with kmix and amixer . Nothing I do will work . The funny thing is that when mic boost is on I can hear feedback in my speakers , but somehow the sound is not getting any further .
Logged
klurig
Pardus fellow craft
**
Posts: 39


View Profile
« Reply #1 on: July 01, 2008, 01:16:32 AM »

Note: make sure to create the ~/.asoundrc file in home first!


First of all we have to make PulseAudio support dmix. edit /etc/pulse/default.pa. Comment out "load-module module-hal-detect". Then, uncomment the following:

Code:

load-module load-module module-alsa-sink ....
load-module module-alsa-source ...

Replace
Code:

load-module module-alsa-sink ...

with
Code
:

load-module module-alsa-sink device=dmix sink_name=output

Replace
Code:

load-module module-alsa-source ...

with
Code:


load-module module-alsa-source device=dsnoop

or
Code
:

load-module module-alsa-source source_name=input

whichever works for you.

Then open your asoundrc file. Add the following to the bottom:
Code:

pcm.skypeout
{
   type plug
   slave.pcm "dmix"
}
ctl.skypeout
{
   type hw
   card 0
}
pcm.skypein
{
   type plug
   slave.pcm "dsnoop"
}
ctl.skypein
{
   type hw
   card 0
}

Now kill PulseAudio and start it again. You may close the terminal using "exit" if you wish.
Code:

killall pulseaudio
pulseaudio &

Then, start Skype, and go to the Sound Devices section in the Options. Select for Sound Out and Ringing, the device called "skypeout". Select for Sound In, the device called "skypein"

This method works with all native ALSA programs which supported ALSA software mixing previously, as well as all programs which use PulseAudio. In other words, Skype AND Adobe Flash 9 work.

M.v.h

Max Klurig

pardus-linux.se

Administratör
PiSi
*****
Logged
berkus
Newbie
*
Posts: 9



View Profile
« Reply #2 on: April 23, 2009, 04:29:01 AM »

Good howto, thanks!
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!