Welcome, Guest. Please login or register.
April 21, 2014, 12:45:32 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  [solved]New Pardus user: ADSL - PPPoE help
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: [solved]New Pardus user: ADSL - PPPoE help  (Read 5003 times)
alvx
Guest
« on: June 28, 2008, 20:18:09 PM »

Hi, greetings from Brazil!

I just downloaded Pardus 2008 after seeing some good reviews on Distrowatch
Installation was a breeze e everything looked so fine that I though my ditro-hopping days were history.

But I've a very serious issue that would prevent me from using Pardus if I can't work around it:

I connect to internet via ADSL (PPPoE). I found no graphic tool for setting this up (sure Pardus suports other connection types graphicaly). So I've ended up in this forum to search the topics and found out the adsl-setup command line

well, to make a long story short:
- the super-user konsole crashes when I type my root password and press enter
- if I try to use the 'su' command in the regular konsole my root password is not accepted (don't ask me why)

thus, there's no way I could set my internet connection up so far

could someone give a little help on this?

thanks in advance
« Last Edit: June 29, 2008, 13:11:11 PM by Andreas » Logged
Andreas
Guest
« Reply #1 on: June 28, 2008, 20:27:15 PM »

Hello and welcome,

have you looked here

Greetings
Andreas
« Last Edit: June 28, 2008, 20:40:01 PM by Andreas » Logged
alvx
Guest
« Reply #2 on: June 28, 2008, 20:31:03 PM »

Hello, Andreas

Yes, I looked up that topic before posting but I couldn't follow the instructions because my konsole (super-user mode) crashes and the regular konsole does not accept my root pass as I mentioned previously
Logged
Andreas
Guest
« Reply #3 on: June 28, 2008, 20:38:55 PM »


regular konsole does not accept my root pass as I mentioned previously

Try it in the regular console with the command:

su -

and than your root-password

If it still does not work, write please a bug-report to http://bugs.pardus.org.tr/

Greetings
Andreas




Logged
Andreas
Guest
« Reply #4 on: June 28, 2008, 20:45:38 PM »

Hello,

have you done this during the installation:

Have you give during the installation youryself (as the regular user) superusers privileges)?
That's why sudo did nothing and su was not even possible in the Konsole (denied)


I think, that could be the problem.

Greetings
Andreas
« Last Edit: June 30, 2008, 06:35:44 AM by Andreas » Logged
Andreas
Guest
« Reply #5 on: June 28, 2008, 20:50:23 PM »

Is there anyway to do this without having to reinstall? :-)

Hello,

yes, that is possible Wink

You can restored it via Tasma > System > Users Managment and  check the checkbox " give systemadministrator privileges to this user"

Greetings
Andreas
Logged
alvx
Guest
« Reply #6 on: June 28, 2008, 21:02:19 PM »

ok, the 'su/sudo' problem was gone

but now, when I try to set up my connectio it says that I'm missing the rp-pppoe file
I can't retrieve it from the repos because I obviously have no internet connection. So, is there a direct link to this package so I can save it in my HD (I'm booting from WinXP right now) and then reboot from Pardus and install it by pointing it's location to the package manager?
Logged
Andreas
Guest
« Reply #7 on: June 28, 2008, 21:07:00 PM »


but now, when I try to set up my connectio it says that I'm missing the rp-pppoe file


Hello,

rp-pppoe pisi

Greetings
Andreas
Logged
alvx
Guest
« Reply #8 on: June 28, 2008, 21:41:10 PM »

hi there!

Sorry to keep bothering but I coudn't install the rp-pppoe file Sad
I used my pen drive to transfer it to /home/<username>/Downloads/pardus
I clicked on it and it warned me that I've chosen a package to install, I clicked ok and then ... nothing

then I clicke with my right button and select open woth package manager, the same thing happened as before.

so I opened the SU-terminal and tried the command pisi -D --home/<user>/Downloads/pardus it rp-pppoe-3.8-7-3.pisi

and it said that the directory or file does not exist

any tip?
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #9 on: June 28, 2008, 21:44:10 PM »

To start with according to me the syntax should read:

Code:
pisi it ..and then.. /path/to/file

so in your words:

Code:
pisi it -D --home/<user>/Downloads/pardus rp-pppoe-3.8-7-3.pisi

so the "it" should not be placed between the targetdirectory and the installerfile but follow right after the pisi command.

Whether this solves your problem I do not know, but this is what I noticed in your previous posting.

Furthermore following all downloads (from the web or an USB device) you will first have to make the donwloaded file executable by changing it's properties, perhaps that will do the trick for you?
« Last Edit: June 28, 2008, 21:47:27 PM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Andreas
Guest
« Reply #10 on: June 28, 2008, 22:06:30 PM »


I clicked on it and it warned me that I've chosen a package to install, I clicked ok and then ... nothing

then I clicke with my right button and select open woth package manager, the same thing happened as before.


About this problem I wrote a Bug-Report. Wink

Klick

Greetings
Andreas
Logged
alvx
Guest
« Reply #11 on: June 28, 2008, 22:08:46 PM »

Hi

well I was able to partially solve the syntax problem by coping the file to /var/cache/pisi/packages (after open konqueror as root)

then I configured pppoe stuff through the command lines and I proudly announce that I'm a new member of the Pardus Users Community! Cheesy

Now, one more question: how do I setup the connection o start at boot time (without the need to open the terminal and type pppoe-start)

Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #12 on: June 28, 2008, 22:12:39 PM »


Now, one more question: how do I setup the connection o start at boot time (without the need to open the terminal and type pppoe-start)



Perhaps via Tasma-Sysetm-Services Manager where you can select which services should start upon boottime (e.g. CUPS, Samba, Apache etcetc) ?

Congratulations that you managed to get online!
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Andreas
Guest
« Reply #13 on: June 28, 2008, 22:21:44 PM »


when I try to set up my connectio it says that I'm missing the rp-pppoe file


Hello,

about this problem I wrote a Bug too.  Wink

Klick

Greetings
Andreas
Logged
alvx
Guest
« Reply #14 on: June 28, 2008, 22:25:43 PM »

I coudn't find the option to start pppoe connection at startup via tasma, but I'm online now and already installing packages

I found Pardus to possibly be the best distro around but I hope developers will add a solution to adsl-pppoe users when '2009' comes out

thanks Andreas and Michiel for your help and patience
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!