Welcome, Guest. Please login or register.
April 20, 2014, 12:55:53 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  [solved]New Pardus user: ADSL - PPPoE help
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] Go Down Print
Author Topic: [solved]New Pardus user: ADSL - PPPoE help  (Read 5001 times)
Andreas
Guest
« Reply #15 on: June 28, 2008, 22:30:44 PM »


thanks Andreas and Michiel for your help and patience

Hello,

gladly done. Smiley

Can you please edit your first post as [solved] on the beginning of Subject.

Thanks an good work with Pardus 2008.

Greetings
Andreas
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #16 on: June 28, 2008, 22:38:22 PM »

Found this in an Ubuntu forum (https://help.ubuntu.com/community/ADSLPPPoE?highlight=(pppoe)) upon googling on " pppoe boot"  Perhaps you can do something with this?


In the terminal type:

Code:
sudo pppoeconf

A text-based menu program will guide you through the next steps, which are:

   1. Confirm that your Ethernet card is detected.
   2. Enter your username(provided by your ISP).
   3. Enter your password(provided by your ISP).
   4. If you already have a PPPoE Connection configured, you will be asked if it may be modified.
   5. Popular options: you are asked if you want the 'noauth' and 'defaultroute' options and to remove 'nodetach' - choose "Yes".
   6. Use peer DNS - choose "Yes".
   7. Limited MSS problem - choose "Yes".
   8. When you are asked if you want to connect at start up, you will probably want to say yes.
   9. Finally you are asked if you want to establish the connection immediately.

Once you have finished these steps, your connection should be working.

=================

Boot issues

If you find that you have to run pppoeconf each time you boot, you can try two things:

    *

      Edit /etc/network/interfaces as described here, so that that 'pppoe maintained' lines are before 'auto dsl-provider':
Code:
# added by pppoeconf
auto eth0
iface eth0 inet manual
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf

auto dsl-provider
iface dsl-provider inet ppp
provider dsl-provider
    * Failing that, edit /etc/rc.local, and before the last line ("exit 0"), add:

Code:
ifconfig eth0 up
pon dsl-provider


« Last Edit: June 29, 2008, 18:39:43 PM by Andreas » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Bahri16
Global Moderator
Pardus Master
*****
Posts: 208



View Profile
« Reply #17 on: June 29, 2008, 01:33:09 AM »

for aditional information.

you can configure your pppoe also with a programm which has a GUI and where you dont have to be su or sudo to start the connection. this programm creates also a menuitem. is really comfortable.
you can find it here.

http://www.roaringpenguin.com/products/pppoe
« Last Edit: June 29, 2008, 18:39:54 PM by Andreas » Logged

The world is not digital - the world is an analog swoosh
Bandito
Pardus fellow craft
**
Posts: 50


View Profile
« Reply #18 on: June 29, 2008, 10:14:23 AM »

I`m another adsl user who had the same problems regarding internet connection.

After reading trough the tread i saw that some things changed again :S (su-), on top of all rp-pppoe pisi isn`t included in pardus package installation process. It is true that majority of users don`t use adsl anymore but still there are few that need pppoe pisi to get internet connection going. From new user point of view this can be a very important aspect especially if this user doesn`t use dual boot with windows, he is basically left in the dark to do his own research. Another thing is command line tools for new user is a no go, there is a big posibility that they will freak out and ran to another distribution or back to windows (point and click mentality).

@ alvx: Regarding setup of the internet connection, you seem to have quite a few experiences with different distros, I`m glad to hear you got connection up and going.

Here is another way how to get connection up at boot time

1. open console and login as root
2. use konqueror or mc to make copy of sudoers file. back it up to another location prior to editing it.
3. open sudoers file located in /etc with your favorite text editor
4. edit sudoers file to look like this
Code:
# sudoers file.
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the sudoers man page for the details on how to write a sudoers file.
#

# Host alias specification

# User alias specification

# Cmnd alias specification

# Defaults specification

# Runas alias specification

# User privilege specification
root ALL=(ALL) ALL

# Uncomment to allow people in group wheel to run all commands
%wheel ALL=(ALL) ALL

# Allow members of the group "dialout" to connect to the internet:
%dialout   ALL=(ALL)       NOPASSWD: /usr/sbin/pppoe-start, /usr/sbin/pppoe-stop

# Same thing without a password
#%wheel ALL=(ALL) NOPASSWD: ALL


5. the key line that must be added is
Code:
# Allow members of the group "dialout" to connect to the internet:
%dialout   ALL=(ALL)       NOPASSWD: /usr/sbin/pppoe-start, /usr/sbin/pppoe-stop
6. save it and exit

Second part consists of making yourself an executable script that will be started at boot time

1. open your favorite text editor and
2. copy this lines in to it
Code:
#! /bin/bash
# dsl start
sudo /usr/sbin/pppoe-start
3. save the file and name it like you want (ex. adsl-start)
4. right click on the file ----> properties----> permissions tab----> make a tick in the is executable box----> confirm the changes
5. open console you can use mc to navigate to ~/.kde3.5/Autostart
6. find your script and copy it to location mentioned above
7. restart your computer and try if it works
8. if you want you can make another script for disconnecting your connection
Code:
#! /bin/bash
# dsl stop
sudo /usr/sbin/pppoe-stop

p.s. I can`t confirm that this is working on pardus 2008 but I`m using it daily on 2007.3 and other distros, so it should work without any problems

Regards,
bandito

« Last Edit: June 29, 2008, 18:40:15 PM by Andreas » Logged
alvx
Guest
« Reply #19 on: June 30, 2008, 01:33:05 AM »

Hey Bandito
How is it going?

Thanks for your extensive instructions. I'm gonna try those on later. For now, I'm getting to know better this wonderful distro.

Regarding PPPoE, unfortunately it's still very used in my country (Brazil). I hope the next version of Pardus will support this type of connection too, so I can 'spread the word' to my distro-hopper friends.

Logged
Bandito
Pardus fellow craft
**
Posts: 50


View Profile
« Reply #20 on: June 30, 2008, 06:25:28 AM »

Hi alvx!

It`s almost the same situation in Slovenia, only major cities have interenet connection trough fiber optics and cos of that they are given option to use high speed dsl connections for low price. On suburbs many are still using adsl as this is the only way to get internet connection, but things are looking better  Grin
I had luck when I started learning linux cos at the time many users were still on adsl and instructions weren`t hard to find.
« Last Edit: June 30, 2008, 07:14:08 AM by Bandito » Logged
fastguy
Newbie
*
Posts: 8


View Profile
« Reply #21 on: July 18, 2008, 23:55:46 PM »

Hi,

you should write the command sequence you use to start your pppoe connection in file:

/etc/conf.d/local.start

this script runs the commands that you put inside at system bootup.

Fastguy
Logged
Pages: 1 [2] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!