Welcome, Guest. Please login or register.
April 21, 2014, 01:32:16 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  StartX
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: StartX  (Read 1694 times)
willy
Pardus fellow craft
**
Gender: Male
Posts: 99



View Profile WWW
« on: July 24, 2009, 11:48:38 AM »

When I start Pardus 2009 he don't start in graphical mode,I have to  login and then type startx.
How can I get fix it to start him automatic?
I googled a lot and I have found that you have to change etc/inittab,you must change id:3:initdefault in id:5:initdefault ?
I've done that but it doesn't help!
Can somebody help me ?

Willy
Logged
BenimAdımKırmızı
Guest
« Reply #1 on: July 30, 2009, 09:14:43 AM »

cant help but confirm  Shocked
Logged
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #2 on: July 30, 2009, 09:24:37 AM »

try this
Code:
service xdm status
if its running then then try adding nomodeset to your kernel boot line
if that works tweaking your xorg.conf may allow you to remove it again
if its not running then simply enable it to run on boot using service-manager in system settings


Logged
BenimAdımKırmızı
Guest
« Reply #3 on: July 30, 2009, 10:59:33 AM »

well i remember editing my grub-entry maybe that was the issue.

Thanks for the info but i have to do a fresh install.
Logged
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #4 on: July 30, 2009, 11:09:43 AM »

Was the service running? what happened with no modeset?
Did you alter /etc/innitab if so try default
Code:
# /etc/inittab:                      
#                                    
# This file describes how the INIT process should set up
# the system in a certain run-level.
#

# Default runlevel.
id:3:initdefault:

# System initialization, mount local filesystems, etc.
si::sysinit:/sbin/mudur.py sysinit

# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/mudur.py boot

l0:0:wait:/sbin/mudur.py shutdown
l1:S1:wait:/sbin/mudur.py single
l2:2:wait:/sbin/mudur.py nonetwork
l3:3:wait:/sbin/mudur.py default
l4:4:wait:/sbin/mudur.py default
l5:5:wait:/sbin/mudur.py default
l6:6:wait:/sbin/mudur.py reboot
#z6:6:respawn:/sbin/sulogin

c1:12345:respawn:/sbin/mingetty --noclear tty1
c2:12345:respawn:/sbin/mingetty --noclear tty2
c3:12345:respawn:/sbin/mingetty tty3
c4:12345:respawn:/sbin/mingetty tty4
c5:12345:respawn:/sbin/mingetty tty5
c6:12345:respawn:/sbin/mingetty tty6

# SERIAL CONSOLES
#s0:12345:respawn:/sbin/agetty 9600 ttyS0 vt100
#s1:12345:respawn:/sbin/agetty 9600 ttyS1 vt100

# What to do at the "Three Finger Salute".
ca:12345:ctrlaltdel:/sbin/shutdown -r now
This really shouldn't be a reinstall issue
What is your graphics card / driver ?
« Last Edit: July 30, 2009, 11:12:34 AM by mpie » Logged
BenimAdımKırmızı
Guest
« Reply #5 on: July 30, 2009, 11:25:11 AM »

sorry cant tell you - working right now and dropped pardus for a few days
Logged
BenimAdımKırmızı
Guest
« Reply #6 on: July 31, 2009, 07:39:33 AM »

hi
thanks mpie for your support but nothing solved the problem.
I did a fresh install. Installed all packages i need. And tried to get xfce running.
So i changed on the "old kcontrolcenter" on advanced the settings for boot up to get changed the xdm to start up to xfce or that i have no automatic login. I guess to change that was not a good idea - there is a big bug or i am to silly to get it in the right way and did some things the system dont like at all.

So i had also a look at the /etc/inittab but it was also default...
nomode changed nothing and xdm was running.
i am completely without a clue what to do so i installed again and have to use a pure kde...

Logged
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #7 on: July 31, 2009, 07:56:53 AM »

Sorry but now I'm slightly confused, what  isn't working? when you boot it leaves you at a console and you then log in and type startx you launch an xfce session?

Have you uninstalled any kde packages? what is is you xorg.log?

the option to add to the kernel was nomodeset
Logged
BenimAdımKırmızı
Guest
« Reply #8 on: July 31, 2009, 09:29:21 AM »

well no i installed xfce, played around with the systemsettings - Advanced - System - Login-Manager i guess.  And then this issue appears. After reboot it will start all Services but not KDM or kwin - but after a startx i will get into KDE.

Thats what happen.
Xfce i wanted to start but i am not able to.


My Xorg.conf says "nothing" just those 4 entries which cant tell me much.
But if i go to /etc/X11/xdm there are more files which i guess do the job of the old known xorg.conf....
Logged
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #9 on: July 31, 2009, 11:23:07 AM »

sounds like you set an option that is not configured correct.

go back into login manager and click default

switch to another vt and try restarting xdm(kdm)

sudo or as root service xdm restart if that works it was down to your settings

you should not be able to select xfce from kdm

also worth checking the service is set to run on boot

service xdm on
« Last Edit: July 31, 2009, 11:28:05 AM by mpie » Logged
BenimAdımKırmızı
Guest
« Reply #10 on: July 31, 2009, 22:12:17 PM »

well i fixed it by reinstall of pardus and never touched that systemsettings for loginmanager....

thanks for your help anyway
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!