Welcome, Guest. Please login or register.
April 19, 2014, 16:31:34 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  [solved]How to open port 631 for Linux-to-Linux printing?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [solved]How to open port 631 for Linux-to-Linux printing?  (Read 9320 times)
william5
Newbie
*
Posts: 28


View Profile
« on: July 10, 2008, 01:49:53 AM »

I want to print from a Linux client to a Linux server. The latter has Pardus 2008. I used the Remote CUPS Server for the protocol and entered the IP address of the Pardus system and port 631. If the server runs Ubuntu, I then see all the pinters available on the Ubuntu server. However, if the server runs Pardus 2008, I get "unable to connect to <IP address> on port 631". Also, when I run nmap on the client I see that port 631 on the server is listed if the server runs Ubuntu, but not when the server runs Pardus 2008. So, the question is, I need port 631 open for CUPS printing to the server, but in Pardus 2008 it is closed by default. How do I open that port? Note that this has nothing to do with the firewall, which was turned off.
« Last Edit: July 10, 2008, 18:27:49 PM by Andreas » Logged
william5
Newbie
*
Posts: 28


View Profile
« Reply #1 on: July 10, 2008, 04:44:04 AM »

I want to print from a Linux client to a Linux server. The latter has Pardus 2008. I used the Remote CUPS Server for the protocol and entered the IP address of the Pardus system and port 631. If the server runs Ubuntu, I then see all the pinters available on the Ubuntu server. However, if the server runs Pardus 2008, I get "unable to connect to <IP address> on port 631". Also, when I run nmap on the client I see that port 631 on the server is listed if the server runs Ubuntu, but not when the server runs Pardus 2008. So, the question is, I need port 631 open for CUPS printing to the server, but in Pardus 2008 it is closed by default. How do I open that port? Note that this has nothing to do with the firewall, which was turned off.

I now compared the output of nmap using localhost and the actual IP address of this server. The result was:

using localhost:

Quote
PORT     STATE SERVICE
22/tcp   open  ssh
111/tcp  open  rpcbind
139/tcp  open  netbios-ssn
199/tcp  open  smux
445/tcp  open  microsoft-ds
631/tcp  open  ipp
5800/tcp open  vnc-http
5900/tcp open  vnc

Using the actual IP address of this server:

Starting Nmap 4.62 ( http://nmap.org ) at 2008-07-10 02:32 EDT
Interesting ports on 192.168.0.4:
Not shown: 1709 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
111/tcp  open  rpcbind
139/tcp  open  netbios-ssn
445/tcp  open  microsoft-ds
5800/tcp open  vnc-http
5900/tcp open  vnc
Notice that port 631 is only open in localhost. It should also be open in nmap of the IP addrees. Can anybody shed some light on this?
« Last Edit: July 10, 2008, 18:27:24 PM by Andreas » Logged
Andreas
Guest
« Reply #2 on: July 10, 2008, 06:42:19 AM »

Hello,

have please a look in this Thread

Greetings
Andreas
Logged
william5
Newbie
*
Posts: 28


View Profile
« Reply #3 on: July 10, 2008, 17:59:53 PM »

Hello,
have please a look in this Thread
Greetings
Andreas

I studied this Wiki and found that opening port 631 for CUPS Linux-to-Linux printing is really a matter of having the /etc/cupsd.conf configured right. It is tricky if you are not experienced. I also studied the cupsd.conf file on Ubuntu which does work (see my previous message) and I finally ended up copying the Ubuntu file as much as possible to the Pardus 2008 cupsd.conf file. It is working fine now and I can use all printers in my office on both Pardus 2008 computers, one directly and the second one wirelessly via the first one. If anybody is interested in getting a copy of this modified Pardus cupsd.conf file, let me know.

william5
=====
Logged
Andreas
Guest
« Reply #4 on: July 10, 2008, 18:25:27 PM »

If anybody is interested in getting a copy of this modified Pardus cupsd.conf file, let me know.


Hello william5,

for other users it would helpful, if you can give a output of your modified Pardus cupsd.conf-file.  Wink

I edit your Thread as solved.

Thanks and greetings
Andreas
Logged
william5
Newbie
*
Posts: 28


View Profile
« Reply #5 on: July 10, 2008, 20:41:06 PM »

Hello william5,
for other users it would helpful, if you can give a output of your modified Pardus cupsd.conf-file.  Wink
I edit your Thread as solved.
Thanks and greetings
Andreas

Andreas: yes, consider it solved. Here is the output of the modified Pardus cupsd.conf file. Most of it is already in the default file, but the first 10 lines or so are critical. They have been modified + a few others.

Quote
LogLevel warning
SystemGroup lpadmin
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
# Share local printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAddress @LOCAL
DefaultAuthType Basic
<Location />
  # Allow shared printing...
  Order allow,deny
  Allow @LOCAL
</Location>
<Location /admin>
  # Restrict access to the admin pages...
  Order allow,deny
</Location>
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  # Restrict access to the configuration files...
  Order allow,deny
</Location>
<Policy default>
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

william5
=====
« Last Edit: July 10, 2008, 20:47:09 PM by Andreas » Logged
Andreas
Guest
« Reply #6 on: July 10, 2008, 20:49:24 PM »

Hello william5,

thanks for it and I have set your output in a "Quote-Block"  Wink

Greetings
Andreas
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #7 on: January 12, 2011, 19:55:25 PM »

So glad to find this old thread. All of the sudden on my updated Pardus 2008 system CUPS would no longer start and printing was only possible to a file (since CUPS could not be started no printer was shown).

Filling the cupsd.conf file with the code above and service cups restart seems to have solved the weird problem here
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!