Welcome, Guest. Please login or register.
April 25, 2014, 02:15:45 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  ( SOLVED )Hold Back Updates
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 3 Go Down Print
Author Topic: ( SOLVED )Hold Back Updates  (Read 4847 times)
linuxwizard
Newbie
*
Gender: Male
Posts: 19



View Profile
« on: September 09, 2008, 00:08:23 AM »

Just testing out Pardus to see what it looks like and see what it may offer. Everything from install went good no issues or problems. If I go to install a appl. it wants to install all system updates with appl.
Is their away to hold back certain system updates that I don't want to install ? I normally don't install all system updates I pick and choose what I want to update.
« Last Edit: December 21, 2008, 23:28:28 PM by linuxwizard » Logged

Registered Linux User # 418555
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #1 on: September 09, 2008, 00:36:59 AM »

Hello and welcome linuxwizard,

In order not to update a specific package or a list of packages belonging to a system component you have to use the command line. For example, if you want to update all the packages except firefox :   

Code:
sudo pisi upgrade -x firefox

Similarly, if you don't want to update the packages that are part of the desktop.kde system component, do :

Code:
sudo pisi upgrade -x desktop.kde

The components' names are listed by the following command :

Code:
pisi lc

The other way to avoid the hundreds of Mb of updates is to wait until Pardus 2008.1 is released, which should be soon.
Logged

Team Pardus-fr - French Pardus tools translator
linuxwizard
Newbie
*
Gender: Male
Posts: 19



View Profile
« Reply #2 on: September 09, 2008, 02:55:36 AM »

Thank You PhiX
For your input and help. I knew their had to be away to hold back packages just didn't know how in Pardus. Right now I am using Pardus 2008 on a test harddrive that I use to try out different distro or experiment on before I install on my main harddrives. If the next release of Pardus is close to release and yes I will watch for that and install it. Thanks Again
Logged

Registered Linux User # 418555
Andreas
Guest
« Reply #3 on: September 09, 2008, 06:43:47 AM »

Hello linuxwizard and welcome,

if the problem is solved for you please edit it in your first post as [solved]  Wink

Thanks and greetings
Andreas
Logged
linuxwizard
Newbie
*
Gender: Male
Posts: 19



View Profile
« Reply #4 on: November 01, 2008, 23:27:31 PM »

Hello
Why is it everytime I try to hold back updates they are still trying to be installed. > sudo pisi upgrade -x (typed in 47 package) I want held back and still tried to install them. Go to the Package Manager pick what updates I want but all will  be installed anyway. I want to install > pidgin-libnotify > well can not do that without taking all updates. I know when using Synaptic and I want to install a package I can without getting all the updates being rammed down my throat. All my other systems I can pick & choose what I want to update or upgrade with no problems. What am I missing here with Pardus ? Pardus is running great, but these updates or upgrade issues and trying to install things I need are becoming a real big issue. (installed Pardus 2008.1 a month ago)
« Last Edit: November 02, 2008, 01:09:25 AM by linuxwizard » Logged

Registered Linux User # 418555
Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #5 on: November 02, 2008, 02:57:11 AM »

If you don't want the updates, disable Package Manager from the notification area, you will then receive no more notification - but you have to open Package Manage and look for upgradable packages manually if you want updates... still - works for me Smiley
Logged

linuxwizard
Newbie
*
Gender: Male
Posts: 19



View Profile
« Reply #6 on: November 02, 2008, 06:37:56 AM »

You are missing my point. Their are alot of updates that I do not want to install. I want to hold them back from being installed. If I pick the updates I want, when I go to install those the ones I don't want tries to install also. If I go to Package Manager and try to install a package or appl. the updates wants to install with it. What am I missing to hold these updates from being installed ?
Logged

Registered Linux User # 418555
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #7 on: November 02, 2008, 10:38:36 AM »

If you don't want the updates, disable Package Manager from the notification area, ....................
I agree with Linuxwizard.
This is not the solution.
Because of this there are a number of updates which I want to prevent from installing until the bug has been fixed.
But when I want to install another package, I also get these unwanted updates.
And because of this I can't install the other package. Angry
« Last Edit: November 02, 2008, 21:51:38 PM by atolboo » Logged
Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #8 on: November 02, 2008, 10:44:52 AM »

Hm... Don't quite understand, when you go to the "Upgradeable Packages" can't you select which updates are installed?  Undecided
Logged

atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #9 on: November 02, 2008, 11:45:08 AM »

.......when you go to the "Upgradeable Packages" can't you select which updates are installed? 
Yes, I can, but for instance when I select only mplayer, I get 28 extra dependencies, and the kernel + nvidia-drivers-new is one of them.
Logged
linuxwizard
Newbie
*
Gender: Male
Posts: 19



View Profile
« Reply #10 on: November 02, 2008, 21:46:35 PM »

Hello atolboo
Finally someone else sees this huge issue and problem.
Logged

Registered Linux User # 418555
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #11 on: November 02, 2008, 22:03:24 PM »

Finally someone else sees this huge issue and problem.
I don't understand this. Besides you and me, I don't see 'someone else'. Or do I miss something and getting too old?
And I don't see much reaction to my bug report.  Sad
Is it only with the Nvidia Geforce FX 5200 card?

Code:
sudo pisi upgrade -x firefox
and
Quote
sudo pisi upgrade -x kernel
isn't working.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #12 on: November 03, 2008, 01:56:07 AM »

Hi all,

This happened to me as well.  Prior to last week there were about 54 updates in the PiSi package manager (I have Pardus 2008.1)  I was trying to update certain of these updates (by ticking off the boxes) and it was retrieving them, but then my ISP cut me off so I had to restart later that day.  It must have refreshed and then showed 95 updates available.  I then tried again to get the updates I originally wanted (by ticking off the boxes in package manager) and I typed in root to let it fetch them, but it started to retrieve the Linux kernel update (can't remember exactly the name linux header, linux image or kernel) but I didn't choose it.  So I cancelled.  Normally, what you tick is what is retrieved and any dependencies that are needed.  It said it would take 8 hours, and well, like I said, I cancelled.  I had contrib in addition to the regular repositories. 

So, now I am starting again, fresh install ( I don't mind doing this, as I was having problems with my modem or ISP and now no more problems there). 

This time I don't have contrib in addition to the regular repository.  When I try to get update, I'll let you know if this happens again.

Lisa Marie
Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #13 on: November 03, 2008, 14:25:34 PM »

linuxwizard, maybe it is not a bug, but a feature aiming at keeping updates' consistency.
I think you should write a bug report to get more insight from the Pardus developpers on this issue.
Logged

Team Pardus-fr - French Pardus tools translator
linuxwizard
Newbie
*
Gender: Male
Posts: 19



View Profile
« Reply #14 on: November 03, 2008, 21:53:56 PM »

Hi PhiX
This is what I was trying to figureout. Is it a bug or this is the the feature or design of Pisi. If it is a feature than Pardus is not going to work for me and that is to bad. Cause I like Pardus but I will not install updates that I don't want or need. I will file a bug report and see what happens.
Logged

Registered Linux User # 418555
Pages: [1] 2 3 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!