Welcome, Guest. Please login or register.
April 20, 2014, 23:06:46 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Font rendering in GTK+ apps
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Font rendering in GTK+ apps  (Read 1638 times)
temcat
Newbie
*
Posts: 5


View Profile
« on: September 09, 2008, 13:37:07 PM »

Hi all,

I have installed 2008.1 beta, but I think I had that problem in 2008, too.

I have installed gtk-qt theme engine and set GTK to use my KDE theme and fonts, but fonts are rendered significantly worse in GTK than in Qt. What should I do to make fonts in GTK look exactly as it does in Qt?
Logged
Andreas
Guest
« Reply #1 on: September 09, 2008, 18:16:14 PM »


What should I do to make fonts in GTK look exactly as it does in Qt?

Hello and welcome,

I would like to help you gladly, have however unfortunately no hint. Sorry. Roll Eyes

Greetings
Andreas
Logged
temcat
Newbie
*
Posts: 5


View Profile
« Reply #2 on: September 09, 2008, 21:20:06 PM »


I would like to help you gladly, have however unfortunately no hint. Sorry. Roll Eyes

Do GTK+ and Qt render fonts differently in your system? (That is, with gtk-qt installed and set up to use KDE style and fonts.) That could help establish that I am not alone in having this problem with Pardus.
Logged
Andreas
Guest
« Reply #3 on: September 09, 2008, 21:40:14 PM »


Do GTK+ and Qt render fonts differently in your system?

Sorry, I do not know, what you mean.  Roll Eyes
Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #4 on: September 09, 2008, 21:52:56 PM »

A screenshot would be useful to understand your problem.
Logged

Team Pardus-fr - French Pardus tools translator
temcat
Newbie
*
Posts: 5


View Profile
« Reply #5 on: September 09, 2008, 22:32:29 PM »

A screenshot would be useful to understand your problem.

OK, I'm attaching a screenshot.

The top window is a KDE (Qt) app - Pardus configuration center. You can see that I set GTK+ to use my KDE style and fonts.

The bottom window is a GTK+ app - PulseAudio Volume Control.

Now compare the look of the fonts in both windows. There are obvious differences, and the fonts in the upper window (and in all KDE apps) are much more beautiful.


* fontsqtgtk.png (128.86 KB, 1280x800 - viewed 54 times.)
Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #6 on: September 09, 2008, 23:31:40 PM »

The differences in font rendering are not obvious to me. And I have the same visual effect on my Pardus.
I'm afraid I can't help you.
Logged

Team Pardus-fr - French Pardus tools translator
Andreas
Guest
« Reply #7 on: September 10, 2008, 06:11:45 AM »

The differences in font rendering are not obvious to me.

For me the difference in font rendering are not obvious to me too, because I have the same visual effect.  Wink

Greetings
Andreas
« Last Edit: September 10, 2008, 06:13:28 AM by Andreas » Logged
temcat
Newbie
*
Posts: 5


View Profile
« Reply #8 on: September 10, 2008, 10:27:45 AM »

Fonts in the top windows are darker and thicker. Fonts in the bottom window are lighter and thinner.
Logged
LinuxFanatic
Pardus Master
***
Gender: Male
Posts: 177



View Profile WWW
« Reply #9 on: September 10, 2008, 11:28:03 AM »

Hi all,

I have installed 2008.1 beta, but I think I had that problem in 2008, too.

I have installed gtk-qt theme engine and set GTK to use my KDE theme and fonts, but fonts are rendered significantly worse in GTK than in Qt. What should I do to make fonts in GTK look exactly as it does in Qt?

Hi temcat,

the option "Use my KDE style in GTK application" in "Appearance & Themes > GTK Styles and fonts" has no effekt for font rendering. With this option GTK applications uses same font settings (like size and style of fonts ...) as KDE applications, but not anti-aliasing of fonts. You can configure Anti-aliasing for fonts  in "Appearance & Themes > Fonts and settings" (hope "Fonts and settings" is correct description, because I'm using German system ... Grin )

Perhaps "QtCurve" design can help out, but I'm not sure ...


Kindly regards,
LinuxFanatic
Logged


German Pardus Linux Communtiy --> www.PardusUser.de
temcat
Newbie
*
Posts: 5


View Profile
« Reply #10 on: September 10, 2008, 11:35:14 AM »


the option "Use my KDE style in GTK application" in "Appearance & Themes > GTK Styles and fonts" has no effekt for font rendering. With this option GTK applications uses same font settings (like size and style of fonts ...) as KDE applications, but not anti-aliasing of fonts. You can configure Anti-aliasing for fonts  in "Appearance & Themes > Fonts and settings" (hope "Fonts and settings" is correct description, because I'm using German system ... Grin )

Perhaps "QtCurve" design can help out, but I'm not sure ...


Kindly regards,
LinuxFanatic

Thanks LinuxFanatic,

Well, I set up antialiasing in Tasma the way I like. The problem is, GTK+ either doesn't see these settings or somehow handles them differently. I'll try QtCurve style, but I doubt that it will help with font rendering.
Logged
LinuxFanatic
Pardus Master
***
Gender: Male
Posts: 177



View Profile WWW
« Reply #11 on: September 10, 2008, 12:15:39 PM »

Hi temcat,

this can be useful for you too:
http://forums.whirlpool.net.au/forum-replies.cfm?t=622830#r11

^^^ It is Ubuntu/Debian related, but perhaps helpful too for you issue Wink


Greetings
LinuxFanatic
« Last Edit: September 10, 2008, 12:18:36 PM by LinuxFanatic » Logged


German Pardus Linux Communtiy --> www.PardusUser.de
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!