Welcome, Guest. Please login or register.
April 24, 2014, 23:03:02 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Laptop
| | |-+  [ABANDONED] Aspire One - Battery not recognised
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 3 Go Down Print
Author Topic: [ABANDONED] Aspire One - Battery not recognised  (Read 10736 times)
azra
Guest
« on: October 14, 2008, 10:54:27 AM »

The battery is not recognised at all.
KPowersave only shows the plug in icon and I installed the Kthinkbat applet which says that I have no battery.
Any idea how to solve this?
Thanks!
« Last Edit: October 18, 2008, 23:33:29 PM by azra » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #1 on: October 14, 2008, 11:28:13 AM »

Is the ACPI service "on" (Tasma > System > Service manager) ?
Logged

Team Pardus-fr - French Pardus tools translator
azra
Guest
« Reply #2 on: October 14, 2008, 11:32:30 AM »

Hum... Can't see it...
Here is a screenshot.
How would I switch it on?


* service_manager.png (104.3 KB, 1024x600 - viewed 252 times.)
Logged
azra
Guest
« Reply #3 on: October 14, 2008, 11:56:58 AM »

Ok, here is the update, in case you are interested.
I modified the grub.conf to show acpi=on and rebooted.
The pc went into kernel panic and I had to hard boot.
Nothing would get it to work, and I eventually hit F3 on the grub screen to select failsafe. It eventually booted and kpowersave showed the battery fine BUT the screen became all jerky and unresponsive, the mouse would not be reactive and lag.
So I undid the acpi=on option back to off and I guess I will have to live with the lack of battery indicator!
Logged
atolboo
Guest
« Reply #4 on: October 14, 2008, 14:31:42 PM »

So I undid the acpi=on option back to off and I guess I will have to live with the lack of battery indicator!
Cannot shut down properly. Goes into a loop at the end of the shut down process and has to be turned off manually
I presume that  'acpi=on' is in your grub.conf file.
Start your computer and in the grub start menu screen stop the timer with the down-arrow key and then the up-arrow key.
Pardus 2008 should now be selected.
At the bottom of the screen you will see the start options of Pardus.
Somewhere in that line acpi=on should be visible.
With the help of the left-arrow, right-arrow and backspace you can change acpi=on into acpi=force.
If acpi=on is NOT on the line, simply add acpi=force to the end of the line.
Then go to the end of the line and hit Enter.
Pardus will now start with these options.
You can now check the battery indicator and if the shut down process is now working.
Logged
azra
Guest
« Reply #5 on: October 14, 2008, 14:55:47 PM »

Hey Atolboo
Thanks for taking the time to look into my problem!
My grub.conf is currently set as acpi=off.
The boot goes into a kernel panic when I have acpi=on.
I did as you said and changed acpi=off with acpi=force, and unfortunately, the booting also went into kernel panic and nothing happened...
So I reversed to acpi=off
Is there any way apm=on could achieve similar objectives? I was reading that it could be an acpi  substitute for lower end pcs, so I set it to apm=on acpi=off, but no changes at all.
« Last Edit: October 18, 2008, 23:33:47 PM by azra » Logged
atolboo
Guest
« Reply #6 on: October 14, 2008, 15:36:34 PM »

Here are some more options to try:
Quote
acpi=force pci=noacpi
acpi=force apm=power-off
acpi=off apm=on apm=power-off
apm=power-off
noapic nolapic pci=noacpi
noapic nolapic acpi=off
You can try them as I described in my first post.
In this way you don't have to change /boot/grub/grub.conf.
Can you post the exact entry of Pardus 2008 ?
Logged
azra
Guest
« Reply #7 on: October 15, 2008, 00:12:38 AM »

Ok I'll give that a try and let you know how it goes! Wink
« Last Edit: October 18, 2008, 23:34:02 PM by azra » Logged
Sertse
Pardus fellow craft
**
Posts: 32


View Profile
« Reply #8 on: October 17, 2008, 17:06:29 PM »

Replying to say I really appreciate this and your other post Azra.

I've ordered an aspire one myself, should arrive next week. Good to see pardus works ok for most things. I've tbeen reading though both posts.., is there a overall summary on what I need to do?

and "Abandoned" - I guess nothing worked? A quibble I guess...
Logged
azra
Guest
« Reply #9 on: October 18, 2008, 23:33:09 PM »

Hey Sertse
Welcome to the Pardus community and thank you for the post!
I don't think compliments are due, I am particularly bad at linux! Without the rest of the guys here and their advice, I would be lost  Wink
I don't think you need a summary if you've installed a linux distro before. Just make sure that you select the safe install (I seem to recall?) and that your boot from the external CD drive.
The only thing which I eventually really tweaked was the changing of the vga settings.
If you find any way to solve the issues I still have, i.e. the shutdown and the battery, let me know? "Abandoned" just means that I gave up on this particular issue, and that I am not so bothered about this problem....
« Last Edit: October 19, 2008, 10:14:09 AM by azra » Logged
azra
Guest
« Reply #10 on: October 18, 2008, 23:37:48 PM »

Can you post the exact entry of Pardus 2008 ?

What does that mean? How do I get that?
Logged
Sertse
Pardus fellow craft
**
Posts: 32


View Profile
« Reply #11 on: October 19, 2008, 04:43:35 AM »

azra: I haven't got my One yet to try it myself, but for the shutdown maybe try adding

rmmod snd-hda-intel

to the top of the file at

/etc/init.d/halt

This is what I read from Eee users who are having shutdown prob, don't if it also works for the One.
Logged
azra
Guest
« Reply #12 on: October 19, 2008, 10:11:37 AM »

Here are some more options to try:
Quote
acpi=force pci=noacpi
acpi=force apm=power-off
acpi=off apm=on apm=power-off
apm=power-off
noapic nolapic pci=noacpi
noapic nolapic acpi=off
You can try them as I described in my first post.
In this way you don't have to change /boot/grub/grub.conf.
Can you post the exact entry of Pardus 2008 ?

Hey Atolboo
I tried all these options, and including noapic nolapic at the beginning does stop the loop! The cpu does not shut down, but the screen shows "system halt" and stays there.
Is it worth me adding these to my grub.conf?
Logged
azra
Guest
« Reply #13 on: October 19, 2008, 10:18:00 AM »

azra: I haven't got my One yet to try it myself, but for the shutdown maybe try adding

rmmod snd-hda-intel

to the top of the file at

/etc/init.d/halt

This is what I read from Eee users who are having shutdown prob, don't if it also works for the One.


Hey sertse
You know what? I do not have such a file...
In my /etc/init.d directory, I only have compat.py, compat.pyc and slpd?
Logged
atolboo
Guest
« Reply #14 on: October 19, 2008, 10:21:32 AM »

I tried all these options, and including noapic nolapic at the beginning does stop the loop! The cpu does not shut down, but the screen shows "system halt" and stays there.
When this is with "noapic nolapic acpi=off" try "noapic nolapic acpi=force".
I am waiting for the result.
Logged
Pages: [1] 2 3 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!