Welcome, Guest. Please login or register.
April 21, 2014, 14:31:23 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  [solved] No sound on Laptop (Amilo)
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [solved] No sound on Laptop (Amilo)  (Read 3268 times)
frisil
Pardus fellow craft
**
Gender: Male
Posts: 75


Linux rules!


View Profile
« on: October 15, 2008, 17:36:48 PM »

As I like Pardus so much, I just tried installing it on my girlfriends laptop (Fujitsu Simens Amilo). Everything works fine, even the wireless LAN stick I had already given up on. But a serious problem is: there is no sound. Volume is turned to 100% and Amarok seems to be playing, but there is no sound output. This is a serious issue, as the laptop is connected to the stereo and usually serves as mp3 player for the living room. I need a fast solution, or my GF will insist I discard Pardus and re-install Mepis.

Any idea what could be wrong?
« Last Edit: October 15, 2008, 17:45:52 PM by frisil » Logged

The most merciful thing in the world is the inability of the human mind to correlate all its contents. (Lovecraft)
frisil
Pardus fellow craft
**
Gender: Male
Posts: 75


Linux rules!


View Profile
« Reply #1 on: October 15, 2008, 17:45:14 PM »

Forget about it - I  AM A MORON!
I didn't see the cable to the stereo was plugged in and the stereo was turned to TV instead of AUX!

Everything works fine! Pardus rules!
Logged

The most merciful thing in the world is the inability of the human mind to correlate all its contents. (Lovecraft)
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #2 on: October 15, 2008, 17:54:42 PM »

No problem, it happens sometimes...
Logged

Team Pardus-fr - French Pardus tools translator
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #3 on: October 15, 2008, 19:32:28 PM »

Hey Frisil,

Yep,  I did that yesterday when I installed Pardus on my older box.  I plugged the speaker wire into the onboard audio plug (disabled in BIOS) instead of the external audio card plug.   Grin

Lisa Marie
Logged
frisil
Pardus fellow craft
**
Gender: Male
Posts: 75


Linux rules!


View Profile
« Reply #4 on: October 16, 2008, 01:39:02 AM »

Thanks, I'm glad I'm not the only one...
Logged

The most merciful thing in the world is the inability of the human mind to correlate all its contents. (Lovecraft)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #5 on: October 16, 2008, 20:38:04 PM »

My Pardus system tends to start up every time using the onboard sound as default started sound device, however I want to use my soundcard (to which the speakers are attched to) to be used as default. The onboard sound for me is only audible by use of the front headphone sockets, no speakers are attached to it.

So far I have not yet figrued out how to set this as default option after starting up Pardus.

The above discussion on onboard versus specific soundcards reminds me of this minor problem I have on my Pardus system.

Once started most of the times I succeed in changing sound output to the soundcard, but it is a bit annoying that the onboard one is always selected by default upon starting up.

Anyone that can guide me to the solution for this?
« Last Edit: October 16, 2008, 20:40:14 PM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
atolboo
Guest
« Reply #6 on: October 16, 2008, 21:02:11 PM »

My Pardus system tends to start up every time using the onboard sound as default started sound device,
Isn't it possible to disable the onboard sound in the bios?

Once started most of the times I succeed in changing sound output to the soundcard, but it is a bit annoying that the onboard one is always selected by default upon starting up.
Where in Pardus are you changing the sound ouput?
Logged
MitraMai
Pardus fellow craft
**
Gender: Male
Posts: 89


View Profile
« Reply #7 on: October 16, 2008, 21:31:02 PM »

Don't really know if this will help, but look in /etc/pulse/default.pa. There is an option there to set the default sink-output.
Logged

HP nc4010, which I love dearly...
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #8 on: October 25, 2008, 23:44:52 PM »

Update on this issue.

I could not find how to disable my onboard soundchip anywehere in my BIOS, but...more elegant I found...

this solution that solved the problem for me.

Configuring default soundcards / stopping soundcards from switching

Note: This section assumes that you have installed each soundcard properly.

1)In the Konsole type
Code:
cat /proc/asound/modules
   --> This will give the the name and index of each soundcard you have currently.

Make a note of the names, and decide which one you want to be the default card.
 

2)Now edit (with root privileges) /etc/modprobe.d/alsa-base
Code:
kdesu kwrite /etc/modprobe.d/alsa-base

At the end of the file, add the following (assuming you have 3 cards with module names A, B and C and you want to have them in the order CAB)

Code:
options snd-C index=0
options snd-A index=1
options snd-B index=2
(replace of course  C, A and/or B woth the names you got in step 1)

(this solution was originally found here )

Now everytime I start Pardus my preferred soundcard is loaded as default and visible in Kmix as selected device.  Cheesy
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!