Welcome, Guest. Please login or register.
April 17, 2014, 06:32:20 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  [Solved] Window border missing in compiz
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [Solved] Window border missing in compiz  (Read 1594 times)
Northernfrog
Pardus fellow craft
**
Posts: 38



View Profile
« on: October 28, 2008, 18:07:25 PM »

Hello , I've installed compiz and works great except missing window border . My laptop has an nvidia GeForce4 420 go 32M . Yes compiz has worked before in Pardus 2007 but had same problem that had been resolved and now cannot remember how . I've tried Emerald and still no work .  .......................................Thanks ...  .........Northernfrog....
« Last Edit: November 09, 2008, 19:20:26 PM by Mhmrcs » Logged
Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #1 on: October 28, 2008, 18:14:10 PM »

Run: Konsole (Programs>System>Konsole]
Type: sudo nvidia-xconfig --add-argb-glx-visuals
Press: [Control-Alt-Backspace]

Try disabling then re-enabling Window Decoration from ccsm first, to avoid unessessary trouble.
Logged

Northernfrog
Pardus fellow craft
**
Posts: 38



View Profile
« Reply #2 on: November 07, 2008, 16:29:38 PM »

I followed directions on wiki and now compiz won't run at all . I put ( nvidia-xconfig --composite --allow-glx-with-composite --add-argb-glx-visuals ) . How do i remove that info and try ( sudo nvidia-xconfig --add-argb-glx-visuals ) as suggested by Mhmrcs .  I was hoping this will fix all with compiz including missing window border .
         THANKS.      Northernfrog     
Logged
Pjotr
Pardus fellow craft
**
Gender: Male
Posts: 48



View Profile
« Reply #3 on: November 07, 2008, 16:54:29 PM »

Did you select the "Emerald" window decorator?
Logged
frisil
Pardus fellow craft
**
Gender: Male
Posts: 75


Linux rules!


View Profile
« Reply #4 on: November 07, 2008, 22:38:07 PM »

How do i remove that info and try ( sudo nvidia-xconfig --add-argb-glx-visuals ) as suggested by Mhmrcs . 

I think all changes are written to /etc/X11/xorg.conf

So you can try editing that file as root. If you don't know how to do this:

- press Alt-F2
- enter "kdesu konqueror" (without quotations)
- give root password
- navigate konqueror to /etc/X11
- click the file xorg.conf to edit it, look for what you had nvidia-xconfig insert and delete that line
- save the file
- CAVEAT: ALWAYS MAKE A COPY of your old working xorg.conf before tempering with it. If X refuses to start, you can fall back to your old copy (in that case you can use a live-cd to delete xorg.conf and rename your copy to xorg.conf to get your original config back. You don't need a live cd if you can do that in a terminal)
Logged

The most merciful thing in the world is the inability of the human mind to correlate all its contents. (Lovecraft)
Northernfrog
Pardus fellow craft
**
Posts: 38



View Profile
« Reply #5 on: November 09, 2008, 18:36:51 PM »

Solved . I put (#) in front of line ( Option         "AllowGLXWithComposite" "True" ) in x.org and rebooted . Now everything working great . Someone should fix or add more info in Pardus Wiki so it won't happen to others . And to all who helped ---- THANK YOU'S-----  .           Northernfrog
Logged
Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #6 on: November 09, 2008, 19:20:53 PM »

Thanks NorthernFrog - I'll add it to PardusWiki.
Logged

Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!