Welcome, Guest. Please login or register.
April 20, 2014, 02:51:35 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  [solved]Resolution after major upgrade
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: [solved]Resolution after major upgrade  (Read 3381 times)
waf
Guest
« on: October 31, 2008, 17:58:15 PM »



Today, after a major upgrade (new kernel, ...) of about 40 packages my resolution changed from 1280x1024 to 800x600. I changed it from Tasma-System-Display Manager to the correct value (1280x1024) but after reboot nothing changed. Also, Pardus now chooses 'vesa' instead of 'nv' or 'nvidia'.
« Last Edit: April 29, 2011, 10:06:46 AM by waf » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #1 on: October 31, 2008, 19:20:49 PM »

Hi waf,

I understand that if one does a kernel update/upgrade, one needs to reinstall proprietary drivers. 

I hope others will help here, but if it were me, I would go to Display Manager and it "should" ask you that you can install drivers for your card, and then take you to PiSi - just like when you first installed the nvidia drivers the first time through Display Manager.


I'm somewhat grinning as this happened to me yesterday when I installed nvidia drivers through Mint KDE using the utility Hardware Drivers-configure third-party....  It downloaded, did something and when I rebooted system, the icons were huge, the fonts fuzzy and small, and I was stuck at 800x600.  I ended up re-installing the operating system.  Try the above and see if that works.

Lisa Marie
« Last Edit: October 31, 2008, 19:22:56 PM by Lisa » Logged
Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #2 on: October 31, 2008, 19:22:44 PM »

I had the same problem with Debian, Lisa is right - No proprietary drivers. If the Display Manager doesn't detect the uninstalled NVIDIA card, try the second method on the link:
http://worldforum.pardus-linux.nl/index.php?topic=2278.0
Logged

AlanGB
Newbie
*
Posts: 19


View Profile
« Reply #3 on: October 31, 2008, 21:15:43 PM »

Hi all,

I have the same problem. After upgrading, I can't get beyond 800*600. I've tried the suggestions but none seem to work. I've uninstalled and then reinstalled "Nvidia drivers new" using the package manager but that didn't work.

When i run "Nvidia X server settings" from the System menu, it tells me "You do not appear to be using the Nvidia X driver. Please edit your X configuration file and restart the X server". 

Anyway, I'll keep trying :-)

Regards,  Alan.

Logged
Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #4 on: October 31, 2008, 21:58:55 PM »

Sorry to hear that Alan - There must be a bug in the upgrading process, I'll file a bug report.

@ Ch00k, English only please, it makes moderation of inappropriate language etc, difficult, also, far fewer people will be able to understand you. If you wish to have your language included as a Board under International Users please apply for one.
Logged

AlanGB
Newbie
*
Posts: 19


View Profile
« Reply #5 on: October 31, 2008, 22:10:49 PM »

A little more info.

Rebooting into the previous kernel gives the same results.

My graphics card is an Nvidia Geforce FX 5200.

When trying to install "nvidia drivers" (not "New") from the package manager, I get:

"Comar Error-Package Manager message:
 tr.org.pardus.comar.python.Exception: kernel release 108 dependency of package nvidia-drivers is not satisfied."

This package then fails to install

I updated with konsole using "pisi up". Hence I can't always see what's installing.

Thanks Mhmrcs. Much appreciated.

Alan.
Logged
AlanGB
Newbie
*
Posts: 19


View Profile
« Reply #6 on: October 31, 2008, 22:23:16 PM »

Just for the record, I've got my original 1024*768 resolution running ok now by using the "nv" driver instead of "nvidia".  800*600 is like looking through a magnifying glass!

Regards, Alan.
Logged
Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #7 on: October 31, 2008, 22:33:05 PM »

I didn't do much, but you're welcome in any case Smiley
Logged

Mhmrcs
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 346



View Profile
« Reply #8 on: October 31, 2008, 23:44:28 PM »

I don't think its a "bug" per se. NVIDIA installed just fine on Vista and everything ran like fluid. I used Ubuntu (GNOME), which made my system very unstable, since then I simply did not install NVIDIA drivers. When I started using Pardus I used Compiz - My system turned unstable after a week (slow response rate etc, windows dissapearing when I tried to drag them etc). NVIDIA need to work on their intergration with the Linux platform.
Logged

Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #9 on: November 01, 2008, 00:37:55 AM »

Hi all,

When i run "Nvidia X server settings" from the System menu, it tells me "You do not appear to be using the Nvidia X driver. Please edit your X configuration file and restart the X server". 

Oh no Alan! You didn't install...nvidia-settings?  Shocked  Just kidding you, but I installed this yesterday too as well as nvidia-xconfig, and I also got the "you do not appear to be" error, but it also said,  "Please run nvidia-xconfig as root and restart server".  Something like that anyway and that is how I lost my x11 kde desktop.  If I had to do it all over again, I would just install nvidia-drivers-new from Display Manager as that is what I did a couple weeks ago and had no problems.  It was when I also installed nvidia-settings from package manager that I got in trouble. And, as Mhmrcs, what can one expect from third-party drivers?  nVidia has some work to do to make the install process work better. 

A big welcome, Alan!

Regards,
Lisa Marie
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #10 on: November 01, 2008, 15:30:22 PM »

I also have a Nvidia Geforce FX 5200 and use nvidia-drivers-new (see here) and got the same result after the update.
And this
AlanGB: I took the system back using History Manager in Tasma->System. All works fine again. Welcome to the forum!!!  Cheesy
is the solution for this moment.  Shocked
Logged
AlanGB
Newbie
*
Posts: 19


View Profile
« Reply #11 on: November 01, 2008, 18:05:42 PM »

From what I can tell, the nvidia driver wasn't actually running after the update. But according to Display Manager it was.  Anyhow, as I don't use any 3D effects, the nv driver is fine for my needs.

Alan.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #12 on: November 01, 2008, 22:18:14 PM »

Look here for my bug report.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #13 on: November 02, 2008, 09:55:22 AM »

........... I simply did not install NVIDIA drivers. .........
I don't get 3D-support without NVIDIA drivers and as a result Google Earth wil not work.  Sad
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #14 on: November 03, 2008, 13:52:46 PM »

The problem has been SOLVED  Grin
I see that in the Package Manager nvidia-drivers-new is no longer present.
And I see 2 new nvidia-drivers (dd 02-Nov-2008)

nvidia-drivers177
nVIDIA kernel and glx drivers for GeForce 6xxx and newer NVIDIA cards

nvidia-drivers173
nVIDIA kernel and glx drivers for GeForce FX cards

This is how I solved the problem:
I switched to the "nv" driver.
In Package manager I removed nvidia-drivers-new. <-- not necessary, look here)
I started TASMA>System>Display Manager and followed the instructions .........
And I have 3D-support and Google Earth again.  Cheesy Grin Shocked
« Last Edit: November 03, 2008, 20:46:28 PM by atolboo » Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!