Welcome, Guest. Please login or register.
April 16, 2014, 16:38:22 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  [solved] nvidia-drivers problem, nvidia-xconfig error output
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [solved] nvidia-drivers problem, nvidia-xconfig error output  (Read 3713 times)
Lisa
Pardus Guru
****
Posts: 841



View Profile
« on: November 16, 2008, 20:56:48 PM »

Hi,

I wanted to give this another try, since obviously some of you have successfully installed nvidia drivers for your computer.  My install failed again, but at least I can give more clues:

Geforce 8500, and I recently updated the kernel, as well as Display Manager.

I have two users: one with admin rights. 

I was in my super admin session. I opened up Display Manager> which suggested I use Nvidia-drivers177.  I typed in Root password and it took me to package manager, I downloaded the suggested package (as root), as well as Nvidia-settings and nVidia-xconfig additonal packages for would think these are needed to configure the driver.
In Display manager, I have three options, nv driver, the nVidia driver. and I can't remember the third.  I ticked nVidia that was just installed. I was previously using the Linux nv driver.  I then restarted the system, and my layout was large.  I logged in to my super admin. user desktop, and went to Tasma>System>Display Manager, and it said I wasn't using the nvidia drivers and would I like to install them.  ?  > The driver was now  set to Vesa.  Resolution was set to 800x600, but at least I had a choice to select my 1280x1024 resolution, but I decided to quit there, and try the nVidia Settings GUI.  It said that I wasn't using the nvidia driver and to run nvidia-xconfig as root, and restart xserver.  Okay, I did this in another Linux distro and ran into trouble, but I'm all for breaking the system to work out bugs.  So, I did as root in terminal, the output for nvidia-xconfig:
Code:
admin_user@admin_user-pardus ~ $ su
Password:
admin_user-pardus admin_user # nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".

WARNING: The CorePointer device was not specified explicitly in the layout;
         using the first CorePointer in the config input list.


WARNING: The CoreKeyboard device was not specified explicitly in the layout;
         using the first CoreKeyboard in the config input list.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

admin_user-pardus admin_user #

Both nvidia-xconfig and nvidia-settings executables are located in /usr/bin ownership is root/root.

After running this command, I then went to System>Display Manager and I get the error:

"Display manager cannot get configuration information. Configuration file may be corrupted or modified by another tool. If you want to use display manager to configure your video hardware, you must create a new configuration file.
Would you like to create a new configuration at the next boot?"

I dare not reboot the system for not wanting to lose the xserver.  So, where did I go wrong?  I am almost convinced that I am not able to use this third party driver as such, and will happily go back to using the Linux nv driver instead.  I was curious to try this again, and this time take notes of the sequence and errors I received so I could share the output, in case you notice I am doing something wrong.  The only other thing I can think of is that I should have typed in my super admin password instead of my root password, otherwise, I'm confused as to how to get this working correctly.  Or, maybe I did something in the wrong order.  Maybe I should have run the nvidia-xconfig after installing the driver before I rebooted.

Do I need to manually edit the xconfg file, the one created by nvidia? 

Sorry to throw this out there on a late Sunday.  I can wait a day for any suggestions.

Code:
xorg.conf (notice it doesn't have my screen resolution as a choice under modes: 1280x1024)

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (root@2008)  Prş May 29 08:18:12 EEST 2008

Section "ServerLayout"
    Identifier     "Layout"
    Screen         "Screen" 0 0
    InputDevice    "Keyboard"
    InputDevice    "Mouse"
EndSection

Section "Files"
    RgbPath         "/usr/lib/X11/rgb"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/dejavu/"
    FontPath        "/usr/share/fonts/TTF/"
    FontPath        "/usr/share/fonts/freefont/"
    FontPath        "/usr/share/fonts/TrueType/"
    FontPath        "/usr/share/fonts/corefonts"
    FontPath        "/usr/share/fonts/Speedo/"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/100dpi/"
    FontPath        "/usr/share/fonts/75dpi/"
    FontPath        "/usr/share/fonts/encodings/"
EndSection

Section "Module"
    SubSection     "extmod"
        Option         "omit xfree86-dga"
    EndSubSection
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "SuspendTime" "0"
    Option         "OffTime" "0"
    Option         "BlankTime" "0"
    Option         "AllowMouseOpenFail" "true"
    Option         "StandbyTime" "0"
EndSection

Section "InputDevice"
    Identifier     "Keyboard"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
    Option         "XkbVariant" "basic"
    Option         "CoreKeyboard" "true"
EndSection

Section "InputDevice"
    Identifier     "Mouse"
    Driver         "mouse"
    Option         "CorePointer" "true"
EndSection

Section "Monitor"
    Identifier     "Monitor[default]"
    VendorName     ""
    ModelName      "Default Monitor"
    HorizSync       31.5 - 50.0
    VertRefresh     50.0 - 70.0
EndSection

Section "Device"
    Identifier     "VideoCard"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "GeForce 8500 GT"
EndSection

Section "Screen"
    Identifier     "Screen"
    Device         "VideoCard"
    Monitor        "Monitor[default]"
    DefaultDepth    16
    SubSection     "Display"
        Depth       16
        Modes      "800x600" "800x600" "640x480"
    EndSubSection
EndSection
Second file:
Code:
 
xorg.conf.backup
Section "Module"
    SubSection "extmod"
        Option  "omit xfree86-dga"
    EndSubSection
EndSection

Section "dri"
    Mode    0666
EndSection

Section "Files"
    RgbPath "/usr/lib/X11/rgb"
    FontPath    "/usr/share/fonts/misc/"
    FontPath    "/usr/share/fonts/dejavu/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath    "/usr/share/fonts/freefont/"
    FontPath    "/usr/share/fonts/TrueType/"
    FontPath    "/usr/share/fonts/corefonts"
    FontPath    "/usr/share/fonts/Speedo/"
    FontPath    "/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/75dpi/"
    FontPath    "/usr/share/fonts/encodings/"
EndSection

Section "ServerFlags"
    Option  "SuspendTime" "0"
    Option  "OffTime" "0"
    Option  "BlankTime" "0"
    Option  "AllowMouseOpenFail" "true"
    Option  "StandbyTime" "0"
EndSection

Section "InputDevice"
    Identifier  "Keyboard"
    Driver  "kbd"
    Option  "XkbLayout" "us"
    Option  "XkbModel" "pc105"
    Option  "XkbVariant" "basic"
    Option  "CoreKeyboard" "true"
EndSection

Section "InputDevice"
    Identifier  "Mouse"
    Driver  "mouse"
    Option  "CorePointer" "true"
EndSection

Section "Device"
    Identifier  "VideoCard"
    Driver  "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "GeForce 8500 GT"
    BusId   "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier  "Screen"
    Device  "VideoCard"
    Monitor "Monitor[default]"
    DefaultDepth    24
    SubSection "Display"
        Depth   24
        Modes   "1280x1024" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier  "Layout"
    Screen  "Screen"
EndSection

Section "Monitor"
    Identifier  "Monitor[default]"
    VendorName  ""
    ModelName   "AL1716"
    HorizSync   30.0-83.0
    VertRefresh 56.0-75.0
EndSection
Third file:
Code:
xorg.conf.backup

Section "Module"
    SubSection "extmod"
        Option  "omit xfree86-dga"
    EndSubSection
EndSection

Section "dri"
    Mode    0666
EndSection

Section "Files"
    RgbPath "/usr/lib/X11/rgb"
    FontPath    "/usr/share/fonts/misc/"
    FontPath    "/usr/share/fonts/dejavu/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath    "/usr/share/fonts/freefont/"
    FontPath    "/usr/share/fonts/TrueType/"
    FontPath    "/usr/share/fonts/corefonts"
    FontPath    "/usr/share/fonts/Speedo/"
    FontPath    "/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/75dpi/"
    FontPath    "/usr/share/fonts/encodings/"
EndSection

Section "ServerFlags"
    Option  "SuspendTime" "0"
    Option  "OffTime" "0"
    Option  "BlankTime" "0"
    Option  "AllowMouseOpenFail" "true"
    Option  "StandbyTime" "0"
EndSection

Section "InputDevice"
    Identifier  "Keyboard"
    Driver  "kbd"
    Option  "XkbLayout" "us"
    Option  "XkbModel" "pc105"
    Option  "XkbVariant" "basic"
    Option  "CoreKeyboard" "true"
EndSection

Section "InputDevice"
    Identifier  "Mouse"
    Driver  "mouse"
    Option  "CorePointer" "true"
EndSection

Section "Device"
    Identifier  "VideoCard"
    Driver  "vesa"
    VendorName  "nVidia Corporation"
    BoardName   "GeForce 8500 GT"
    BusId   "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier  "Screen"
    Device  "VideoCard"
    Monitor "Monitor[default]"
    DefaultDepth    16
    SubSection "Display"
        Depth   16
        Modes   "800x600" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier  "Layout"
    Screen  "Screen"
EndSection

Section "Monitor"
    Identifier  "Monitor[default]"
    VendorName  ""
    ModelName   "Default Monitor"
    HorizSync   31.5-50
    VertRefresh 50-70
EndSection

Thanks for having a look.  Oh, just after downloading these, I went ahead and downloaded cmake, in case it would help smooth the integration.

Regards,
Lisa Marie









« Last Edit: November 17, 2008, 17:24:48 PM by Lisa » Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #1 on: November 16, 2008, 21:07:21 PM »

Quote
I downloaded the suggested package (as root), as well as Nvidia-settings and nVidia-xconfig additonal packages for would think these are needed to configure the driver.

I would suggest using the History Manager and take your system back to before the date you altered the nvidia settings and packages.

I also noticed on my Pardus PC that after the most recent update for my Geoforce card no longer the nvidia-new, but the blabla-177 driver was advised.

I ONLY installed the driver that was advised, not the other two packages you mentioned.

Had no problems after that, got the NVIDIA splash boot image back again etcetc..

So give it a new try after first taking your system back in history to a point before you processed the nvdia stuff.

Good luck!
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #2 on: November 16, 2008, 22:08:19 PM »

Also have a look in this post. Wink
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #3 on: November 16, 2008, 23:24:12 PM »

Hi,

And a big thanks to the both of you...now, get some sleep!  Cheesy

I will try the suggestions, and will inquire at a later date as all newbs do,

"Then why are nvidia-settings and nvidia-xconfig available as packages if they cause problems?" 

I am also wondering if one should be compeletely out of the xsession to install these extra configuration utilities?  You know, like reboot, and go into console and run the nvidia-xconfig as root from there.

I must say, at this larger font size, I can easily read things without my reading glasses.  Wink

Thanks again, fellas!

Lisa Marie

 



Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: November 17, 2008, 10:12:07 AM »

.....I am also wondering if one should be compeletely out of the xsession to install these extra configuration utilities? 
No, that is not necessary.
Start TASMA>System>Display Manager and followed the instructions .........
When you were using "nvidia-setings", you get a warning about (translated from Dutch) something like a invalid configuration file with a Cancel and a Continue button.
Select Continue, and after a restart, open TASMA>System>Display Manager again and followed the instructions .........

"Then why are nvidia-settings and nvidia-xconfig available as packages if they cause problems?" 
Nvidia-settings is giving better support when you are connecting a second monitor or HD-tv to your video card.
This is my experience.
After you have installed the new nvidia driver with TASMA>System>Display Manager, you can again start using nvidia-setings.
It is not necessary to use  nvidia-xconfig. (use 'Save to X Configuration File' in nvidia-setings)

I must say, at this larger font size, I can easily read things without my reading glasses.  Wink
So,....eh..... it is a big PLUS or are you getting older ?  Huh? Grin Cheesy Shocked
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #5 on: November 17, 2008, 17:44:13 PM »

Thank you, atolboo for the added information!  I appreciate it!  I am back to where I was.  Last night I used the handy/helpful GUI system tool HIstory Manager, which I will say, I have never used before, but a tool that is very helpful to put you back in a place before you arrived at a messy spot. 

I first went back to before I added the two utilities, nv-settings and x-config, to see if I could still use the 177 driver.  But, when I logged out, I had to hit restart button as as the screen was black with a floating "autoconfig, please wait" from my monitor appeared.  So, I logged back in, and the log in page wasn't in the right layout size, a bit stretched, so I went to History Manager and went back another history step to prior to installing the 177 drivers.  I was able to restart with no problems then, but the login and desktop fonts were still a bit odd, and I noticed in Display Manager that the resolution was at 1200x768 or something like that.  I ended up having to set my monitor to "plug and play" to get it right (Acer AL1716) and select the correct resolution.

My latest xconfig file was not as it should be, even though the display resolution was correct, so I did a silly thing, and installed Pardus 2008.1 on another partition so I could compare the original xconfig file and then manually changed some of the settings as root  such as depth from 16 to 24 and from VGA1 to VGA2 and I removed those extra back up files.  Picky picky picky. 

Again, thanks for the added input.  My complaint is that newcomers will end up frustrated, as many of the  LINUX distros have a, what shall I call it, nag screen, that says, "you are not using the proprietary drivers for your card, you won't be able to fully use its 3D effects."  Most newcomers will think, Okay! and go about the install process, just to find they have lost their xsession.  It needs to be easier so as not to put off these newcomers, or maybe no nag screen, as human nature tends to want to follow the suggestions from the OS.  So far, I am still perplexed.  I still do not understand how to install it.  So, I marked this solved, but solved, sort of.   Huh?

Warm regards,
Lisa Marie
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!