Welcome, Guest. Please login or register.
April 21, 2014, 16:43:24 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  Installing a Netgear WG111 Wireless USB Dongle in Pardus 2008.1
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Installing a Netgear WG111 Wireless USB Dongle in Pardus 2008.1  (Read 2001 times)
EmyrB
Newbie
*
Posts: 19


View Profile
« on: December 17, 2008, 14:05:56 PM »

Hi All,

Recently my daughter's XP box got riddled with spyware/malware again and I am fed up of wiping and reinstalling every few months. I want to put Pardus on the PC but what is holding me back is that she uses a Netgear WG111 Wireless USB Dongle to talk to the outside world.

I have done a search and all I can find is a French forum post which (I think) gives step by step instructions on how to install such device using Pardus. Unfortunately my French is not very good, so is there a English guide or can anybody help with instructions on how to setup one of these wireless dongles?

Cheers in advance

EmyrB
Logged
waterfietser
Pardus fellow craft
**
Posts: 48


View Profile
« Reply #1 on: December 17, 2008, 14:07:45 PM »

What is the french topic's URL?
Logged
EmyrB
Newbie
*
Posts: 19


View Profile
« Reply #2 on: December 17, 2008, 14:33:01 PM »

It was a post written by petibob, here is the url (I hope)

http://worldforum.pardus-linux.nl/index.php?topic=1060.0
Logged
azra
Pardus Master
***
Gender: Male
Posts: 189



View Profile
« Reply #3 on: December 17, 2008, 14:53:03 PM »

Hey

It reads a bit like this:

1)Install the driver

The driver on the CD does not work with pardus and you have to download an alternate version under the following link
http://kbserver.netgear.com/release_notes/D102843.asp.

Unzip the driver. Place the file WIN98 in your home folder.

Open a terminal and type

$ su

Go to WIN98 : # cd /home/username/WIN98

Type : # ndiswrapper -i net111v2.inf

Type : # depmod -a
This is to check that the modules are up to date

Type : # modprobe ndiswrapper
This is to load ndiswarapper in the Linux kernel

Type: # ndiswrapper -m
This is to make sure the module takes into account the driver


2) Setting up the network.

Connect your USB device.

Open “Tasma (System Settings)”, go to “Internet & Network” then “Network manager”.

Usually this device is known as “WG111 Wifi (v2) – Netgear, Inc. (wlan0)”. Go to "Create a new connexion"  and tick “WG111 Wifi (v2) – Netgear, Inc. (wlan0)” in Wireless network.

Enter your ESSID (which was automatically detected for me by clicking on the appropriate box) then your WEP. Chose DHCP. Validate.

Your WIFI should now work.



To make sure the connection is effective each time you log in, type in a terminal:

# echo ndiswrapper>>/etc/modules.autoload.d/kernel-2.6
Logged
EmyrB
Newbie
*
Posts: 19


View Profile
« Reply #4 on: December 17, 2008, 15:07:56 PM »

Thanks azra, you are a life saver. I shall try it out on my test PC tonight and if I get any problems I shall report back Wink
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #5 on: December 17, 2008, 15:17:46 PM »

Also have a look in this Wiki page.  Smiley
Logged
azra
Pardus Master
***
Gender: Male
Posts: 189



View Profile
« Reply #6 on: December 17, 2008, 18:04:33 PM »

Thanks azra, you are a life saver. I shall try it out on my test PC tonight and if I get any problems I shall report back Wink

No worries, for once that I can help someone, the pleasure is all mine!  Wink
Logged
EmyrB
Newbie
*
Posts: 19


View Profile
« Reply #7 on: December 18, 2008, 23:34:23 PM »

OK, I have downloaded the driver and unzipped it. Here is the roblem, which I have reported to the forum before but it was never resolved. The system does not recognise my root password. When installing I use 2 different passwords, one for my username and one for root. When I run things like PiSi or Tasma and it asks for the root password, I enter the one I set during installation and everything is fine. When I try to change the time or type su, the root password is not accepted  Huh?

Any ideas?
Logged
EmyrB
Newbie
*
Posts: 19


View Profile
« Reply #8 on: December 19, 2008, 00:14:43 AM »

Scratch that last message, I figured out why I couldn't "su". I had to give myself administrator privilages in the user account and then I could use the "su" command.

Anyway, just to let you know that I managed to get the wireless working, so this weekend Windows is history on my daughters PC and she will be introduced to the wonders of Pardus  Grin

So thansk for all your help, it was much appreciated  Grin
Logged
azra
Pardus Master
***
Gender: Male
Posts: 189



View Profile
« Reply #9 on: December 19, 2008, 00:56:21 AM »

Excellent!

Well done and happy pardusing!  Cheesy
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!