Welcome, Guest. Please login or register.
April 23, 2014, 08:53:01 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  [SOLVED] Hibernate and Shutdown hotkeys - how to turn off?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [SOLVED] Hibernate and Shutdown hotkeys - how to turn off?  (Read 845 times)
frisil
Pardus fellow craft
**
Gender: Male
Posts: 75


Linux rules!


View Profile
« on: January 11, 2009, 19:46:03 PM »

Hi,
I got a new keyboard with prgrammable hotkeys, two of them are hibernate and shutdown. These two are automatically recognized and used - but I don't want them! Hibernate does not work on my machine and causes it to crash. It's too dangerous for me to have two keys that can accidently destroy my unsaved work when hit by accident, so I want them disabled! How do I do that?

There must be a program/daemon controling these hotkeys, but what is it and how can I change the config to turn hibernate and shutdown off?

Thanks for your help in advance!
« Last Edit: January 13, 2009, 02:26:31 AM by frisil » Logged

The most merciful thing in the world is the inability of the human mind to correlate all its contents. (Lovecraft)
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: January 11, 2009, 22:16:01 PM »

Have a look in Tasma > Peripherals > Keyboard Shortcuts, Keyboard or Keyboard Layout.
I expect the first (Keyboard Shortcuts) item.
Logged
frisil
Pardus fellow craft
**
Gender: Male
Posts: 75


Linux rules!


View Profile
« Reply #2 on: January 11, 2009, 23:43:03 PM »

Have a look in Tasma > Peripherals > Keyboard Shortcuts, Keyboard or Keyboard Layout.
I expect the first (Keyboard Shortcuts) item.

Nope, can't find it there! It's just for "normal" special keys like alt, windows, ctrl and so on, but not the "very special" keys. It's the ones you cannot just apply to a program when pressed because they are out of normal keycode range. You only get Linux to react to them with xev in a terminal - or with a special daemon/progam like hotkeys or lineakd.

Any other ideas?
Logged

The most merciful thing in the world is the inability of the human mind to correlate all its contents. (Lovecraft)
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #3 on: January 12, 2009, 15:04:19 PM »

Any other ideas?
Yes Smiley, the next idea is:
Right click on KPowersave (in systemtray) and select Configure KPowersave...
   General Settings > Button Events 
         and clear entry at [Sleep button:] and [Suspend-to-disk Button:]
         and [Apply] and [OK]
Maybe this will do the trick.
Logged
frisil
Pardus fellow craft
**
Gender: Male
Posts: 75


Linux rules!


View Profile
« Reply #4 on: January 12, 2009, 23:33:39 PM »

Thanks atolboo, that did the trick!
Logged

The most merciful thing in the world is the inability of the human mind to correlate all its contents. (Lovecraft)
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!