Welcome, Guest. Please login or register.
April 19, 2014, 03:50:02 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  MD5 TOOL
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: MD5 TOOL  (Read 842 times)
JDee
Newbie
*
Posts: 2


View Profile
« on: March 02, 2009, 22:39:43 PM »

Source:http://dl.getdropbox.com/u/614750/wxChecksums-1.2.2-src.tar.bz2
First of all I want to say that I have used every single distro under the sun and Pardus is by far my favorite next to crunchbang. It is very user friendly, aesthetically pleasing, efficient, fast, easily configuired, great hardware support out of the box, and installing software is very easy. 2 click installs!! Wink

I just wish I could port other apps because in a world of rpm's and deb's its hard getting new software. I do believe pisi is the best package installer of them all because its even simpler than windows or mac to install software. Grin

Now on to my question I am surprised that there is no gui based md5 hasher in the repo's. Something so essential and simple... I only saw some pearl md5 apps but I couldnt figuire out how to use them. I am trying to install WxChecksums an excellent Gui based md5 hashing tool that hashes mutiple files and subdirectories. It can even process a batch of md5 files all at once! I have attached the source for anyone willing to help me. The only other way to install is rpm and i know pardus doesnt support them... i hate rpm hell anyways. lol.
I tried doing the instructions outlined here :
http://en.pardus-wiki.org/Pardus:How_To#How_to_install_.tar.gz_packages_on_Pardus.3F
the    ./configure  string said there isnt such a directory and the make commands gave me errors. I already installed wxwidgets from the repos.

SO then I tried the instructions in the source code
make depend
make
but it told me there is no such command  as make depend. Please help. I know many people can benefit from this app if it is added to the repos. I tried to make a pisi package but im a programming noob so that didnt work out. lol   Tongue
« Last Edit: March 02, 2009, 22:42:01 PM by JDee » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #1 on: March 02, 2009, 23:56:23 PM »

Hello and welcome JDee,

makedepend belongs to the xorg-util package, so you have to install it first.

Note that a new GUI utility to build PiSi packages from sources has recently appeared in the repository. It comes in two packages : PisiYap and PisiYap-kde3 ( or PisiYap-kde4 if you use KDE4).
Logged

Team Pardus-fr - French Pardus tools translator
JDee
Newbie
*
Posts: 2


View Profile
« Reply #2 on: March 03, 2009, 01:07:23 AM »

Thank you!
Okay Im up to the part where it asks what tools were used to build it. According to the author he used:
- MinGW 2.0.0-3 and Borland C++ Free Compiler (5.5.1) under Windows.
- gcc 3.3.1 under Linux.
- WxWidgets
I dont see any tools resembling that. What do you think? Im thinking Cmake might be a good option....
I tried selecting one of the modules but it wont let me select any. Thats probably why nothing happens when i select create.
Okay i tried manually installing it again with makedepend installed. It seems that it is using an older version of wxwidgets and is looking for the files in:
/usr/include/wx/ 
but the latest version installs itself under /usr/include/wx-2.8/wx
so it keeps failing.
How would I go about pointing it to that direction? I cant rename or manipulate the files in the folder it tells me access denied. I know i cant log in as root so im pretty much stuck. lol Huh?
« Last Edit: March 03, 2009, 03:18:13 AM by JDee » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #3 on: March 10, 2009, 19:41:36 PM »

I think the Makefile or some source files have to be modified in order to be compatible with the Pardus naming scheme.
I think the author of this software is the best person to ask.
Logged

Team Pardus-fr - French Pardus tools translator
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!