Welcome, Guest. Please login or register.
April 25, 2014, 02:06:19 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  ppp unable to open /dev/ppp device - need to create node [solved]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: ppp unable to open /dev/ppp device - need to create node [solved]  (Read 7901 times)
Lisa
Pardus Guru
****
Posts: 841



View Profile
« on: April 02, 2009, 21:51:46 PM »

Hi all,

I refreshed the updates and installed these last night: openssh, disktype, piksemel, mudur, lcms, whois, pygtk, vim, policykit-kde, dejavu fonts, xorg-video

and turned off the computer.  This morning as soon as modem would dial out I could hear the telephone disconnect.  I assumed my ISP was working on their servers.  Tried again and this time I paid attention to the kppp log errors.  It said: ppp log: me-pardus pppd [1698] pppd is unable to open the /dev/ppp device.  You  need to create the /dev/ppp device node by executing the following command as root:
^lmknod /dev/ppp c 108 0

I decdided to go ahead and give this command as root and it terminal said: ^lmknod /dev/ppp c 108 0:substitution failed. 

I checked to make sure the name servers were there, and sure enough they were.  I then went in Tasma History manager and returned back before I had installed the updates.  It said it returned, but with errors.  So I'm using another os to surf for now. 

Regards,
Lisa Marie
p.s. oh, pppd says error 4 which is, "The  kernel  does  not  support PPP, for example, the PPP kernel
              driver is not included or cannot be loaded.

« Last Edit: April 03, 2009, 17:56:45 PM by Lisa » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #1 on: April 02, 2009, 23:23:04 PM »

It looks like some of the update packages messed things up. I would bet for a bug in the new version of mudur.
Have you tried to recreate your internet configuration with network-manager ?

If the problem keeps repeating again and again, you should report it as a bug.
Logged

Team Pardus-fr - French Pardus tools translator
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #2 on: April 03, 2009, 01:12:59 AM »

Hi PhiX,

yeah, probably.  I was thinking it was policykit. 

I'll try that, though I've never been able to successfully use networkmanager to get dial up working, but I think I can try since I have the nameservers I can add if they are needed. 

I was also thinking of trying to re-add my modem, like it was a new modem, via kppp. 

Thanks for the help!

I'll work on this tomorrow-stormy weather out.

Edited to add, I had a quick look for anything mudur in the file system, and maybe this won't be of help, but
etc/conf.d/mudur-newconfig and etc/conf.d/mudur pardus boot configuration file:

#Number of TTYs
#tty-number="6"

Just thinking that the second line should not be commented out. 

Tried setting up a connection with NetworkManager and it didn't even dial out, as it has in the past with Pardus when I tried setting it up months back.  I guess it cannot find the modem device, either.

Oh well, all of this is for another day.  It is late for all!  Night Night!

Regards, Lisa Marie
« Last Edit: April 03, 2009, 02:09:50 AM by Lisa » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #3 on: April 03, 2009, 18:11:52 PM »

I finally got it working.  I looked over most all of the
var/log files
and didn't really see anything, as my ACM0 modem is detected at boot ( I hit "esc" during boot to see the terminal outputs).  I had a look in /dev/ppp and there was no node for ppp.  So, obviously it was missing.  But, when I tried the kppp error suggestion of "You need to create the /dev/ppp device node by executing the following command as root...the same output I found in var/log/daemon.log :Apr  2 08:52:21 me-pardus pppd[1509]: pppd is unable to open the /dev/ppp device. You need to create the /dev/ppp device node by executing the following command as root: ^Imknod /dev/ppp c 108 0
Well, when I tried this yesterday my syntax was wrong as I thought the first letter was an l "el".  Then today I tried this again but got the same response, with the correct syntax as listed above, a captital I "eye"  Cheesy and got the same "/dev/ppp c 108 0: substitution failed".  Harummpff!

So I had a look at this file
/dev/stderr (whatever this file is?)
 and towards bottom it said:
Code:
Opener: received OpenDevice
Opener: received ExecPPPDaemon
In parent: pppd pid 1664
Couldn't find interface ppp0: No such device
Kernel supports ppp alright.
pppd: pppd is unable to open the /dev/ppp device.
You need to create the /dev/ppp device node by
executing the following command as root:
mknod /dev/ppp c 108 0
opened up terminal as super user and entered root password, entered the command without the ^ and the l or the I in front of it as shown above, and yeehaw, I got my internet connection back. 

I now need to write a bug report for this.

Thanks again, and glad to be able to surf using pardus and not mint, as I don't care for FF browser . 

Regards, Lisa Marie
Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #4 on: April 03, 2009, 18:56:51 PM »

Good job Lisa ! That's great !
Logged

Team Pardus-fr - French Pardus tools translator
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!