Welcome, Guest. Please login or register.
April 21, 2014, 06:43:36 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  Standard application hotkeys available only in us keyboard layout[SOLVED]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: Standard application hotkeys available only in us keyboard layout[SOLVED]  (Read 2990 times)
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« on: April 03, 2009, 09:20:03 AM »

Hi,

Ctrl sequences (Ctrl-S, for instance) work in the en keyboard layout, but won't in the ru layout. There must be a remedy, as in other distros it works transparently at least from 2.4.1 version. Any ideas?

I've got OpenOffice 3.0.1 installed, but I checked 2.4.1 before removing; the same behavior. It's funny, because Pardus isn't an English language distro Smiley . The trouble should have been weeded out by now.
« Last Edit: April 05, 2009, 13:01:19 PM by Llama » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #1 on: April 03, 2009, 19:20:31 PM »

Have you tweaked the configuration in OpenOfffice > Tools > linguistic parameters ?
« Last Edit: April 03, 2009, 19:24:24 PM by PhiX » Logged

Team Pardus-fr - French Pardus tools translator
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #2 on: April 04, 2009, 05:21:43 AM »

Have you tweaked the configuration in OpenOfffice > Tools > linguistic parameters ?
Default language for documents set for Russian, that's all.
Logged
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #3 on: April 04, 2009, 17:49:32 PM »

A couple of depressing observations:

(1) It isn't necessarily OpenOffice issue. Ctrl-T in Firefox works in en layout only; in Arch both OpenOffice and Firefox (same versions) hotkeys work regardless of the layout.

(2) I tried Google, but the problem which has been annoying me for as long as I use Linux, seems nonexistent. Well, almost, but the only relevant link I managed to find looks like a joke in a bad taste Smiley . Meanwhile, the trouble should be all too familiar to any bilingual user. I don't know what to think.
« Last Edit: April 04, 2009, 18:01:01 PM by Llama » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #4 on: April 04, 2009, 21:38:45 PM »

You should write a bug report about this on http://bugs.pardus.org.tr/
Logged

Team Pardus-fr - French Pardus tools translator
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #5 on: April 05, 2009, 08:39:05 AM »

The bug #9513 filed. Nevertheless, I feel silly: this can't be happening the way it actually happens Smiley ...
Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #6 on: April 05, 2009, 10:06:20 AM »

What do you mean ?
Logged

Team Pardus-fr - French Pardus tools translator
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #7 on: April 05, 2009, 10:33:29 AM »

What do you mean ?
I mean, the problem just can't be that obscure and unnoticed. You are at least bilingual users here, all of you, aren't? Nobody even bothers to tell me that their hotkeys are all nice and shipshape. This attitude persists all over the Internet, though there is some scant evidence that the issue does exist Smiley . I'm very much puzzled, that's what I mean Smiley .
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #8 on: April 05, 2009, 11:09:01 AM »

I am also a bit puzzled, have you also checked the settings in TASMA-Peripherals (in dutch it says Randapparatuur) and then Hotkeys (in dutch sneltoetsen)?

There is a tab called Application hotkeys (toepassingssneltoetsen), and that lists all types of Ctrl +.. hotkeys.

Is this part of the settings in Tasma similar on your Pardus system?
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #9 on: April 05, 2009, 11:12:46 AM »

And did you also set the russian layout of your keyboard in Tasma-Peripherals-Keyboard layout (indeling)?

Would show something like this at the bottom in the command bar:

setxkbmap -model pc104 -layout ru -variant intl
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #10 on: April 05, 2009, 12:10:45 PM »

(1) Application Shortcuts tab in my Pardus installation looks exactly like the one in my Arch installation. Ctrl-S is present, Current Scheme selected.

(2) In Keyboard Layout, Pardus (Tasma), the respective entries are:

setxkbmap -model pc104 -layout us
setxkbmap -model pc104 -layout ru -variant winkeys

There is interestig (?) difference (Archlinux Control Center):

setxkbmap -model evdev -layout us
setxkbmap -model evdev -layout ru,us -variant ,winkeys


Evdev layout makes things hard to compare, though...
« Last Edit: April 05, 2009, 12:33:04 PM by Llama » Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #11 on: April 05, 2009, 12:29:15 PM »

what happens if you choose -variant intl,  so:
setxkbmap -model pc104 -layout ru -variant intl

?

or if you just leave the variant part at all, so:

setxkbmap -model pc104 -layout ru

?

when you highlight your ru keyboar layout (in Tasma-Peripherals-Keyboard layout) you can choose several alternatives (Intl, dvorak, dvorak-Intl etcetc) for the variant part from a pulldown menu that is above the bar with label ru and above the command bar
« Last Edit: April 05, 2009, 12:35:45 PM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #12 on: April 05, 2009, 12:37:12 PM »

what happens if you choose -variant intl,  so:

setxkbmap -model pc104 -layout ru -variant intl

or if you just leave the variant part at all, so:

setxkbmap -model pc104 -layout ru


Nothing changes. But look at what I dug up in my previous post. I can't tell where the difference comes from, though.
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #13 on: April 05, 2009, 12:41:27 PM »

Maybe that is just your problem, why don't you try
 setxkbmap -model evdev -layout ru,us -variant ,winkeys
as well in Pardus and see what happens?

You can choose evdev from the pulldown menu above the highlghted keyboard layout, I have generic -104-button, but perhaps you can also just copy and paste setxkbmap -model evdev -layout ru,us -variant ,winkeys in the command bar and push the apply button?

Aternatively try this one:
setxkbmap -model pc104 -layout ru,us

or

setxkbmap -model pc104 -layout ru,us -variant ,winkeys

Because what is remarkable from your Arch settings that apparently ru, us is coded instead of "only" ru
« Last Edit: April 05, 2009, 12:45:10 PM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #14 on: April 05, 2009, 12:44:31 PM »

I'm an idiot. There's even no copy/pasting required: in the Layout tab they even provide "Include latin layout" checkbox. So much for it all...
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!