Welcome, Guest. Please login or register.
April 24, 2014, 10:50:41 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  General
| |-+  Wish list
| | |-+  KDEnlive 0.7.3
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: KDEnlive 0.7.3  (Read 1706 times)
Willem
M.D.
Administrator
Pardus Guru
*****
Gender: Male
Posts: 1020



View Profile WWW
« on: April 16, 2009, 11:06:31 AM »

The version of KDEnlive on Pardus is still 0.6, is KDE4 needed to upgrade to the new 0.7.3 ?
Would be great to use the new functionality like:
    * Clip grouping
    * Creation of rendering scripts for delayed rendering
    * Double pass encoding for rendering (just add "pass=2" to your profile)
    * Track locking
    * Configurable monitor background color for better previewing
    * Web updates: you can now download new rendering profiles from Kdenlive's web site
    * Split audio, allows you to separate a clip in it's audio and video parts
    * Improved compatibility with Kdenlive 0.5 project files
Logged

For freedom...
bubbel
Guest
« Reply #1 on: April 16, 2009, 12:54:34 PM »

Hello Willem,

look please here  Wink

Greetings
bubbel
« Last Edit: October 07, 2009, 15:19:33 PM by bubbel » Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #2 on: April 16, 2009, 13:42:30 PM »

Although I have to admit I cannot immediately find the original bug report I have requested for the new kdenlive version already months ago.
This bug report was not really necessarily, however it might result in renewed attention being paid to it.
As far as I can remember from the bug report there were difficulties for getting this KDE4 port of dkenlive to compile and work properly under the current KDE 3.5.
I have the impression that work on this has been halted and one is waiting for Pardus 2009.

Menwahile you can try to get it compiled and working my making use of Kdenlive Builder Wizard.
I guess that programm is still listed somewhere on http://www.kdenlive.org
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
bubbel
Guest
« Reply #3 on: April 16, 2009, 13:59:46 PM »

Although I have to admit I cannot immediately find the original bug report I have requested for the new kdenlive version already months ago.


I think, this is your Bug: http://bugs.pardus.org.tr/show_bug.cgi?id=8642  Wink

Greetings
bubbel
Logged
Willem
M.D.
Administrator
Pardus Guru
*****
Gender: Male
Posts: 1020



View Profile WWW
« Reply #4 on: April 16, 2009, 18:20:35 PM »

Thanks for all the help!
Logged

For freedom...
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #5 on: April 16, 2009, 20:42:30 PM »

Although I have to admit I cannot immediately find the original bug report I have requested for the new kdenlive version already months ago.


I think, this is your Bug: http://bugs.pardus.org.tr/show_bug.cgi?id=8642  Wink

Greetings
bubbel

From this bug report, quite recently posted:

The new mlt and mlt++ packages and the other dependencies of the new kdenlive
is in pardus/devel but can't be merged to 2008 as they will break ABI/API.

The new kdenlive package is in my playground area:
http://svn.pardus.org.tr/pardus/playground/ozan/desktop/kde4/kdenlive-kde4/

You can compile it yourself by satisfying the dependencies first. It's all that
we can do for now.
=======================

<History>
        <Update release="1">
            <Date>2009-02-13</Date>
            <Version>0.7.2.1</Version>
            <Comment>Initial KDE4 release.</Comment>
            <Name>Ozan Çağlayan</Name>
            <Email>ozan@pardus.org.tr</Email>
        </Update>
    </History>

<BuildDependencies>
            <Dependency versionFrom="0.3.6">mlt++</Dependency>
            <Dependency>libogg</Dependency>
            <Dependency>ladspa-sdk</Dependency>
            <Dependency>sox</Dependency>
            <Dependency>ffmpeg</Dependency>
            <Dependency>libiec61883</Dependency>
            <Dependency>libtheora</Dependency>
            <Dependency>kdelibs4-devel</Dependency>
        </BuildDependencies>


<RuntimeDependencies>
            <Dependency versionFrom="0.3.6">mlt++</Dependency>
            <Dependency>libogg</Dependency>
            <Dependency>ladspa-sdk</Dependency>
            <Dependency>sox</Dependency>
            <Dependency>ffmpeg</Dependency>
            <Dependency>libiec61883</Dependency>
            <Dependency>libtheora</Dependency>
            <Dependency>kaffeine</Dependency>
            <Dependency>dvdauthor</Dependency>
            <Dependency>dvgrab</Dependency>
            <Dependency>recordmydesktop</Dependency>
            <Dependency>cdrtools</Dependency>
            <Dependency>kdelibs4</Dependency>
        </RuntimeDependencies>

« Last Edit: April 16, 2009, 20:44:46 PM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #6 on: April 16, 2009, 20:54:45 PM »

I have sent the kdenlive PISI package maintainer Ozan Çağlayan an email requesting some additional info.
If he replies I will post the answer here.
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #7 on: April 16, 2009, 21:42:05 PM »

A really quick answer from Turkey  Cheesy

=============================

Michiel wrote:
> > Hi,
> >
> > I once started this bug report:
> > http://bugs.pardus.org.tr/show_bug.cgi?id=8642
> >
> > Although it is nowadays marked resolved I have some (beginners?)
> > questions, could you help me? I am asking you because Willem (the
> > forum moderator of worldforum.pardus-linux.nl) and others are
> > questioning whether kdenlive 0.7 can be instaleld in Pardus.
> >
> > My questions are:
> >
> > 1) Will kdenlive 0.7.x be part of Pardus 2009?
> >

Yep of course.

> > 2) Could you explain to a beginner what exactly is the problem
> > described here:
> >
> > The new mlt and mlt++ packages and the other dependencies of the new
> > kdenlive"
> > is in pardus/devel but can't be merged to 2008 as they will break
> > ABI/API.

The problem is:

The new kdenlive requires the new versions of mlt and mlt++ libraries
but those new versions of mlt and mlt++
break compatibility with older versions. So imagine an application other
than kdenlive which uses mlt and mlt++.

If I update mlt and mlt++ to their latest versions in Pardus 2008
repository, and a user chooses to *only* update
mlt and mlt++ by chance, the new versions of the libraries will be
installed and all the applications that have been
compiled against their older versions will be unfunctional.

> >
> > 3) Could you or someone else provide a short HOWTO for compiling
> > kdenlive 0.7 from playground. Which dependencies must be installed and
> > how to do so before creating a PISI package from  the playground files?

It resides here:
http://svn.pardus.org.tr/pardus/playground/ozan/desktop/kde4/kdenlive-kde4

You have to compile mlt and mlt++ from
http://svn.pardus.org.tr/pardus/2009/devel/multimedia/tv/

mlt will need frei0r-plugins, you also have to compile it from:
http://svn.pardus.org.tr/pardus/2009/devel/multimedia/library/frei0r-plugins/

The dependencies which don't have "releaseFrom=...." in pspec.xml don't
need a specific version so
you can install those packages from package-manager.

For compiling the pisi packages, just checkout the repository:

svn co http://svn.pardus.org.tr/pardus/2009/devel 2009/devel

and then

pisi build 2009/devel/multimedia/tv/mlt/pspec.xml -vd

this will fail if you don't have some dependencies installed. If it
fails, then you install or compile that dependency and then start again.





Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #8 on: October 07, 2009, 15:14:36 PM »

Kdenlive 0.7.6 is currently in development and should be released on the 8th of October.
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!