Welcome, Guest. Please login or register.
April 20, 2014, 23:00:19 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Pardus in VirtualBox: shared folders
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Pardus in VirtualBox: shared folders  (Read 1762 times)
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« on: April 23, 2009, 15:52:42 PM »

Hi,

I've shared a host folder for a VirtualBox Pardus installation (guest). Where am I supposed to find this folder in my Pardus guest Smiley ?
Logged
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #1 on: April 23, 2009, 19:57:05 PM »

In the Guest system (Pardus):
Quote
# modprobe vboxvfs
# mount -t vboxsf my_share /mnt/share
I'd like to know what to put in /etc/fstab to make it permanent...
« Last Edit: April 23, 2009, 20:05:15 PM by Llama » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #2 on: April 23, 2009, 21:51:38 PM »

Can you tell what is your Host OS?
Logged
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #3 on: April 24, 2009, 05:26:21 AM »

Archlinux
Logged
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #4 on: April 24, 2009, 08:50:48 AM »

Another trouble: after
Quote
# modprobe vboxvfs
# mount -t vboxsf my_share /mnt/share
I've got /mnt/share (Pardus guest) accessible only with root privileges. How am I supposed to make it accessible for an ordinary user?
Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #5 on: April 24, 2009, 12:27:04 PM »

Maybe you can add a line in the /etc/fstab file with the user_xattr option ?

Code:
#<fs>             <mountpoint>     <type>    <opts>                                 <dump/pass>
vboxsf           /mnt/share        vboxsf   defaults,user_xattr,noatime            0    0
Logged

Team Pardus-fr - French Pardus tools translator
Llama
Pardus fellow craft
**
Gender: Male
Posts: 111



View Profile
« Reply #6 on: April 25, 2009, 05:36:58 AM »

I'll try. Meanwhile I mount it manually:
Quote
# mount -t vboxsf my_share /mnt/share -o rw,exec,uid=1000,gid=1000,dev
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #7 on: April 27, 2009, 22:41:46 PM »

Maybe you can add a line in the /etc/fstab file with the user_xattr option ?
Code:
#<fs>             <mountpoint>     <type>    <opts>                                 <dump/pass>
vboxsf           /mnt/share        vboxsf   defaults,user_xattr,noatime            0    0
After adding the above line I get in Krusader-root-mode > MountMan > right-click vboxsf > Mount
Quote
error unknown mount option 'noatime'
and after modification (user_xattr gives the same error) to
Code:
vboxsf           /mnt/share        vboxsf   defaults           0   0
I get
Quote
Could not mount device
The reported error was:
/sbin/mount.vboxsf: mounting failed with the error: Protocol error
So I think this line in /etc/fstab isn't going to solve this problem? Huh?
This is all with VirtualBox-2.1.4 from the Repository (Pardus)  (because of this I need to change the wiki pageWink
Until this moment the only option is to use
Code:
mount -t vboxsf name-of-the-shared-folder /mnt/share -o rw,exec,uid=1000,gid=1000,dev
in a Root shell-Konsole.
And because of this "Root shell-Konsole" you can't put this command in an executable file in /home/username/.kde/Autostart ?
Or is there a setting in f.i. Tasma > System > User manager > username > Groups (translated from Dutch) which make it possible to issue the "mount" command in a User Konsole ?  Huh?
Any suggestions and idea's are very welcome !!!!!
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!