Welcome, Guest. Please login or register.
April 17, 2014, 13:17:14 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Permissions for backup partition so VB can access virtual disk (Solved)
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Permissions for backup partition so VB can access virtual disk (Solved)  (Read 1294 times)
markcynt
Newbie
*
Posts: 14



View Profile
« on: July 21, 2009, 12:07:14 PM »

I need to give a file in my backup partition permission to run as an executable.

How do I accompllish this in Pardus?

Thanks

Mark
« Last Edit: July 22, 2009, 20:11:51 PM by markcynt » Logged
BenimAdımKırmızı
Guest
« Reply #1 on: July 21, 2009, 16:58:05 PM »

cd "to path were file is"

then as root or try as regular user....

chmod +x filename

and if you what it as regular user also do

chown "username" filename
Logged
markcynt
Newbie
*
Posts: 14



View Profile
« Reply #2 on: July 22, 2009, 12:13:06 PM »

Thanks but that did not work. Here is my fstab. /dev/sdb2 is the partition the file is in.

Code:
mark@Family ~ $ cat /etc/fstab
# See the manpage fstab(5) for more information.
#
#   <fs>             <mountpoint>     <type>    <opts>               <dump/pass>
LABEL=PARDUS_ROOT    /                ext4      defaults,user_xattr,noatime 0 0
LABEL=PARDUS_HOME    /home            ext4      defaults,user_xattr,noatime 0 0
/.swap               swap             swap      sw                   0 0
proc                 /proc            proc      nosuid,noexec        0 0
sysfs                /sys             sysfs     defaults             0 0
debugfs              /sys/kernel/debug debugfs   defaults             0 0
tmpfs                /dev/shm         tmpfs     nodev,nosuid,noexec  0 0
/dev/sda10           /mnt/sda10       ext3      noatime              0 0
/dev/sdb2            /mnt/sdb2        ntfs-3g   dmask=007,fmask=117,gid=6,locale=en_US.UTF-8 0 0
/dev/sda9            /mnt/sda9        ext3      noatime              0 0
/dev/sda5            /mnt/sda5        ext3      noatime              0 0
/dev/sda6            /mnt/sda6        ext3      noatime              0 0
Logged
BenimAdımKırmızı
Guest
« Reply #3 on: July 22, 2009, 12:24:53 PM »

this is ntfs - so i dont know how to handle this but there must be a kernel driver....

if you start up, press F2 or esc to see the nonverbose - bootmessages - there you can find a way to fix it i think

and rename the Threadname so i guess there will be more and better support
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: July 22, 2009, 14:22:57 PM »

Try this:
Open Dolphin > surf to the file > right-click on the file and in the Permissions tab > Set "Is executable"
In the Permissions tab also the owner is shown.
If root is the owner of the file, the above isn't going to work.
In this case press simultaneously Alt+F2 and enter:
Quote
kdesu dolphin
Enter the root password (wait some seconds) and root-Dolphin will appear.
And repeat the above.
I hope this is the solution!  Wink
« Last Edit: July 22, 2009, 14:46:23 PM by atolboo » Logged
markcynt
Newbie
*
Posts: 14



View Profile
« Reply #5 on: July 22, 2009, 18:30:46 PM »

Try this:
Open Dolphin > surf to the file > right-click on the file and in the Permissions tab > Set "Is executable"
In the Permissions tab also the owner is shown.
If root is the owner of the file, the above isn't going to work.
In this case press simultaneously Alt+F2 and enter:
Quote
kdesu dolphin
Enter the root password (wait some seconds) and root-Dolphin will appear.
And repeat the above.
I hope this is the solution!  Wink

Thanks but I already tried both of those. Root is the owner, but using Dolphin as root still won't let me change the permissions.

I'm going to see if I can't mount it under a different directory with different options in fstab.
Logged
markcynt
Newbie
*
Posts: 14



View Profile
« Reply #6 on: July 22, 2009, 19:40:31 PM »


I'm going to see if I can't mount it under a different directory with different options in fstab.

This worked for me. I removed:
Code:
/dev/sdb2            /mnt/sdb2        ntfs-3g   dmask=007,fmask=117,gid=6,locale=en_US.UTF-8 0 0

And replaced it with:
Code:
UUID=1F4D93145B084DAB /media/windows ntfs-3g defaults 0 0
Logged
markcynt
Newbie
*
Posts: 14



View Profile
« Reply #7 on: July 22, 2009, 20:10:17 PM »

By the way I do this so that I can use the same virtual hard disk in Virtualbox without having to reinstall the OS everytime I install or reinstall a new distro.

i hope this helps someone else.  Smiley
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: July 22, 2009, 20:42:51 PM »

Thanks.
So the problem, in principal, is the ntfs partition and the way it's mounted to the mounting point.
This requires some expert knowledge of mounting and options.
I was wondering if it is possible to change permissions after moving/copying the file to the Pardus partition?
Logged
markcynt
Newbie
*
Posts: 14



View Profile
« Reply #9 on: July 22, 2009, 22:46:50 PM »

Yes that would be possible but I don't like to wait for the 20GB file to copy over.

Plus the way I do it now all changes, files, updates and installed software are accessible no matter which distro I choose to run VB.

If I install a program or add a file in VB while in Pardus today, I will have that same program/file when I use VB in openSUSE or Mint tomorrow.

Figuring it out initially is sometimes hard, sometimes not but always worth it in the long run.  Smiley
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!