Welcome, Guest. Please login or register.
April 25, 2014, 02:10:43 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  2009. I want to have KDE toolbar icons to launch applications...
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: 2009. I want to have KDE toolbar icons to launch applications...  (Read 2277 times)
brjoon1021
Newbie
*
Posts: 20


View Profile
« on: July 28, 2009, 22:04:41 PM »

I hope you know what I mean. The toolbar at the top or the bottom of the screen has icons in Microsoft Windows, Gnome, XFCE, KDE 3, pretty much everything else... but, I can't figure out how to add them with KDE 4. Is it possible ?

Thanks,

B
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #1 on: July 28, 2009, 22:21:41 PM »

do you mean e.g. a little button in the toolbar (system tray if you like) to startup let' s say firefox?

The bar itself is called "panel" if you select any application from the start menu (Kickoff menu) and rightclick it instead of opening it with leftclick, you can choose "add to panel", and then a little icon appears in the system tray.

Does this help you, or did I misunderstand your question?
« Last Edit: July 28, 2009, 22:23:53 PM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
brjoon1021
Newbie
*
Posts: 20


View Profile
« Reply #2 on: July 28, 2009, 22:25:07 PM »

You have my question understood perfectly. However, that has never worked in KDE 4 as far as I know. I installed Kubuntu with 4.1 and 4.2 as well as the newest 2009 Pardus. Right-clicking opens the application just like a left click, there is not menu. Please verify.

Thanks,

B
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #3 on: July 28, 2009, 22:29:19 PM »

That is strange! On my laptop I have a fresh install of Pardus 2009.
I have added a Firefox button without problems to my system tray just like I mentioned.

Since the behaviour in your Pardus is the same on left or rightclick, possibly you should check your current mosue settings?

I get the attached context menu when I rightclick on Firefox in the start menu (in my case it is in dutch language). See attachment.


* right.png (7.92 KB, 241x143 - viewed 93 times.)
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #4 on: July 28, 2009, 22:36:26 PM »

That works from the classic menu or kickoff menu , but not from lancelot.
You could always switch types to add them then switchback
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #5 on: July 28, 2009, 22:40:26 PM »

I just noticed that changing tio classic menu style results in launching an application no matter you left- or rightclick it, where as the procedure I described apparently only works for the Kickoff menu style.

Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #6 on: July 28, 2009, 22:43:07 PM »

In the calssic menu style (yeah everyone including me keeps learning as we discuss this) you can just drag and drop an application from the menu to the system tray.

So when you leftclick e.g. Firefox and you drag it to the system tray your launcer icon will appear there, give it a try!

Likewise drag any application from your menu (leftclick-and-hold) to the system tray if you want.
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
brjoon1021
Newbie
*
Posts: 20


View Profile
« Reply #7 on: July 28, 2009, 22:48:08 PM »

That is kind of weird...

Ok, I will just change the menu type so that I can add icons. By the way, I am not at that computer now, I am at a Gnome / ubuntu box, so I hope you can tell me how to change the menu once I get back to my Pardus box.

Thanks,

B.
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #8 on: July 28, 2009, 22:52:14 PM »

For switching between KDE classic menu style and KDE Kickoff menu style I just rightclick on the KDE menu button at the far left of the system tray (where in Windows you have the start button)


* menu.png (21.56 KB, 378x161 - viewed 104 times.)
« Last Edit: July 28, 2009, 22:54:38 PM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #9 on: July 29, 2009, 00:16:34 AM »

....... but not from lancelot.
Huh? I just added the Krusader icon from the Lancelot menu by drag-drop to the taskbar.
Logged
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #10 on: July 29, 2009, 06:01:35 AM »

Weird, I wonder if it is theme/config dependent, as drag and drop does not work for me from lancelot or kickoff but does from classic. Right clicking works from kickoff only for me

Ok so I  just cleaned out my .kde .kde4 and .config/kde.org
 and now dragging and dropping works from all three with the default settings
« Last Edit: July 29, 2009, 06:17:31 AM by mpie » Logged
brjoon1021
Newbie
*
Posts: 20


View Profile
« Reply #11 on: July 29, 2009, 08:13:29 AM »

Why are the new icons crowded over by the notification area at the right side of the screen ? I can't move them ?

B.

**********   Figured it out: youtube video, of course.
http://www.youtube.com/watch?v=5HZAcwiWKyo
« Last Edit: July 29, 2009, 08:19:07 AM by brjoon1021 » Logged
waf
Guest
« Reply #12 on: July 29, 2009, 09:33:16 AM »

Right-click on the task manager, unlock widgets, left-click on the symbol that appears on the right and move the cursor over the icons.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!