Welcome, Guest. Please login or register.
April 24, 2014, 03:10:52 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  [Solved] New kernel- can't start x
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] 3 Go Down Print
Author Topic: [Solved] New kernel- can't start x  (Read 6479 times)
bubbel
Guest
« Reply #15 on: August 07, 2009, 17:02:08 PM »

Working now

Good news. Smiley
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #16 on: August 30, 2009, 01:51:40 AM »

Hi all,

I'm having the same problem, but I did not install any third party drivers for my nvidia card.  I installed Pardus 2009 a few days ago, did some of the updates yesterday which included the kernel to .125 and I get the black screen when I choose that kernel in the grub menu.  I'm using the default nv driver for my geforce card.  I finished getting all of the updates today, so there are none shown when I click on "show upgradable packages" in Package Manager.  I'm not sure if clicking on "show upgradable packages" is the same as refreshing the repositories, as there is no "refresh" in the GUI for PiSi Package Manager.  I'm uncertain what I need to do to fix this. 

Lisa Marie
Logged
bubbel
Guest
« Reply #17 on: August 30, 2009, 08:41:11 AM »

"show upgradable packages" is the same as refreshing the repositories,

Hello Lisa Marie,

yes it is or type in console pisi up  Wink

Greetings
bubbel



Logged
waf
Guest
« Reply #18 on: August 30, 2009, 12:36:08 PM »

Using the terminal (pisi --help), refresh the repos, delete cache, rebuild databases, update repos or upgrade. Maybe it works.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #19 on: August 30, 2009, 17:06:27 PM »

oops, I see I wrote .5-125, when I think it was 5-126 kernel. 

An update.  I did a reinstall last night since I noticed I had no user with administrative rights set up, even though I thought I had originally set it up in that way, but this time it worked as I see I have a choice of both user and root when doing administrative stuff.  Still no system sound and I don't see the usual audio icon in the bottom right of the panel (maybe this is by default?). I'll start another thread about the sound problem, but this is why I did the updates the other day in case any of you were curious why  Cheesy

Thanks bubbel and waf.  That is what I wanted to know-how to do it via the terminal. 

Thanks very much for your time and help!

Lisa Marie
Logged
bubbel
Guest
« Reply #20 on: August 30, 2009, 17:32:04 PM »


Thanks bubbel and waf. 

No problem. Happy to help,  Smiley
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #21 on: September 02, 2009, 16:32:58 PM »

Hi all,

An update.  I reinstalled again, as I mentioned in another thread just to see if it was from a glitch in the install  process.  I reopened this bug as I'm still getting the blank screen with the blinking vertical horizontal cursor (no x/tty1) after doing all 107 updates that included xorg update and kernel 2.6.30.5-126.   At the blinking cursor page, I can hit Alt+F2 and get to a command line login, but that is it.  A console log in still doesn't allow "startx".  I have to click Cntl+Alt+Del which restarts the computer.  I think this has something to do with the Nouveau graphics drivers with the latest kernel, as it wasn't used in Pardus 2008.2 or prior.  I was using nv.  But nouveau did work with default kernel.  I don't want to use proprietary drivers if I don't have to-I'm stubborn and have the patience for those fine Linux folks to figure out my nvidia geforce card.  Wink

Regards, Lisa Marie

edited to add:
My temporary fix for this problem:
boot into old kernel, go to System Settings>Boot Manager>select kernel 30.5-126, edit, under Boot Options, change to
root=LABEL=PARDUS_ROOT1 nouveau.modeset=1 splash=silent quiet vga=0
OK and reboot and I can get to graphical log-in.  If vga is left at default vga=0=31a I get distorted graphics.  Changing it to vga=0 gives me simple console output and then to graphical log-in.  I also have set System Settings>Display>Devices>Configure>Select from list>Nouveau, though I do not know if this makes a difference, but selecting Nouveau and selecting Color Depth>Select from list>24 bit instead of leaving it at "determined by the driver" gives me very clear graphics display.  Digikam pictures looks crisper!  Just in case this helps.
Oh, ignore [0.00000 - unknown boot option - nouveau.modeset=1 - ignoring" or whatever it says at boot up.  This is acceptable/normal.  It still reads the menu.lst. 
« Last Edit: September 06, 2009, 18:28:44 PM by Lisa » Logged
FoxXav
Newbie
*
Posts: 19


View Profile
« Reply #22 on: September 13, 2009, 21:34:00 PM »

Hi everyone,

I got the same problem but the trick didn't work. I always have distorded display.
Actually I only use pardus on VirtualBox.
I got an asus G50V with an Nvidia 9700MGT (problems are the same in VirtualBox and with "real" install)

So is there something else I can try to make it work ?

See you
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #23 on: September 13, 2009, 21:43:15 PM »

I got the same problem but the trick didn't work.
Did you try this trick?
Logged
FoxXav
Newbie
*
Posts: 19


View Profile
« Reply #24 on: September 13, 2009, 21:57:59 PM »

The same problem of distorted display apply with old kernel too.
To late this evening, but I'll try tomorrow to do a fresh install in VirtualBox of pardus to try these tricks.

I'll post the result.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #25 on: September 13, 2009, 22:22:06 PM »

I didn't read very carefully !!!!! Angry sorry.
When you are using Pardus as a Guest in VirtualBox, the VirtualBox Graphics Adapter (from InnoTek) is used.
And this has nothing to do with using Nvidia 9700MGT in Pardus.
What is your Host_OS?
Logged
FoxXav
Newbie
*
Posts: 19


View Profile
« Reply #26 on: September 14, 2009, 19:45:25 PM »

Hi,

I'm with windows 7 Ultimate x64.
There is something wrong in the update because after update I got these display problem but it works ok with fresh install without update.

I'll do as I say yesterday I'm reinstalling the system, I'll do all update except xorg update to see if it's kernel or xorg or both problems.

--------------------------------------------

I've finished reinstall, I've done all update except xorg update, display's problem come back, and both new and old kernel affected.
« Last Edit: September 14, 2009, 20:48:53 PM by FoxXav » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #27 on: September 14, 2009, 20:57:01 PM »

........I'm reinstalling the system, I'll do all update ........
Pardus 2009, at this moment, might have a big problem getting all updates as you can read in this bug report.
They are working on the problem.
The possible (temporary) solution is in Comment #48
In some other Comment #number you can see that this solution isn't always working.
Keep this in mind !
Logged
FoxXav
Newbie
*
Posts: 19


View Profile
« Reply #28 on: September 15, 2009, 22:20:54 PM »

Hi !

I've made a reinstall again in VirtualBox and I'll do pisi up and no problem with the 127 update.
But always display problem after update with old and new kernel.

I put a screenshot of the display problem.

I try to do a Xorg -configure but it didn't change anything after I replace the xorg.conf and reboot.

What can I try ? Could the pisi problem (that didn't seem to appear during my install but who know) responsible of that mess ?

See you


* graphicsPb.jpg (353.19 KB, 1680x1050 - viewed 120 times.)
Logged
FoxXav
Newbie
*
Posts: 19


View Profile
« Reply #29 on: September 20, 2009, 22:16:31 PM »

I solved my problem with virtualbox.
To do so, I uninstalled virtualbox kernel module.

I also solved my pardus problem with my real install.
After upgrading the kernel I restart with the old one and selected the nvidia-current driver in display properties.

Then it's all ok with new kernel.

Thank you
Logged
Pages: 1 [2] 3 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!