Welcome, Guest. Please login or register.
April 19, 2014, 20:24:48 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  first start Konqueror-asks to open links using Firefox [solved]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: first start Konqueror-asks to open links using Firefox [solved]  (Read 730 times)
Pardus Guru
Posts: 841

View Profile
« on: September 05, 2009, 22:13:05 PM »

Hi all,

I'm not sure if this is a Pardus bug or a Konqueror KDE  bug.  I'm back to using the default kernel as I try to take a look at changes/updates that cause any problems.  I have done the KDE updates including baselayout, KDE4 libs, kaptain, and plasma.  No, I still do not have search engine in upper right hand corner.  But this I can get installing plugins in installable.

Anyway, just wondering if anyone else that uses Konqueror as browser (mdiegi?) is having this problem.
When Konqueror is first started, if I go to Go>Most often visited or Recently visited, and click on one of the links there, it brings up a pop up window.  The link example below is for altavista search engine.  Popup:
"www.altavista.com - Konqueror
Icon with the letter "i"
Open 'http://www.altavista/'?
Type: HTML document
Do not ask again
Save As
Open with 'Firefox'

I click "cancel".  Normally it would open the link in Konqueror and not ask me this.  I have left default settings alone, the section under General>when konqueror starts>show introduction page, and the way it opens up links is default.  Maybe this has something to do with Dolphin side by side with Konqueror, but no idea, just a guess.

The same window also pops after first starting Konqueror and opening History and trying to click on a link in history.  The only way this does not happen is to go to Bookmarks and click on a saved bookmark link there-it opens it up normally, in existing window.  This bug only happens when Konqueror starts up.  Otherwise, after opening up a link in Bookmarks, I can then freely use Go>Most often visited or Recently visited, as well as History.

I have looked over System Settings>Default Applications>Choose default for web browser>open HTTP and HTTP URLs in the following browser, which by default was set to Firefox, but I changed it to>in the following browser>konqbrowser>Apply, reboot and it still shows this pop up window upon start of Konqueror as mentioned above.  I opened up Firefox and unticked, "always check to see if  firefox is default browser" in case this made a difference, usually doesn't, and it didn't.   

I may have to file a bug report to KDE. 

Regards, Lisa Marie
« Last Edit: September 06, 2009, 18:25:57 PM by Lisa » Logged
Pardus Guru
Posts: 642

View Profile WWW
« Reply #1 on: September 06, 2009, 12:56:28 PM »

Hi Lisa,

No need to file a bug report. The thing is you have configured Konqueror to be the default browser, but Konqueror is himself set - by default - to launch Firefox when you click on html links !

Go to  Configuration > Configure Konqueror > File management > File association. Type 'html' in the search box. Change the behaviour of both 'html' entries in 'application' and 'text'. Under the 'General' tab, change the application's preference order. Under the 'Incorporation' tab, configure the left click in order to display html page in Konqueror.

Then go to Configuration > Configure Konqueror > General. There, you can change the start-up page to the page of your choice.
« Last Edit: September 06, 2009, 13:06:36 PM by PhiX » Logged

Team Pardus-fr - French Pardus tools translator
« Reply #2 on: September 06, 2009, 14:08:22 PM »

you can  do this:

System settings - General - Default Applications - Web browser - Default component (change to Konqueror)

« Last Edit: April 29, 2011, 10:48:07 AM by waf » Logged
Pardus Guru
Posts: 841

View Profile
« Reply #3 on: September 06, 2009, 18:25:28 PM »

Hi Phix and waf,

(oh, I am fickle.  I did grab the latest kernel  5-126 because I wanted sound  Wink  )

waf, I did try that and it didn't do anything.  But I thought for certain this was why it was a bug as it didn't heed the change I made by changing/selecting "konqbrowser".

PhiX, that worked!  As you wrote, I had to make sure I changed both application and text and "move up" Konqueror.  Firefox was at top.   Boy, I never knew there were so many settings in Konqueror.  Sometimes you have to dig deep!   Cheesy

Thanks so much!
Regards, Lisa Marie
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!