Welcome, Guest. Please login or register.
April 16, 2014, 23:52:29 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  grub-install Freezes the system [Solved]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: grub-install Freezes the system [Solved]  (Read 1820 times)
Ganesh
Pardus fellow craft
**
Gender: Male
Posts: 79



View Profile
« on: September 08, 2009, 08:27:58 AM »

Hi,

I have installed Pardus 2009.
When i try to do grub-install /dev/sda, i receive the following message

Due to a bug in xfs-freeze, the follwoing command might produce segmentation fault when
/boot/grub is not in an xfs file system. This error is harmless and can be ignored.



After this the system freezes. I have to do a hard shutdown to come out of the situation.

What could be the problem?

Ganesh


« Last Edit: September 09, 2009, 12:03:39 PM by Ganesh » Logged

Speak Your Truth and Clearly; and listen to others, even the dull and ignorant; they too have their story. ('Cheesy')
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: September 08, 2009, 15:25:20 PM »

What could be the problem?
I have the same behavior. It's probably a bug in Pardus.
You can also use this manual to restore Grub. Wink
Logged
bubbel
Guest
« Reply #2 on: September 08, 2009, 18:01:27 PM »

What could be the problem?

Hello Ganesh,

I wrote about this a Bug  Wink

Greetings
bubbel
Logged
Ganesh
Pardus fellow craft
**
Gender: Male
Posts: 79



View Profile
« Reply #3 on: September 08, 2009, 19:39:10 PM »

Hey atolboo,

Thanks for your help. I will try to fix using manual suggested by you.

Ganesh

Logged

Speak Your Truth and Clearly; and listen to others, even the dull and ignorant; they too have their story. ('Cheesy')
Ganesh
Pardus fellow craft
**
Gender: Male
Posts: 79



View Profile
« Reply #4 on: September 09, 2009, 12:02:45 PM »

Hey atolboo,

I had installing Pardus 2009 through 4 GB USB drive.
After it finished installing, I found that the boot loader was not installed.

But Thanks to help, i was able to fix the grub boot issue.

Is this a problem with Pardus or would I have done something wrong?

Ganesh
Logged

Speak Your Truth and Clearly; and listen to others, even the dull and ignorant; they too have their story. ('Cheesy')
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #5 on: September 09, 2009, 13:42:40 PM »

........... would I have done something wrong?
No, you didn't do anything wrong. 
Is this a problem with Pardus ....
The Pardus*.iso is built to make an installation CD.
And thus it has some problems when you use it as an USB device. Sad
I found this link.
As it's not very practical, I modified what I did see there and made the Wiki page.
(By the way, my knowledge of Turkish is zero.)
I still have to modify this part to look like this one.
Logged
bubbel
Guest
« Reply #6 on: September 27, 2009, 13:57:56 PM »

@Ganesh

the developer wants the following outputs:

Quote
------- Comment #1 From Onur Küçük 2009-09-27 14:49:14 -------
can you give the output of commands

disktype /dev/sd*

fdisk -l

mount

cat /boot/grub/device.map

dmesg

as an "attachment" to this bug ? To get the output just do

command &> /tmp/infofile

and the output will be written as /tmp/infofile

you can change the name of the output file

And put it here or directly here  Wink

Greetings
bubbel
« Last Edit: September 27, 2009, 14:04:57 PM by bubbel » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #7 on: September 27, 2009, 17:34:40 PM »

the developer wants the following outputs:
The "grub-install /dev/...." command is working in P2008 but not in P2009.
You can test this and add the requested output to the bug repport.

     >HERE< you can find the manual how to do this in a running P2008 or P2009 system.
« Last Edit: November 19, 2009, 16:44:33 PM by atolboo » Logged
Andreas
Guest
« Reply #8 on: November 19, 2009, 15:36:30 PM »

Hello together,

have please a look in Bug Comment #8

Greetings
Andreas
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!