Welcome, Guest. Please login or register.
April 23, 2014, 16:29:48 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  S/w compilation Error
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: S/w compilation Error  (Read 1289 times)
Ganesh
Pardus fellow craft
**
Gender: Male
Posts: 79



View Profile
« on: September 27, 2009, 08:02:15 AM »

Hey, I had these compilation errors.

cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
-- Found Qt-Version 4.5.2 (using /usr/qt/4/bin/qmake)
CMake Error at /usr/kde/4/share/apps/cmake/modules/FindX11.cmake:389 (MESSAGE):
Could not find X11
Call Stack (most recent call first):
/usr/kde/4/share/apps/cmake/modules/FindQt4.cmake:1460 (FIND_PACKAGE)
/usr/kde/4/share/apps/cmake/modules/FindKDE4Internal.cmake:291 (find_package)
/usr/share/cmake-2.6/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)
CMakeLists.txt:3 (find_package)

-- Configuring incomplete, errors occurred!

what could be the reason.
Thanks
Logged

Speak Your Truth and Clearly; and listen to others, even the dull and ignorant; they too have their story. ('Cheesy')
bubbel
Guest
« Reply #1 on: September 27, 2009, 09:46:33 AM »

Hello Ganesh,

did you install for compiling the following packages: Wink

kernel-source, kernel-headers, gcc and make

Greetings
bubbel
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #2 on: September 27, 2009, 10:08:10 AM »

..and not to forget cmake
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Ganesh
Pardus fellow craft
**
Gender: Male
Posts: 79



View Profile
« Reply #3 on: September 27, 2009, 11:06:04 AM »

Hi,

Except for kernel-source, i have installed rest of the packages.

I will let you know the result after installing  the missing package.

Thanks
Ganesh
Logged

Speak Your Truth and Clearly; and listen to others, even the dull and ignorant; they too have their story. ('Cheesy')
Ganesh
Pardus fellow craft
**
Gender: Male
Posts: 79



View Profile
« Reply #4 on: September 27, 2009, 11:34:21 AM »

I am trying to install Plasma theme Nirogen from kde-look.org.

After installing all the required packages, I issued the command,


cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` .

and got the following errors.


-- Found Qt-Version 4.5.2 (using /usr/qt/4/bin/qmake)
CMake Error at /usr/kde/4/share/apps/cmake/modules/FindX11.cmake:389 (MESSAGE):
  Could not find X11
Call Stack (most recent call first):
  /usr/kde/4/share/apps/cmake/modules/FindQt4.cmake:1460 (FIND_PACKAGE)
  /usr/kde/4/share/apps/cmake/modules/FindKDE4Internal.cmake:291 (find_package)
  /usr/share/cmake-2.6/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)
  CMakeLists.txt:3 (find_package)


-- Configuring incomplete, errors occurred!

What else is required?

Ganesh
Logged

Speak Your Truth and Clearly; and listen to others, even the dull and ignorant; they too have their story. ('Cheesy')
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #5 on: September 27, 2009, 12:59:37 PM »

Quote
  Could not find X11
It's possible that this error comes from the fact that Pardus is not LSB-compliant and therefore that some paths are wrong. I think it's best to send the error to the author of the theme. He will tell you what source file to edit to make it work on Pardus.
Logged

Team Pardus-fr - French Pardus tools translator
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!