Welcome, Guest. Please login or register.
April 19, 2014, 01:28:23 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  LyX 1.6.4
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: LyX 1.6.4  (Read 4581 times)
superleste
Newbie
*
Posts: 9


View Profile
« on: October 07, 2009, 16:10:59 PM »

Hello,

I am using the newest version of Pardus (2009). Shortly I am also using LyX. Not so long time ago there was an update in the package manager for this program. (LyX 1.6.4) Despite of the update I have still the next problems

1. If I want to see my report in DVI format, lyx opens the DVI with Okular. But it is impossible to read the letters. (see attachment)

2. If I want to see the PDF format I get the next error-message:

File does not exist: /tmp/lyx_tmpdir.MT1186/lyx_tmpbuf0/verslag.pdf

Is this a bug or a problem with my LyX settings??

Thank you

Ronald


* dvi_okular.png (163.09 KB, 1280x800 - viewed 75 times.)
Logged
waf
Guest
« Reply #1 on: October 07, 2009, 16:45:41 PM »

You can try kile or texmaker.
Wellcome!
« Last Edit: April 29, 2011, 10:52:12 AM by waf » Logged
James T
Pardus Master
***
Posts: 155



View Profile
« Reply #2 on: October 07, 2009, 18:23:41 PM »

1. If I want to see my report in DVI format, lyx opens the DVI with Okular. But it is impossible to read the letters. (see attachment)

I think the problem is in the default KDE settings rather than LyX specifically: you need to change your file associations (this can be done in a number of places, the "system settings" program, the "configure konqueror" item in the konqueror settings menu, and I guess somewhere in Dolphin's menus). The default appears to be Okular, so you could try moving "Document viewer" up, or adding "xdvi" at the top of the list to see if they work better.
Logged
James T
Pardus Master
***
Posts: 155



View Profile
« Reply #3 on: October 07, 2009, 19:18:41 PM »

Actually I just realized a more likely explanation of the rendering problem, since Okular displays DVI's just fine on my Kubuntu machine, so I suspect that the problem is missing fonts rather than wrong application.
Logged
superleste
Newbie
*
Posts: 9


View Profile
« Reply #4 on: November 26, 2009, 14:14:01 PM »

Ok, I tried to install the fonts with:

'updmap --enable Map=txfonts.map'

in a terminal and it worked (the installation)

BUT, still Lyx 1.6.4 does not manage to create a PDF nor DVI.
Logged
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #5 on: November 26, 2009, 21:28:34 PM »

Hi, superleste (Ronald),

Welcome to the Pardus Forums! I am not a LyX user (I use LaTeX instead), so I only know enough about LyX to get myself in trouble. However, I might have found a workaround for you to try.

I just installed LyX on my Pardus 2009, and it brought along the following dependencies with it: libXp; openmotif; aiksaurus; and xdvik. < Edit: > (I should mention that I had previously installed TeX Live, which includes base components such as tex, latex, etc. I suspect that LyX also requires these as dependencies, so it's likely that your download of LyX and related packages would have been larger than mine).

I created a brief test document and tried to produce both a DVI and a PDF file. I included a few foreign-language diacritics (accute accent, circumflex accent, cedille, tilde).

The results: Pressing the "View DVI" button on the toolbar did produce output, but xdvik was very slow in appearing on the screen (it took maybe 1-1.5 minutes). Also, the foreign diacritics were missing from the DVI (I'm not sure why).

Pressing the "View PDF" button worked better for me. The file was displayed by Okular (which started up quickly) and all of the foreign diacritics displayed correctly.

You might try this suggestion and see if it will fix your problem. It will reconfigure LyX's preferences to use Okular to display DVIs:

Start up LyX and go to Tools > Preferences. A new window will open; in its left-hand pane, look for File Handling and then choose File formats. Then, in the right-hand window pane, look for the Format: box at the top of the window. It has a drop-down menu beside it; from there, choose DVI. In the Viewer: box, change the default xdvik to okular. Then click on the Save button.

In order to complete the configuration change, in LyX's main GUI window, go to Tools > Reconfigure. After doing this, you will see a dialog box that says your setup has been reconfigured and that you must close LyX and restart it for the changes to take effect.

I am attaching two screenshots which will show the configuration preferences better (I hope).

Interestingly enough, the default configuration for viewing PDFs is to use "xdg-open" rather than Okular. (I have not changed this in any way, and Okular opens with no problem).

Hope this helps and Good luck,
=david

P.S. to waf:

If I understand correctly, LyX is a stand-alone environment which uses LaTeX as its typesetting engine. The LyX GUI has its own built-in editor, so users do not need to install a separate editor such as Kile or Texmaker.  


* lyx-config-dvi.png (47.1 KB, 668x535 - viewed 82 times.)

* lyx-config-pdflatex.png (47.84 KB, 668x535 - viewed 72 times.)
« Last Edit: November 26, 2009, 22:34:07 PM by kalwisti » Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
superleste
Newbie
*
Posts: 9


View Profile
« Reply #6 on: November 26, 2009, 22:31:43 PM »

Hey kalwisti,

Thanks for your reply. I followed your instructions and this is my results. (see attachments)

Still not good. Really strange.

Ronald


* lyx_dvi.png (119.41 KB, 1280x800 - viewed 59 times.)

* lyx_pdf.png (184.29 KB, 1280x800 - viewed 61 times.)
Logged
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #7 on: November 26, 2009, 22:54:20 PM »

Hi, Ronald,

You're very welcome. Hmm ... I agree that those results look strange. I think that James T's hunch about missing fonts may be correct.

I will try investigating further this evening to see if I stumble upon something. However, since my LyX knowledge is extremely basic, in the meantime I suggest that you try asking in two LyX-specific user forums. Hopefully, someone more familiar with LyX can tell you what's going wrong:

http://n2.nabble.com/LyX-f475766.html
LyX Forum

http://www.latex-community.org/forum/viewforum.php?f=19
LaTeX Community Forum -- LyX Subforum

(You'll first need to register with the LaTeX Community Forum [which is a pretty friendly place, I've used it before]. I'm not sure about the LyX Forum, as I haven't ever tried it).

I've seen occasional LyX-related questions posted to the comp.text.tex Usenet newgroup, but I think you would have better luck with the Web-based forums.

With best wishes,
=david
Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #8 on: November 26, 2009, 23:31:26 PM »

Hi, Ronald,

Just another thought ... If your problem is possibly related to missing fonts, it occurred to me that it might be helpful for you to see which fonts I have installed on my system. (I did a PiSi search from the command line; with luck, this lists everything).



Code:
david-pardus david # pisi search lyx                                                                                                        
lyx - Graphical frontend for LaTeX                                                                                                            
gv - Standard ghostscript frontend used by programs like LyX
   

                                                                            
Code:
david-pardus david # pisi search fonts
Nafees-Naskh-fonts - Nafees Naskh font for Urdu language                                                                                      
ecofont - Eco friendly and cost reducing printing fonts                                                                                        
texlive-fontsrecommended - TeXLive Recommended fonts                                                                                          
fontforge - Font editor and converter
libXfont - X.Org Xfont library
dejavu-fonts - DejaVu fonts
texlive-fontsextra - TeXLive Extra fonts
Gentium-basic-fonts - Gentium Basic TTF font
gbdfed - Bitmap font editor
Charis-compact-fonts - A version of Charis SIL with tighter line spacing
Nafees-Web-Naskh-fonts - Nafees Web Naskh font for Urdu language
Inconsolata-fonts - A font similar to the TheSansMono
graphviz - Open source graph drawing software
urw-fonts - Free versions of the 35 standard PostScript fonts
Bitstream-Vera-fonts - Bitstream Vera TTF Fonts
droid-fonts - Droid is a TrueType font family intended for use on the small screens of mobile handsets
Gentium-fonts - Unicode enabled TTF font
MgOpen-fonts - MgOpen TTF Fonts
Libertine-fonts - A font similar to Times New Roman
liberation-fonts - Font collection similar to ones found in Microsoft Windows
t1utils - Type 1 Font utilities
ftgl - Font rendering library for OpenGL
freefont - Free UCS Outline Fonts
arkpandora-fonts - Arkpandora MS-TTF replacement font pack
Tiresias-fonts - Tiresias TTF Fonts
gnu-gs-fonts-std - Ghostscript standard fonts
Doulos-fonts - A font similar to Times/Times New Roman with only regular face
xorg-font - XOrg font files
ttf2pt1 - TrueType to Type1 font converter
ttmkfdir - A utility to create a fonts.scale file from a set of TrueType fonts
Nafees-Riqa-fonts - Nafees Riqa font for Urdu language
scheherazade-fonts - An Arabic true type font
Nafees-Pakistani-Naskh-fonts - Nafees Pakistani Naskh font Urdu language
Nafees-Nastaleeq-fonts - Nafees Nastaleeq font for Urdu languages
tv-fonts - TV Fonts for Xawtv
t1lib - A Type 1 Font Rasterizer Library for UNIX/X11
Stix-fonts - Stix Fonts
xorg-font-extra - XOrg font files
lcdf-typetools - Font utilities for eg manipulating OTF
Charis-fonts - A font similar to Bitstream Charter
graphviz-docs - Open source graph drawing software
aquafont - Far East fonts

Also, I noticed that the default TeX encoding is for T1 fonts (under Preferences > Output > LaTeX > TeX encoding: ), so here's what a PiSi search for "T1" turned up on my system:

Code:
david-pardus david # pisi search T1
twolame - An optimised MPEG Audio Layer 2
t1utils - Type 1 Font utilities
terminus-font - Fixed point font
xterm - Terminal emulator for the X Window System
ttf2pt1 - TrueType to Type1 font converter
t1lib - A Type 1 Font Rasterizer Library for UNIX/X11
minicom - Text-based modem control and terminal emulation program

Maybe you are missing t1utils and/or ttf2pt1? Just a stab in the dark ...


HTH, =david
« Last Edit: November 26, 2009, 23:45:17 PM by kalwisti » Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
superleste
Newbie
*
Posts: 9


View Profile
« Reply #9 on: November 27, 2009, 11:13:22 AM »

Hej kalwisti,

I got the same results in the terminal when pisi search this all. But thanks again for the advise.

Ronald
Logged
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #10 on: November 27, 2009, 21:25:37 PM »

Hi, Ronald,

Sorry I haven't been able to help you very well. I hope that a knowledgeable LyX user from one of those forums will be able to point you in the direction of a solution.

Here are a few more pieces of evidence which might help you with troubleshooting. I also have LyX installed in Ubuntu 8.04 LTS and in PCLinuxOS 2009, and I looked at their settings:

Ubuntu:
LyX ver. 1.5.3
DVI display works: with Evince (although the viewer is configured as "xdg-open")
PDF display works: with Evince (although configured as "xdg-open")
TeX encoding = T1

PCLinuxOS:
LyX ver. 1.6.4.1
DVI display works: with xdvik (viewer configured as "xdvi")
PDF display does not work: Produces error message about "File [X] does not exist".  (Current viewer configuration is "kpdf")
TeX encoding = T1

(I will attach screenshots of those configuration settings).

As a last resort, another thing you might try (you may have done this already) is to completely uninstall LyX and then reinstall the program. This technique has sometimes worked for me when an application is behaving strangely and I haven't been able to figure out what's causing the problem.

If you solve the problem, please post back and let us know how you did it. Good luck,
=david


* lyx-ubuntu-dvi-config.png (56 KB, 606x577 - viewed 63 times.)

* lyx-ubuntu-latex-config.png (44.16 KB, 606x577 - viewed 59 times.)

* lyx-ubuntu-pdflatex-config.png (57.6 KB, 606x577 - viewed 55 times.)

* lyx-ubuntu-pdftex-config.png (56.08 KB, 606x577 - viewed 61 times.)
Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #11 on: November 27, 2009, 21:28:01 PM »

Here are the configuration screenshots for PCLinuxOS 2009 (with LyX 1.6.4.1).


* lyx-pclos-dvi-config.png (38.88 KB, 680x518 - viewed 66 times.)

* lyx-pclos-latex-config.png (46.53 KB, 680x518 - viewed 60 times.)

* lyx-pclos-pdflatex-config.png (39.67 KB, 680x518 - viewed 71 times.)

* lyx-pclos-pdftex-config.png (40.75 KB, 680x518 - viewed 65 times.)
Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #12 on: November 28, 2009, 02:21:33 AM »

Hi again, Ronald,

Thanks to Google and some semi-educated guesses  Smiley, I found some additional info which might be useful. I think the component you might be missing is the cmsuper font package (which contains Type 1 fonts converted from METAFONT fonts). I am fairly certain that it is part of TeX Live; in PCLinuxOS, the subpackage is named texlive-texmf-cmsuper but I do not know what it is called in Pardus. (The Pardus developers seem to have "bundled" TeX Live in a slightly different way). I did a PiSi search of my installed packages, but did not find anything called "cmsuper" or "cm-super."

My hunch is that it might be included in one of these two packages:

texlive-fontsrecommended
texlive-fontsextra

So you might check to see if both of those packages are installed on your system.

The other useful tip I found is where LyX keeps a log of its activity. (LyX is an offshot of TeX / LaTeX, and the TeX program is meticulous about keeping track of what it does). On my system, this log can be read in the following directory:

/tmp/lyx_tmpdir.MT1080/lyx_tmpbuf0/

LyX generates a file called [filename].log when you compile your source file and try to generate either a DVI or a PDF. Even if LyX encounters an error and is unable to create a DVI / PDF, it will nonetheless create this .log file which will include some details about the error(s). You can open up the .log file and view it with KWrite (or any text editor).

So my suggestion is to start LyX and attempt to produce a PDF file from your source. Immediately afterwards, navigate to that temporary directory and look at the .log file that LyX created. Even if the PDF creation is unsuccesful, TeX should log some sort of info about why it failed.

Even if I cannot understand the error message, you now know where to look for it and can show it to a more knowledgeable LyX user. HTH,

=david 

P.S.
By installing the cmsuper package in PCLinuxOS, I was able to get LyX to successfully produce PDFs. I looked at the .log file and read that the error was because TeX was unable to find the cmsuper fonts. I hope your PDF issue can be solved just as easily.

Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
superleste
Newbie
*
Posts: 9


View Profile
« Reply #13 on: November 28, 2009, 11:56:08 AM »

Hey again,

Good advise to look in the .log file. Always good to do. Here is the result:

!pdfTeX error: pdflatex (file ecbx1000): Font ecbx1000 at 600 not found
 ==> Fatal error occurred, no output PDF file produced!

So I googled this error, but couldn't really find THE solution. Still continue now, but maybe you have encountered this problem before.

Ronald
Logged
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #14 on: November 29, 2009, 06:21:39 AM »

Hi again, Ronald,

Just a few more suggestions about things you can try before I give up on this. (You might have seen and/or tried these already). I have done more searching and found some interesting tidbits. However, the basic problem (for me, at least) is that one needs in-depth, technical knowledge of both TeX's and LyX's guts to understand what is going wrong. I have neither, unfortunately ...

There is an interesting thread on the Arch Linux Forums you might read:

http://bbs.archlinux.org/viewtopic.php?id=83276
"[Solved] Lyx: pdf preview and pdf generation doesn't work."
(From the Arch Linux User Forums)
User "bender02" offers a concise explanation of how TeX finds available fonts (in post #6).

One of the suggestions is to run texhash to help TeX know where to look for fonts. (You must do this as root). When I did it on my system, I got the following output:

Code:
david-pardus david # texhash
texhash: Updating //etc/texmf/ls-R...
texhash: Updating /usr/share/texmf/ls-R...
texhash: Updating /usr/share/texmf-dist/ls-R...
texhash: Updating /usr/share/texmf-site/ls-R...
texhash: Updating //var/lib/texmf/ls-R...
texhash: Done.

Also, you might run the two commands below and see how my output compares to yours:

Code:
david@david-pardus ~ $ whereis pdflatex
pdflatex: /usr/bin/pdflatex /usr/share/man/man1/pdflatex.1

david@david-pardus ~ $ kpsewhere ecbx1000.tfm
/usr/share/texmf-dist/fonts/tfm/jknappen/ec/ecbx1000.tfm

I learned there is an easier way to access the TeX / LaTeX log file. Rather than navigating to the /tmp directory, just go to LyX's main menu and choose Document > LaTeX Log.

At this point, I have run out of ideas. If running texhash doesn't fix the problem, and you have both pdflatex and the ecbx1000.tfm font installed, my recommendation is for you to ask on a LyX-specific forum. I did see that there are several LyX mailing lists you could try:

http://www.lyx.org/MailingLists

I'm sorry that I haven't been able to help you more with this. I've learned some useful things about LyX but its inner workings remain a Great Mystery to me. If you're able to solve the problem, I'd be very interested in hearing what the fix was.

With best wishes,
=david

 
Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!