Welcome, Guest. Please login or register.
April 17, 2014, 06:35:52 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  [SOLVED]Pavi - Pardus VirtualBox Installer
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: [SOLVED]Pavi - Pardus VirtualBox Installer  (Read 5086 times)
LinuxFanatic
Pardus Master
***
Gender: Male
Posts: 177



View Profile WWW
« on: October 31, 2009, 02:31:30 AM »

Hi altogether,

The goal of Pavi is to make installation of the popular visualization Software "Sun xVM VirtualBox" easier on Pardus GNU/Linux.

Pavi can download and install VirutalBox for you automatically from the internet - or you can select any locally saved *.run - file of your wish and Pavi will install it!  Grin

    Pardus 2008:



         Pardus 2009




Features of Pavi:
  • Fully compatible with Pardus 2008 (KDE 3.5.x) and Pardus 2009 (KDE 4.x)
  • Making usb support available on Pardus GNU/Linux
  • Automated update from the Internet
  • Automatically configuration all kind of needed settings - so that every user will be able use VirtualBox
  • Automatically patching the kernel after a newer one is installed (kernel upgrade)
  • Automated installation of VirtualBox
  • Manually installation of any VirtualBox installation file available
  • Automated removing of VirtualBox
  • Multilingual user interface:
     - Dutch
     - English
     - German
     - Spanish
     - Turkish
    If you are interested to use Pavi in your native language - just let us know Wink


Download for Pardus 2009: pavi-2.4-18.pisi

Download for Pardus 2008: pavi-2.4-18.pisi

Or you can browse in the online interface of our PardusUser.de - community repository:
http://www.pardususer.de/index.php?action=repository

Discussions for German speaking users is in the German Pardus user forum possible:
http://forum.pardususer.de/index.php?topic=551.0


Have a nice time,
Gürkan
« Last Edit: November 01, 2009, 11:02:34 AM by Michiel » Logged


German Pardus Linux Communtiy --> www.PardusUser.de
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #1 on: October 31, 2009, 09:25:18 AM »

Looks very nice and easy! Thanks!
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #2 on: October 31, 2009, 09:34:17 AM »

Hmm..first bug report.

Following installing pavi and then opening pavi either from the menu or in the Konsole iut gets stuck in a loop in the first popupscreen where you choose the preferred language. If I choose dutch or english I keep getting the same window being returned, it does not apss this window.

In the Konsole it mentions:
Code:
michiel@laptop ~ $ pavi
/usr/bin/pavi: line 538: /home/michiel/.kde/share/config/pavirc: Bestand of map bestaat niet

and I get ‘/home/michiel/.kde/share/config/’ does not exist.

Have you put the 2008 and 2009 pisi links in wrong order?

I downloaded the "2009" version, but in there there is only .kde4, not a .kde folder?
« Last Edit: October 31, 2009, 09:37:10 AM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #3 on: October 31, 2009, 12:49:35 PM »

In 2008 this works without problems, in 2009 version .kde4 instead of .kde should be specified in the pspec.xml package/ source code (which I do not have)
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: October 31, 2009, 13:22:18 PM »

Following installing pavi and then opening pavi either from the menu or in the Konsole iut gets stuck in a loop in the first popupscreen where you choose the preferred language. If I choose dutch or english I keep getting the same window being returned, it does not apss this window.
I can confirm this behavior for pavi-2.4-17  in P2009.  
and to end this situation start System Monitor > right-click > Kill Process for pavi + pavi-2.4.sh and close Pardus VirtualBox Installer 2.4 - KDialog  window.

In 2008 this works without problems, ......
This version is  
Logged
LinuxFanatic
Pardus Master
***
Gender: Male
Posts: 177



View Profile WWW
« Reply #5 on: November 01, 2009, 00:53:21 AM »

I think I found a solution for this bug. You can download the new build of Pavi PiSi package from the first post above (pavi-2.4-18.pisi).

Please test it again and give me a feedback, if the bug is fixed Smiley

Regards,
Gürkan
Logged


German Pardus Linux Communtiy --> www.PardusUser.de
bubbel
Guest
« Reply #6 on: November 01, 2009, 06:02:43 AM »

You can download the new build of Pavi PiSi package from the first post above (pavi-2.4-18.pisi).


pavi-2.4-18 for Pardus 2008 and 2009 not found on your server .

For information.

Greetings
bubbel
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #7 on: November 01, 2009, 08:57:50 AM »

I think I found a solution for this bug. You can download the new build of Pavi PiSi package from the first post above (pavi-2.4-18.pisi).

Please test it again and give me a feedback, if the bug is fixed Smiley

Regards,
Gürkan

I would prefer a more elegant solution then the one you mention in the German forum:
Quote
Aber ich denke, ich weiß auch schon warum es zu diesem Fehler kommt; Wie ich festgestellt habe, ist nicht auf jedem System der Ordner ~/.kde/.../ vorhanden. Daher werde ich in wenigen Minuten ein weiteres Update einspielen - bei dem die Einstellungen direkt im Persönlichen Ordner abgespeichert werden (~/.pavirc) ...

Why don't you use just /.kde4 for Pardus 2009 and /.kde for Pardus 2008?
Why do you go back to the home/username folder whilst in Pardus 2009/KDE4 all similar config files reside in /home/username/.kde4/share/config ?

The only thing that has to changed for 2009 is putting the number 4 behind /.kde !

I hope you are open for this suggestion.

Also the 2.4-18 pavi package is currently not yet available for downlaod I noticed (like bubbel already mentioned)
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
LinuxFanatic
Pardus Master
***
Gender: Male
Posts: 177



View Profile WWW
« Reply #8 on: November 01, 2009, 10:29:30 AM »

Hi Michiel,

our server was yesterday midnight down, because maintaining ... Sorry!

The sever is now online and the package(s) are avaiably again now Smiley

I would prefer a more elegant solution then the one you mention in the German forum:
Quote
Aber ich denke, ich weiß auch schon warum es zu diesem Fehler kommt; Wie ich festgestellt habe, ist nicht auf jedem System der Ordner ~/.kde/.../ vorhanden. Daher werde ich in wenigen Minuten ein weiteres Update einspielen - bei dem die Einstellungen direkt im Persönlichen Ordner abgespeichert werden (~/.pavirc) ...

Why don't you use just /.kde4 for Pardus 2009 and /.kde for Pardus 2008?
Why do you go back to the home/username folder whilst in Pardus 2009/KDE4 all similar config files reside in /home/username/.kde4/share/config ?

The only thing that has to changed for 2009 is putting the number 4 behind /.kde !

I hope you are open for this suggestion.

Of course suggestions and feedbacks are welcome. I promise you that I'm going to make a more elegant solution for the next update of Pavi. But before that, I should know if the current release of Pavi is working now ...


Regards,
Gürkan
Logged


German Pardus Linux Communtiy --> www.PardusUser.de
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #9 on: November 01, 2009, 10:48:41 AM »

Confirmed. It works now as it should in 2009.


* pavi09.png (235.78 KB, 1280x800 - viewed 233 times.)
« Last Edit: November 01, 2009, 11:03:24 AM by Michiel » Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
LinuxFanatic
Pardus Master
***
Gender: Male
Posts: 177



View Profile WWW
« Reply #10 on: November 02, 2009, 20:40:43 PM »

Hi Michiel,

That's good to hear!  Grin

Now I can continue the development of Pavi again 

Sincerely,
Gürkan
Logged


German Pardus Linux Communtiy --> www.PardusUser.de
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #11 on: November 02, 2009, 23:57:56 PM »

Now I can continue the development of Pavi again 
Logged
paragchatterjee
Newbie
*
Gender: Male
Posts: 2



View Profile
« Reply #12 on: June 03, 2010, 07:46:26 AM »

Confirmed. It works now as it should in 2009.


At first let me express my apology as I am posting my problem in an apparently solved topic. But I think this is the right place to post my problem which is as follows:

I Successfully installed Pavi  (in offline mode) using the downloaded .pisi file. First I save the pisi file in /<username>/home/Downloads folder & then double click on it. After a few seconds the installation completed successfully & the application shortcut is placed in Application > System location of Kickoff Menu.

Then I launched Pavi from the above-mentioned location and Choose install VirtualBox from the list of available options (the first one) as I already have Virualbox executable file (RUN file, both 32-bit as well as 64-bit, which I saved inside /<username>/home/Downloads folder). After directing the location of the 32-bit RUN file the installation starts. It shows  (in a black screen) messages like which components are already present in the system & which would be installed during installation. It also instructs that some dependencies needs to be resolved, so I choose Yes & let the installation to continue.

But after that the root: pavi window appears (a window with blue background) showing a message:   /usr/sbin/vboxdrv not found. New installation recommended


I don’t understand what went wrong! Can anyone please help?
Logged
Andreas
Guest
« Reply #13 on: June 03, 2010, 08:42:57 AM »

Can anyone please help?

Hello,

I think the problem has to do with this and should be fixed.  Wink

Greetings
Andreas
« Last Edit: June 03, 2010, 08:49:47 AM by Andreas » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #14 on: June 03, 2010, 09:52:47 AM »

I think the problem has to do with this and should be fixed.  Wink
I can confirm that this problem has been solved.
Update your system in Package Manager or in konsole with
Code:
sudo pisi up -y
and install VB again.
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!