Welcome, Guest. Please login or register.
April 23, 2014, 17:06:43 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  Packetmanager
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] 3 4 Go Down Print
Author Topic: Packetmanager  (Read 5745 times)
klurig
Pardus fellow craft
**
Posts: 39


View Profile
« Reply #15 on: January 02, 2010, 13:34:09 PM »

Try to just add the following:

Code:
sudo pisi add-repo 2009.1 http://packages.pardus.org.tr/pardus-2009.1/pisi-index.xml.bz2

Code:
sudo pisi update-repo


If these works will Pardus trying to upgrade to Pardus 2009.1 Beta. It may take some time. You do this in the terminal. I give you no guarantee that it works. You may choose whether you want to try or not. It's your choice.


« Last Edit: January 02, 2010, 17:33:30 PM by klurig » Logged
PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #16 on: January 02, 2010, 13:40:18 PM »

Mixing repositories from different version of Pardus is really not a good idea.
I suggest Hendrikus write a bug report on http://bugs.pardus.org.tr
Logged

Team Pardus-fr - French Pardus tools translator
klurig
Pardus fellow craft
**
Posts: 39


View Profile
« Reply #17 on: January 02, 2010, 13:45:34 PM »

Mixing repositories from different version of Pardus is really not a good idea.
I suggest Hendrikus write a bug report on http://bugs.pardus.org.tr

You are right, but it's strange that he can not remove repositories with terminal.

Klurig
Logged
Hendrikus Godvliet
Pardus Master
***
Posts: 202



View Profile WWW
« Reply #18 on: January 02, 2010, 15:35:17 PM »

Try to just add the following:

Code:
sudo pisi add-repo http://packages.pardus.org.tr/pardus-2009.1/pisi-index.xml.bz2

Code:
sudo pisi update-repo


If these works will Pardus trying to upgrade to Pardus 2009.1 Beta. It may take some time. You do this in the terminal. I give you no guarantee that it works. You may choose whether you want to try or not. It's your choice.






hendrikus@pardus ~ $ sudo pisi add-repo http://packages.pardus.org.tr/pardus-2009.1/pisi-index.xml.bz2
Wachtwoord:                                                                                           
add-repo (ar): Repository toevoegen                                                                   

Gebruik: add-repo <repo> <indexuri>

<repo>: naam van de toe te voegen repository
<indexuri>: IRI van indexbestand           

Als geen repo wordt gegeven, wordt add-repo pardus-devel als standaard toegevoegd

NB: We ondersteumen momenteel alleen lokale bestanden (bijv. /a/b/c) en http:// URI's


Options:
 --version                    : show program's version number and exit
 -h [--help]                  : show this help message and exit

 add-repo opties:
  --at arg                    : Toevoegen repository op gegeven positie (0 is
                                eerst)

 algemene opties:
  -D [--destdir] arg          : Wijzig de systeem root voor PiSi-commando's
  -y [--yes-all]              : Uitgaan van ja bij alle ja/nee vragen
  -u [--username] arg
  -p [--password] arg
  -L [--bandwidth-limit] arg  : Beperk bandbreedte gebruik tot aangegeven KB
  -v [--verbose]              : Gedetailleerde uitvoer
  -d [--debug]                : Toon debuginformatie
  -N [--no-color]             : Onderdrukt kleuren van PiSi-uitvoer

hendrikus@pardus ~ $ sudo pisi update-repo
* Updaten repository: pardus-2009
pisi-index.xml.bz2.sha1sum     (40.0  B)100%    253.62 KB/s [00:00:00] [compleet]
pardus-2009 repository informatie is nog recent.
* Updaten repository: contrib
pisi-index.xml.bz2.sha1sum     (40.0  B)100%    294.15 KB/s [00:00:00] [compleet]
contrib repository informatie is nog recent.


Sorry that i post evrything but so you know that a did made up your advice


You see nothing happend
Logged

Hendrikus Godvliet
Pardus Master
***
Posts: 202



View Profile WWW
« Reply #19 on: January 02, 2010, 15:37:59 PM »

I suggest Hendrikus write a bug report on http://bugs.pardus.org.tr

I wil write a bug report on http://bugs.pardus.org.tr

Well at least that is wath i can do.

Everybody who helped me, thanks for that  Wink

Logged

PhiX
Pardus Guru
****
Posts: 642



View Profile WWW
« Reply #20 on: January 02, 2010, 15:39:07 PM »

Mixing repositories from different version of Pardus is really not a good idea.
I suggest Hendrikus write a bug report on http://bugs.pardus.org.tr

You are right, but it's strange that he can not remove repositories with terminal.

Klurig

It's the most serious pisi bug I have ever seen. I think it has to be reported as a bug, even though there is an upcoming version of Pardus.
Logged

Team Pardus-fr - French Pardus tools translator
trixon
Guest
« Reply #21 on: January 02, 2010, 16:37:30 PM »

You will have to set a name for the repo too.
Code:
sudo pisi add-repo 2009.1 http://packages.pardus.org.tr/pardus-2009.1/pisi-index.xml.bz2
Logged
klurig
Pardus fellow craft
**
Posts: 39


View Profile
« Reply #22 on: January 02, 2010, 17:32:32 PM »

You will have to set a name for the repo too.
Code:
sudo pisi add-repo 2009.1 http://packages.pardus.org.tr/pardus-2009.1/pisi-index.xml.bz2


Thanks Trixon it is I who have done wrong. I'm sorry. It is good that you notify me. I will now change so my command is correct.

Klurig

 Embarrassed
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #23 on: January 03, 2010, 19:40:34 PM »

Lisa
Atolboo from the dutch forum expect that this will not work because (if the problem is caused by Pisi) history of the program manager Pisi need to restore the entire trade.

I've tried it. But the history backup doesn't react, to earlier setups.

Did you made a bug report of this Pisi item?
Hi Hendrikus.  Sorry for the somewhat late reply.

I didn't file a bug report because the updates I did from the command line ( I usually use CLI in konsole to do updates "sudo pisi up")  on the 25th repaired the problem for me.   

Here's the recent history of my
Code:
pisi hs

to show you what was updated.  Operation #80 fixed it for me:
Code:
Operation #82: install
Date: 2009-12-25 18:43

    * notify-python 0.1.1-4-2 is installed.
    * system-config-printer-gtk 1.1.8-14-1 is installed.

Operation #81: install
Date: 2009-12-25 17:59

    * glibc-zoneinfo 2.9-45-10 is installed.
    * hplip-gui 3.9.8-37-5 is installed.

Operation #80: upgrade
Date: 2009-12-25 17:31

    * glibc-zoneinfo 2.9-45-10 is removed.
    * timezone 0.0_20091214-1-1 is reinstalled.
    * lsb-release is upgraded from 1.4-5-7 to 1.4-6-8 with delta.
    * pisi is upgraded from 2.2.16-150-41 to 2.2.16-151-42.
    * baselayout is upgraded from 3.1-120-29 to 3.1-120-30 with delta.
    * kdm is upgraded from 4.3.4-92-55 to 4.3.4-94-56 with delta.
    * cursor-theme-oxygen-black is upgraded from 4.3.4-92-48 to 4.3.4-94-49 with delta.
    * shared-mime-info is upgraded from 0.70-15-9 to 0.70-16-10 with delta.
    * digikam is upgraded from 1.0.0_rc-15-8 to 1.0.0-16-9 with delta.
    * kdebase-workspace is upgraded from 4.3.4-92-55 to 4.3.4-94-56 with delta.
    * QtCurve-KDE4 is upgraded from 0.69.2-17-11 to 0.69.2-18-12 with delta.
    * module-virtualbox-guest-userspace is upgraded from 3.0.10-14-10 to 3.1.2-15-11.
    * cursor-theme-oxygen-white is upgraded from 4.3.4-92-48 to 4.3.4-94-49 with delta.
    * xdg-user-dirs is upgraded from 0.10-3-4 to 0.12-4-5 with delta.
    * cursor-theme-oxygen-zion is upgraded from 4.3.4-92-48 to 4.3.4-94-49 with delta.
    * icon-theme-oxygen-png is upgraded from 4.3.3-2-8 to 4.3.4-3-9 with delta.
    * package-manager is upgraded from 2.0.1-78-22 to 2.0.1-79-23.
    * kipi-plugins is upgraded from 0.9.0-14-10 to 1.0.0-15-11 with delta.
    * foomatic-db is upgraded from 4.0_20091123-21-5 to 4.0_20091123-22-6 with delta.
    * module-virtualbox-guest is upgraded from 3.0.10-14-21 to 3.1.2-15-22.
* module-alsa-driver is upgraded from 1.0.21_20091206-54-28 to 1.0.22_20091224-55-29.
    * icon-theme-oxygen-index is upgraded from 4.3.3-2-8 to 4.3.4-3-9 with delta.
    * kaptan is upgraded from 4.0.14-48-23 to 4.0.14-52-27.
    * module-alsa-driver-userspace is upgraded from 1.0.21_20091206-54-10 to 1.0.22_20091224-55-11.
    * virtualbox-guest-utils is upgraded from 3.0.10-42-11 to 3.1.2-44-12 with delta.
    * artwork-pardus-release is upgraded from 2009-6-5 to 2009-8-6 with delta.

Operation #79: repository update
Date: 2009-12-25 16:28

    * pardus-test repository is updated.
    * pardus-2009 repository is updated.

Operation #78: upgrade
Date: 2009-12-22 22:39

    * glibc-zoneinfo 2.9-45-10 is installed.
    * pisi is upgraded from 2.2.16-148-39 to 2.2.16-150-41.
    * kdeartwork-styles is upgraded from 4.3.4-30-9 to 4.3.4-30-10 with delta.
    * kdm is upgraded from 4.3.4-92-54 to 4.3.4-92-55 with delta.
    * cursor-theme-oxygen-black is upgraded from 4.3.4-92-47 to 4.3.4-92-48 with delta.
    * qt-sql-mysql is upgraded from 4.5.3-72-16 to 4.5.3-72-17 with delta.
    * kdeartwork-emoticons is upgraded from 4.3.4-30-9 to 4.3.4-30-10 with delta.
    * kdepimlibs is upgraded from 4.3.4-30-8 to 4.3.4-30-9 with delta.
    * kdebase-workspace is upgraded from 4.3.4-92-54 to 4.3.4-92-55 with delta.
    * QtCurve-Gtk2 is upgraded from 0.65.0-19-6 to 0.69.2-20-7 with delta.
    * PyKDE is upgraded from 4.3.4-30-12 to 4.3.4-30-13 with delta.
    * kdelibs-experimental is upgraded from 4.3.4-3-3 to 4.3.4-3-4 with delta.
    * kdeartwork-colorschemes is upgraded from 4.3.4-30-9 to 4.3.4-30-10 with delta.
    * kdeedu-marble is upgraded from 4.3.4-31-7 to 4.3.4-31-8 with delta.
    * kdemultimedia is upgraded from 4.3.4-31-11 to 4.3.4-31-12 with delta.
    * cursor-theme-oxygen-white is upgraded from 4.3.4-92-47 to 4.3.4-92-48 with delta.
    * cursor-theme-oxygen-zion is upgraded from 4.3.4-92-47 to 4.3.4-92-48 with delta.
* qt-sql-sqlite is upgraded from 4.5.3-72-16 to 4.5.3-72-17 with delta.
    * kdepim is upgraded from 4.3.4-25-14 to 4.3.4-25-15 with delta.
    * kdebase is upgraded from 4.3.4-37-15 to 4.3.4-37-16 with delta.
    * kdebase-emoticons is upgraded from 4.3.4-42-21 to 4.3.4-42-22 with delta.
    * kdeutils is upgraded from 4.3.4-29-11 to 4.3.4-29-12 with delta.
    * kdenetwork is upgraded from 4.3.4-32-9 to 4.3.4-32-10 with delta.
    * kdeplasma-addons is upgraded from 4.3.4-21-10 to 4.3.4-21-11 with delta.
    * qt is upgraded from 4.5.3-72-16 to 4.5.3-72-17 with delta.
    * kdelibs is upgraded from 4.3.4-67-41 to 4.3.4-68-42 with delta.
    * kaptan is upgraded from 4.0.13-47-22 to 4.0.14-48-23 with delta.
    * kdegraphics is upgraded from 4.3.4-36-13 to 4.3.4-36-14 with delta.
    * kdeadmin is upgraded from 4.3.4-35-12 to 4.3.4-35-13 with delta.
    * kdebase-runtime is upgraded from 4.3.4-42-21 to 4.3.4-42-22 with delta.
    * kdeartwork-screensavers is upgraded from 4.3.4-30-9 to 4.3.4-30-10 with delta.

Operation #77: repository update
Date: 2009-12-22 22:38

    * contrib repository is updated.

Operation #76: repository update
Date: 2009-12-22 14:10

    * pardus-test repository is updated.
    * contrib repository is updated.

Operation #75: upgrade
Date: 2009-12-18 17:50

    * glibc-zoneinfo 2.9-45-10 is removed.
    * timezone 0.0_20091214-1-1 is installed.
    * pisi is upgraded from 2.2.15-147-38 to 2.2.16-148-39.
    * glibc is upgraded from 2.9-45-10 to 2.9-46-11 with delta.

I will check your bug report later so I can see if I have any information to add to it. 

Oh, Here are my repositories:
$ pisi lr
pardus-test [active]
   http://packages.pardus.org.tr/pardus-2009-test/pisi-index.xml.bz2
pardus-2009 [active]
   http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
contrib [active]
   http://packages.pardus.org.tr/contrib-2009/pisi-index.xml.bz2

Regards, Lisa Marie
« Last Edit: January 03, 2010, 19:49:46 PM by Lisa » Logged
Hendrikus Godvliet
Pardus Master
***
Posts: 202



View Profile WWW
« Reply #24 on: January 04, 2010, 12:07:25 PM »

Lisa
Atolboo from the dutch forum expect that this will not work because (if the problem is caused by Pisi) history of the program manager Pisi need to restore the entire trade.

I've tried it. But the history backup doesn't react, to earlier setups.

Did you made a bug report of this Pisi item?
Hi Hendrikus.  Sorry for the somewhat late reply.

I didn't file a bug report because the updates I did from the command line ( I usually use CLI in konsole to do updates "sudo pisi up")  on the 25th repaired the problem for me.    

Here's the recent history of my
Code:
pisi hs

to show you what was updated.  Operation #80 fixed it for me:
Code:
Operation #82: install
Date: 2009-12-25 18:43

    * notify-python 0.1.1-4-2 is installed.
    * system-config-printer-gtk 1.1.8-14-1 is installed.

Operation #81: install
Date: 2009-12-25 17:59

    * glibc-zoneinfo 2.9-45-10 is installed.
    * hplip-gui 3.9.8-37-5 is installed.

Operation #80: upgrade
Date: 2009-12-25 17:31

I will check your bug report later so I can see if I have any information to add to it.  

Oh, Here are my repositories:
$ pisi lr
pardus-test [active]

   http://packages.pardus.org.tr/pardus-2009-test/pisi-index.xml.bz2
pardus-2009 [active]

   http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
contrib [active]

   http://packages.pardus.org.tr/contrib-2009/pisi-index.xml.bz2

Regards, Lisa Marie


Lisa

Thanks for helping me on my way. Here are the outcomes of Pisi hs  and lr.
I will make a bug right now and place the bug report number here.


Code:
hendrikus@pardus ~ $ pisi hs
Handeling #101: repository updaten
Datum: 2010-01-01 15:42

    * pardus-2009 repository is opgewaardeerd.

Handeling #100: repository updaten
Datum: 2009-12-31 11:08

    * pardus-2009 repository is opgewaardeerd.

Handeling #99: Opwaarderen
Datum: 2009-12-30 16:36

    * gimp-i18n-cs is bijgewerkt van 2.6.7-45-9 naar 2.6.7-46-10 met delta.
    * gtk-qt-engine is bijgewerkt van 1.1_147-5-3 naar 1.1_147-6-4 met delta.
    * django-tagging is bijgewerkt van 0.2.1-1-1 naar 0.3-2-2 met delta.
    * glibc-locales-es is bijgewerkt van 2.9-43-9 naar 2.9-45-10 met delta.
    * gtkdatabox is bijgewerkt van 0.9.0.1-2-3 naar 0.9.1.1-3-4 met delta.
    * neon is bijgewerkt van 0.29.0-10-7 naar 0.29.0-11-8 met delta.
    * gimp-i18n-ca is bijgewerkt van 2.6.7-45-9 naar 2.6.7-46-10 met delta.
    * liberation-fonts is bijgewerkt van 1.05.1_20090721-12-6 naar 1.05.2_20091019-13-7 met delta.
    * qt-sql-odbc is bijgewerkt van 4.5.3-72-16 naar 4.5.3-72-17 met delta.
    * libgphoto2-doc is bijgewerkt van 2.4.7-26-4 naar 2.4.7-27-5 met delta.
    * glibc-locales-en is bijgewerkt van 2.9-43-9 naar 2.9-45-10 met delta.
    * gimp-i18n-zh_HK is bijgewerkt van 2.6.7-45-9 naar 2.6.7-46-10 met delta.
    * qt-sql-ibase is bi  ---------------------------->>>>>> go's on >>>>



Code:
hendrikus@pardus ~ $ pisi lr
pardus-2009 [actief]
   http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
contrib [actief]
   http://packages.pardus.org.tr/contrib-2009/pisi-index.xml.bz2
lxde-2009 [inactief]
   http://pisi.pardus-linux.org/%23pisifiles/P2009-free/pisi-index.xml.bz2

This is also querious?
Code:
hendrikus@pardus ~ $ sudo pisi ur http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
Wachtwoord:
* Updaten repository: http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
Programma beëindigd. # ended program
Geen repository met de naam http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2 gevonden.
# it say's no repository found with this name  
Gebruik pisi help voor algemene hulp.
hendrikus@pardus ~ $


Bug 11912 has been added to the database http://bugs.pardus.org.tr/show_bug.cgi?id=11912


gr Hendrikus
« Last Edit: January 04, 2010, 12:22:20 PM by Hendrikus Godvliet » Logged

Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #25 on: January 04, 2010, 17:05:45 PM »

Hendrikus, I get that error, too.
"sudo pisi ur http ://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
* Updating repository: pardus-2009
Program Terminated.
No repository named http ://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2 found"

but when I do: "sudo pisi ur" it gets the shalsum one and all is well:
" Updating repository: pardus-2009
pisi-index.xml.bz2.sha1sum     (40.0  B)100%    630.15 KB/s [00:00:00] [complete]
pardus-2009 repository information is up-to-date."

so I guess the sha1sum file verification is necessary.

The difference for you and me is I have test repo enabled. 
I'm curious what version of pisi you are using? Mine is:
pisi info pisi
Installed package:
Name: pisi, version: 2.2.16, release: 151, build 42
Regards, Lisa Marie
Logged
trixon
Guest
« Reply #26 on: January 04, 2010, 17:20:42 PM »

The argument for ur is repo name, not repo url
Code:
pisi help ur

if you add LC_ALL=C you will get english output.
Code:
LC_ALL=C sudo pisi ur pardus-2009
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #27 on: January 04, 2010, 17:21:30 PM »

Another thing to try similar to what kluriq suggested is to remove the pardus-2009 repository and re-install it this way:
Code:
sudo pisi rr pardus-2009
which output should be:
"Repo pardus-2009 removed from system."
for repo listing, I go here:
http://worldforum.pardus-linux.nl/index.php?topic=2755.0
so, while in terminal do:
Code:
sudo pisi ar pardus-2009 http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
and it should give output:
"Repo pardus-2009 added to system.
Update PiSi database for repository pardus-2009? (yes/no)y
* Updating repository: pardus-2009"
Logged
Hendrikus Godvliet
Pardus Master
***
Posts: 202



View Profile WWW
« Reply #28 on: January 04, 2010, 18:56:34 PM »

but when I do: "sudo pisi ur" it gets the shalsum one and all is well:
" Updating repository: pardus-2009
pisi-index.xml.bz2.sha1sum     (40.0  B)100%    630.15 KB/s [00:00:00] [complete]
pardus-2009 repository information is up-to-date."

so I guess the sha1sum file verification is necessary.

The difference for you and me is I have test repo enabled.  
I'm curious what version of pisi you are using? Mine is:
pisi info pisi
Installed package:
Name: pisi, version: 2.2.16, release: 151, build 42
Regards, Lisa Marie



Lisa

Code:
hendrikus@pardus ~ $ sudo pisi ur
Wachtwoord:
* Updaten repository: pardus-2009
pisi-index.xml.bz2.sha1sum     (40.0  B)100%    535.42 KB/s [00:00:00] [compleet]
pardus-2009 repository informatie is nog recent.
* Updaten repository: contrib
pisi-index.xml.bz2.sha1sum     (40.0  B)100%    287.44 KB/s [00:00:00] [compleet]
contrib repository informatie is nog recent.

so I guess the sha1sum file verification is necessary.?
How can i do a verificationcheck?

Code:
hendrikus@pardus ~ $ pisi info pisi
Systeemfout: programma beëindigd. #System: Program terminated

Gebruik pisi help voor algemene hulp.
Gebruik --debug voor een terugloop.

??
« Last Edit: January 04, 2010, 19:04:13 PM by Hendrikus Godvliet » Logged

Hendrikus Godvliet
Pardus Master
***
Posts: 202



View Profile WWW
« Reply #29 on: January 04, 2010, 19:10:49 PM »

Another thing to try similar to what kluriq suggested is to remove the pardus-2009 repository and re-install it this way:
Code:
sudo pisi rr pardus-2009
which output should be:
"Repo pardus-2009 removed from system."
for repo listing, I go here:
http://worldforum.pardus-linux.nl/index.php?topic=2755.0
so, while in terminal do:
Code:
sudo pisi ar pardus-2009 http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
and it should give output:
"Repo pardus-2009 added to system.
Update PiSi database for repository pardus-2009? (yes/no)y
* Updating repository: pardus-2009"



Here we go Lisa:

Code:
hendrikus@pardus ~ $ sudo pisi rr pardus-2009
Wachtwoord:
Repo pardus-2009 verwijderd uit het systeem.
Code:
hendrikus@pardus ~ $ sudo pisi ar pardus-2009 http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
Repo pardus-2009 toegevoegd aan het systeem.
Update PiSi-database voor de repository pardus-2009? (ja/nee)j
* Updaten repository: pardus-2009
pisi-index.xml.bz2.sha1sum     (40.0  B)100%     92.77 KB/s [00:00:00] [compleet]
pisi-index.xml.bz2             (1.2 MB)100%    113.29 KB/s [00:00:02] [compleet]
No signature found for http://packages.pardus.org.tr/pardus-2009/pisi-index.xml.bz2
* Pakketdatabase geupdate.  #means o.k


But still my packetmanager is not working


And if i tried to instal from command:
Code:
sudo pisi it zynaddsubfx-2.2.1-2.pisi
Systeemfout: programma beëindigd. #system program terminated

Gebruik pisi help voor algemene hulp.
Gebruik --debug voor een terugloop.

                      </?\>
« Last Edit: January 04, 2010, 19:20:01 PM by Hendrikus Godvliet » Logged

Pages: 1 [2] 3 4 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!