Welcome, Guest. Please login or register.
April 18, 2014, 07:51:12 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  pisi vs package manager (Solved)
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] 3 4 Go Down Print
Author Topic: pisi vs package manager (Solved)  (Read 9146 times)
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #15 on: April 06, 2007, 03:27:52 AM »

I am also having poblems upgrading from behind a proxy,  but I can't access the internet either.  My proxy server requires a username and password.  Tasma does not allow me to enter that information--it defaults to "prompt as needed" but then fails to prompt.  Is there a way to enter username and password for the proxy server from the command line?  Maybe then the package manager would work.  Just a thought.  Thanks for any suggestions.

Marty
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #16 on: April 06, 2007, 11:50:29 AM »

You can add the proxy authentification information in /etc/bashrc and/or /etc/profile in the following way:

http_proxy=http://username:password@proxy.company.com:portnumber
export http_proxy

Hope this helps.
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #17 on: April 07, 2007, 02:07:52 AM »

You can add the proxy authentification information in /etc/bashrc and/or /etc/profile in the following way:

http_proxy=http://username:password@proxy.company.com:portnumber
export http_proxy

Hope this helps.

Thanks for the suggestion.  I tried it today,  but still couldn't upgrade or access the internet.  I tried using pisi from the command line in super user mode and using the package manager,  but no luck.  I even tried to enter my username and password into the proxy settings in Tasma>Network Manager>Proxy in the same format you suggested I use with the command line. Strangely,  I get the green checkmark and an IP address from the network manager and I can print to local network printers.  I just can't get out to the internet.  I have the user set as wheel,  so it should be allowed to dial out.  There must be something else I'm not setting up right.  The login prompt for the internet never comes up,  but I don't know if it needs to with the information already set up using the command line.  I'm going to keep trying.  I'll post another reply if I figure it out.  Thanks again for your suggestions.
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #18 on: April 09, 2007, 20:37:13 PM »

Do you have your name servers set up correctly? What does your /etc/resolv.conf look like? At least the first entry in there should be the IP address of the DNS server or the gateway / router on your local network.

Can you ping servers on the internet?

What are the exact error messages that you get when trying to access the internet (if any?)
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #19 on: April 10, 2007, 21:26:09 PM »

I tried again today to export http_proxy as described above,  this time after using network manager to set up the nameservers.  This time,  I got pisi up to work.  I was still unable to connect to the internet using firefox,  but konqueror works perfectly.  I'll live without firefox.  I'm just glad I could get all of the updates.  Thanks for your help!

Marty
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #20 on: April 11, 2007, 17:12:29 PM »

Marty, that's good to hear :-)

Firefox needs to have the proxy set in its own settings. You can do this under Tools --> Settings --> Options --> General --> Connection settings.

Oops, correction: that should read Edit >Preferences > Advanced >Network > Connection Settings.
« Last Edit: May 07, 2007, 22:17:09 PM by roverrat » Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #21 on: April 11, 2007, 20:33:14 PM »

I must have a different version of Firefox.  Under Tools,  there was no Settings.  I already tried to set it up by going to Edit>Preferences.  This brings up a window where you can select Advanced>Network>Settings.  It still did not connect,  even after restarting Firefox and double checking the proxy settings.  In other distros,  you can select an option to "Use System Settings"  which makes setup a little simpler.  I'm really not worried about it because Konqueror actually loads and surfs faster than Firefox,  even though some sites don't display the same.  I do appreciate your help,  though.  I'd still be stuck on the Nameserver settings if it weren't for your suggestions.

Marty
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #22 on: April 12, 2007, 21:18:37 PM »

Sorry, my mistake. The place I told you to look for the proxy setttings holds true for the Windows version of Firefox ... (I was on a Windows box when writing the previous post)
Logged
stux
Pardus fellow craft
**
Posts: 77


View Profile
« Reply #23 on: April 24, 2007, 11:01:52 AM »

I tried again today to export http_proxy as described above,  this time after using network manager to set up the nameservers.  This time,  I got pisi up to work.  I was still unable to connect to the internet using firefox,  but konqueror works perfectly.  I'll live without firefox.  I'm just glad I could get all of the updates.  Thanks for your help!

Marty
You got pisi to work but is Package Manager able to download?
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #24 on: April 25, 2007, 04:21:07 AM »

No,  Package Manager still does not work.  The last time I tried to use the machine in question was last week.  At that point,  Konqueror was the only program that worked to connect to the internet through the proxy server.  On the date that I posted above,  I could use "pisi up" from the command line to get updates.  Since then,  "pisi up" has not worked.  I know there have been more updates since that time because I use Pardus at home and have not had a problem updating with Package Manager because I don't use a proxy server at home.  When I tried last week using the machine at work from the command line,  I got the message,  "Program Terminated.  Please check your network connections and try again.  Name or Service not known."  I could connect with Konqueror but not with Firefox or Package Manager.  I'll try and spend some more time with it next week when I get back to work and post the results.  I wish I had some better information or more specific instructions to offer until then,  but I can't duplicate the problem from where I am--there's no proxy.

Marty
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #25 on: May 05, 2007, 15:01:26 PM »

I got back from vacation and had a chance to work on my Pardus machine though the proxy.  I tried several configurations of the proxy settings in Tasma to try to get Package Manager (the graphic front end to pisi) to function.  All of my attempts failed.  I did learn that "pisi" from the command line does still work,  but that exporting the proxy configuration the way roverrat describes above is necessary every time you run it.  Apparently,  the proxy information is not saved from session to session,  so it must be reentered each time.  I have also been experimenting with Firefox to get it to work.  Again,  all attempts have failed for me.  Strangely,  Konqueror works perfectly every time.  I would like to get Package Manager and Firefox running,  but I've tried everthing I could think of and not been successful yet.  If I figure it out,  I'll post again.  If anyone has some recommendations,  I would appreciate it.

Marty
Logged
stux
Pardus fellow craft
**
Posts: 77


View Profile
« Reply #26 on: May 07, 2007, 08:52:33 AM »

My Firefox works or should I say everything else works but Package Manager  Sad
Logged
msullivan
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #27 on: May 07, 2007, 12:46:08 PM »

It seems that the Package Manager program fails to use the proxy as set up in Tasma to connect to the internet to download updates.  It tries to make a direct connection,  but fails.  For those of us who use a proxy,  this is a real problem.  Every time I try to use Package Manager I get the error about checking network settings and trying again.  Hopefully,  this will be resolved with future updates.

Marty
Logged
stux
Pardus fellow craft
**
Posts: 77


View Profile
« Reply #28 on: May 07, 2007, 12:57:26 PM »

It seems that the Package Manager program fails to use the proxy as set up in Tasma to connect to the internet to download updates.  It tries to make a direct connection,  but fails.  For those of us who use a proxy,  this is a real problem.  Every time I try to use Package Manager I get the error about checking network settings and trying again.  Hopefully,  this will be resolved with future updates.

Marty
That makes sense. I noticed in Synaptic there is an option for direct connection or proxy.
Hope a dev sees this and adds that option or a workaround  Wink
Logged
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #29 on: May 07, 2007, 22:28:43 PM »

I just found the pisi configuration file /etc/pisi/pisi.conf.

In the section [general] it has several entries for a proxy which default to "None". Adding the http_proxy of your company here should work.  It at least will save you the trouble of entering the proxy info manually each time you run pisi.

As for package manager I will have another go at it it tomorrow. If what you suspect is true and package manager ignores the proxy settings it might be  a good idea to file a bug.
 
« Last Edit: May 07, 2007, 23:14:48 PM by roverrat » Logged
Pages: 1 [2] 3 4 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!