Welcome, Guest. Please login or register.
April 23, 2014, 09:14:21 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  Monitor Alignment
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Monitor Alignment  (Read 2369 times)
mhwelsh
Newbie
*
Posts: 4


View Profile
« on: July 06, 2010, 20:46:03 PM »

I am using a dual booted computer with Pardus as one system and LinuxMint as the other.
When I switch to Pardus the monitor display is misaligned. (The 'Close Button' 'X' is half obscured.)
If I realign the monitor using the monitor 'Auto' button the display is centralised.
Does any body else have this problem?
Other systems which Pardus has replaced did not have this defect.


martin welsh
Logged
John A
Guest
« Reply #1 on: July 06, 2010, 21:47:57 PM »

They write about dual boot here.
Maybe it can be of some help:
http://worldforum.pardus-linux.nl/index.php?topic=3144.0

And here to:
http://en.pardus-wiki.org/HOWTO:Adding_a_GRUB_2_item_in_the_boot-menu_of_Pardus_%28GRUB_Legacy%29

But I dont know so much how to dual boot different Linux so maybe someone else here can be of some help?
« Last Edit: July 06, 2010, 22:02:50 PM by John A » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #2 on: July 07, 2010, 00:27:43 AM »

Does any body else have this problem?
I don't have this problem.
Maybe Pardus and LinuxMint use a different resolution for the monitor.
And what is the make and model of the used video card and monitor?

They write about dual boot here.
I do not think it has anything to do with dual boot.
Logged
mhwelsh
Newbie
*
Posts: 4


View Profile
« Reply #3 on: July 11, 2010, 18:14:29 PM »

Thank you for both replying.
The monitor is a Samsung SyncMaster 2023nw 1680x1050.
The video card is integrated into the motherboard and is a Geforce6100 with Nforce 405.
Both Pardus and LinuxMint have Nvidia 195-36-24 drivers installed although no Nvidia control panel is displayed in the System Settings in Pardus as it is in LinuxMint.
The size settings in the Pardus - System Settings - Display are set to 1680x1050 but I have yet to find a way of checking what it actually is.
As you will appreciate LinuxMint is new grub and Pardus is old grub so I have had to learn about that recently and am confident that whilst LinuxMint is the lead system in new grub my edition of the grub entry for Pardus is all tickety boo.

When I first tried Pardus I also had Sidux and Xandros systems loaded so out of the four systems only Pardus required the monitor to be Auto centered.
A mystery.

martin welsh
Logged
kalwisti
Pardus fellow craft
**
Gender: Male
Posts: 131



View Profile
« Reply #4 on: July 12, 2010, 05:32:04 AM »

Hi, Martin,

First off, Welcome aboard! I hope that you'll enjoy using Pardus. I began using it about 6-7 months ago; it has been a good experience for me and has worked well on my hardware. The Turkish developers have implemented KDE4 very nicely.

I'm not sure that I can solve your problem, but I have a couple of suggestions which might be helpful. I think you can check your resolution via the Info Center (KInfoCenter): Applications > System > Info Center. Then choose X-Server from the left panel and look under "Dimensions". (An alternative method is to start up a Konsole session and type $ kinfocenter from the command line).

I have a 15" HP LCD monitor with a resolution of 1024 x 768, which Pardus correctly detected and configured. I recently installed Ubuntu 10.04 LTS (Lucid Lynx) on my /hda and allowed its GRUB2 to take over the MBR. I'm still very much a GRUB2 novice, so there have been some glitches to overcome with my Linux multibooting. However, GRUB2 did detect and correctly configure my Pardus 2009.2 installation. If you'd like to compare, here's what my GRUB2 entry looks like. (This comes from /boot/grub/grub.cfg):


Code:
menuentry "Pardus 2009.2 Geronticus eremita [2.6.31.13-131] (on /dev/sdb8)" {
insmod ext2
set root='(hd1,8)'
search --no-floppy --fs-uuid --set 7eaecdc1-4e81-4516-99b5-f811c84cabb7
linux /boot/kernel-2.6.31.13-131 root=LABEL=PARDUS_ROOT splash=silent quiet vga=0x317 resume=/dev/sdb7
initrd /boot/initramfs-2.6.31.13-131
}

Apparently that "vga=0x317" parameter is the right value for my screen resolution. You might check yours and see what it says ... For more info on how to set/change that parameter, I found the thread below on the Ubuntu Forums:

http://ubuntuforums.org/showthread.php?t=258484&highlight=kernel+booting+parameters
"HOWTO: Change bootup and console resolution." 16 Sept. 2006.

If you need to tinker with your GRUB2 entries (be careful!), I've found the following webpages to be useful guides:

http://www.dedoimedo.com/computers/grub-2.html

https://help.ubuntu.com/community/Grub2

https://wiki.ubuntu.com/Grub2

HTH,
=david

Logged

Registered Linux User # 442201

Pardus 2011.2 (KDE 4.6.5, kernel 2.6.37.6)

AMD Athlon II X2 240 (Regor) 2.8 GHz, 4 GB RAM, Seagate Barracuda 320 GB HD, Nvidia GeForce 6150SE nForce 430 integrated GPU, Samsung SH-S222L DVD-RW
mhwelsh
Newbie
*
Posts: 4


View Profile
« Reply #5 on: July 12, 2010, 20:54:27 PM »

Thanks for your response.
Applications>System>Info Centre>Xserver shows 1680X1050 so the drivers are doing the best that they can.

My Grub2 tuition was http://www.dedoimedo.com/computers/grub-2.html a thoroughly good tutorial.

I generated a script for the Pardus entry according to this tutorial and this is what it produced in /boot/grub/grub.conf;

### BEGIN /etc/grub.d/11_Pardus_2009_2 ###
Adding my custom Linux to GRUB 2
menuentry "Pardus 2009-2 Geronticus emerita" {
set root=(hd0,7)
linux /boot/kernel-2.6.31.13-131 root=LABEL=PARDUS_ROOT splash=silent quiet vga=0x31a
initrd (hd0,7)/boot/initramfs-2.6.31.13-131

This has given me two boot loader lines for LinuxMint then The Pardus entry followed by the two Memory Test entries.  I disabled 'execution' on all of the other entries.  I think that the vga entry only effects the boot screen display and perhaps the fall back vga setting.  The kernel should instigate/enable the Nvidia driver as it is loaded.  I am probably wrong!

Thanks again for your reply

martin welsh
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: July 12, 2010, 21:02:53 PM »

I think that the vga entry only effects the boot screen display and perhaps the fall back vga setting.  The kernel should instigate/enable the Nvidia driver as it is loaded.  I am probably wrong!
^^ this is 100% wright

And maybe a look in the file /etc/X11/xorg.conf of the various operating systems will give a further hint for this behavior  
Logged
mhwelsh
Newbie
*
Posts: 4


View Profile
« Reply #7 on: July 13, 2010, 20:19:10 PM »

Confession time.
At the top of the display there is a taskbar.
At the right hand end of this taskbar there is a shaded symbol marked as Panel Tool Box.
Clicking this discloses adjustments for centering the screen, these fixed it.
After centralising the settings remain for the next start up.

Thanks to all those that have helped.

martin welsh
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!