Welcome, Guest. Please login or register.
April 24, 2014, 11:00:42 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  My login manager is lying to me.
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: My login manager is lying to me.  (Read 2566 times)
JoanRC
Pardus fellow craft
**
Posts: 39



View Profile
« on: August 05, 2010, 04:22:07 AM »

This past weekend, I destroyed my desktop using Ctrl Alt Esc trying to kill a slow process. I accidently killed the desktop instead of the application. I used Alt SysReq R E to obtain a Konsole prompt, logged back in as user and issued startx, hoping to get my desktop back. Instead, I got a blank screen with no wallpaper, taskbar, widgets or other desktop elements. The screen was green, the colour I'd chosen for my background, and had brown squares with errormessages where my desktop icons should be. I could not invoke Krunner nor Lancelot from the keyboard. nor did Ctrl Alt Del work to reboot. I dropped back to Konsole,and rebooted.

I could not log in as user at the GUI login screen. I logged in as root from the Konsole, and deleted my xorg.conf file as per this article in Wiki:  HOWTO:Fix broken X session/  I still could not login as user at the graphical login screen. I once again logged in as user from the konsole, issued startx and got the same blank screen.  I dropped back to the konsole, logged in as root, and issued startx. This time, a proper desktop appeared, and Kaptan autostarted. I'm guessing it autostarted because I hadn't run it as root after updating the kernel through Package Manager (from 2009.1 to 2009.2) af ew weeks ago.

However, Pardus also told me my root partition was full and suggested I clean something out. Using KDiskFree, I discovered that my /tmp folder contained 1.4 G of files. After deleting them all by hand, I now had 2.8 G free - twice the amount of space I'd actually cleaned out. Then, when I started my desktop as user, my old desktop appeared - with a few minor changes.

I no longer have Shutdown and Reboot options available as user - not from the desktop and not from the keyboard. I can only log out and then reboot or shutdown from the konsole. Upon reboot, I cannot login from the graphical login screen, only from the console. My brother suggested I reinstall my login manager; but, I do not wish to do anything quite that drastic. I found the login manager in System Settings and took a look around.

Nothing in there is true. It claims I am using the Catalan language; yet, English is the language used throughout the entire boot process. It claims I am using the Pardus Air theme for bootin; yet, that screen does not show up anywhere during the boot process. I also claims that my user is allowed to log in at the login screen, which is not true. I set the autologin option for my user, hoping to bypass the login screen. Upon closing, the login manager issued the following errormessage: command '/usr/kde/r/bin/ksmshell4 kdm --lang en_US' not found. That is also not true, as the bootin process is conducted in English throughout.

I looked in the kdmrc files in /etc/X11/kdm/ and in /usr/kde/4/share/config/kdm/ and confirmed that the changes made in the login manager were saved properly in these directories. Autologin appears to be enabled. However, nothing has changed during the bootin process. I still get the login screen and have to login at the console.

If anyone has read my entire tale of woe and feels concern, do not despair. These are minor glitches that can be worked around. They were generated by stupiduser issues, which cannot be fixed by the Pardus team.

But if anyone knows how to fix this, I would be so happy.

 
Logged

Remember: only you can prevent forum fires!
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: August 05, 2010, 13:56:22 PM »

I will test this on my testPC and try to find an answer to your questions Shocked

But first some remarks and solutions (I hope):
Destroying (part of) your KDE Desktop has nothing to do with  X session.

..... that my /tmp folder contained 1.4 G of files.
Have a look in the topic "/tmp Ordner wird nicht geleert (parususer.de)"
In short (and translated): Dolphin > goto directory /etc/conf.d > right-click file local.stop  > Root Actions > Open as Text > and add
Code:
rm -Rf /tmp/*
 > Save > Close.

..... I no longer have Shutdown and Reboot options available as user
Have a look in System Settings > Advanced > Login Manager > Shutdown > Local: Everybody Huh?
And do not forget the Apply button.

....... It claims I am using the Catalan language; etc......
These are the default settings when you start the Login Manager for the first time.
These default settings should have been modified by YALI. And this is more or less a bug in YALI.
But these settings are only applied after you have activated the button "Apply".

...........Autologin appears to be enabled. However, nothing has changed during the bootin process. I still get the login screen and have to login at the console.
Try the (above) button "Apply".
« Last Edit: August 05, 2010, 14:06:08 PM by atolboo » Logged
JoanRC
Pardus fellow craft
**
Posts: 39



View Profile
« Reply #2 on: August 05, 2010, 19:51:48 PM »


Destroying (part of) your KDE Desktop has nothing to do with  X session.


So, I'm guessing the desktop couldn't be generated because X was unable to create temporary files because root partition was full?


..... I no longer have Shutdown and Reboot options available as user
Have a look in System Settings > Advanced > Login Manager > Shutdown > Local: Everybody Huh?
And do not forget the Apply button.
<snip>
But these settings are only applied after you have activated the button "Apply".

...........Autologin appears to be enabled. However, nothing has changed during the bootin process. I still get the login screen and have to login at the console.
Try the (above) button "Apply".

Yes, I had activated the "Apply" button. However, to doublecheck, I just now opened login manager again, unchecked "everybody", checked "root", activated "apply" and "OK". This did not change anything. I still had only "logout" available, and it did not ask for root password. So, I rebooted, logged back in as user, and checked again. Same result - only logout is available.

As mentioned in my previous post, I did check the configuration files kdmrc to verify that changes made in Login Manager are being saved to the configuration files. They are, but the bootin process is ignoring them.

Maybe I should try to make a small batch file to automate login from the console and forget about trying to solve this. It's only a minor irritation.
Logged

Remember: only you can prevent forum fires!
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #3 on: August 05, 2010, 21:49:34 PM »

Wait for
I will test this on my testPC and try to find an answer to your questions Shocked
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: August 05, 2010, 22:50:51 PM »

So far I was not successful in destroying permanently my KDE desktop.

Is
Quote
Ctrl Alt Esc
Ctrl+Alt+Esc and
Quote
Alt SysReq R E
Alt+SysReq+R+E Huh?
(+ = simultaneously)

And after creating a new user in System Settings > User Manager (with all rights).
Does the new user has the same problems?
Logged
JoanRC
Pardus fellow craft
**
Posts: 39



View Profile
« Reply #5 on: August 06, 2010, 00:41:45 AM »

So far I was not successful in destroying permanently my KDE desktop.

Is
Quote
Ctrl Alt Esc
Ctrl+Alt+Esc and
Quote
Alt SysReq R E
Alt+SysReq+R+E Huh?
(+ = simultaneously)


Yes to both.

It was the Ctrl+Alt+Esc that killed the desktop. If used properly, it will kill a programme that has frozen. If you miss the programmes's window and hit the desktop, you will kill your desktop. But it should not be permanent. If you reboot, you should see your desktop as normal. See this article in Wiki: http://en.pardus-wiki.org/Kill Look at section XKill.

As I mentioned earlier, I'm guessing that my full /tmp directory prevented X from creating temporary files needed while creating the screen. This is just a guess; because, I regained the desktop after cleaning out the /tmp directory.

The Alt+SysReq+R+E combination will stop all processes, unmount file systesm, and give you a usable system prompt. See Wikipedia article "Magic SysReq key" http://en.wikipedia.org/wiki/REISUB  I used this because Ctrl-Alt-Del would not reboot the computer.

I used this before when a bug in Mandriva crashed me to a minimal desktop with no access to a system prompt.


And after creating a new user in System Settings > User Manager (with all rights).
Does the new user has the same problems?

No, my new user does not have the login and shutdown problems  Grin . I gave him administrator privileges and put him in root group. However, when I logged back in as old user, my mouse was frozen. I just unplugged and replugged it back in.

So, maybe I need to give my old user adminstrative privileges and put him in root group, too?  I'm not too clear on the difference between adminstrator and root. This is a home computer with no children in the house so no need to worry about in house security.

Logged

Remember: only you can prevent forum fires!
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: August 06, 2010, 13:56:54 PM »

...... and put him in root group, too?
I do not know what you mean by the above.....

Here is a little HOWTO create a new user with administrator rights:
Quote
1. Create a new user with full administration rights.
     System Settings > User Manager > Add New > Add User
   Fill in all User Information.
   Mark at 'Give administrator rights'.
   Authorizations > mark at 'Authorize user' > activate 'Apply this policy to all actions.' > should give all green icons.
   Groups > check mark at: disk,wheel,audio,dialout,video,pnp,power,pnpadmin,removable,users
   Main Group: users
   OK and Close System Settings
(taken from User-repair-EN.odt @ pardususer.de)

...... I'm not too clear on the difference between adminstrator and root.
It is only a different name for the same thing.

And maybe it's possible to repair your original user withe the same  manual User-repair-EN.odt
« Last Edit: August 06, 2010, 14:02:50 PM by atolboo » Logged
JoanRC
Pardus fellow craft
**
Posts: 39



View Profile
« Reply #7 on: August 06, 2010, 20:39:44 PM »

Thank you for the HOWTO.  Grin It looks like something that should go into the Pardus Wiki. Before trying this, I am making a full backup of my home directory. This will take a while; so, I will try your advice later today and report back.

When I said " put him in root group, too?" I meant choose "Main Group: root" instead of "Main group: users." According to this HOWTO which you have given me, I don't need to put him in Main group: root; so, I won't.
Logged

Remember: only you can prevent forum fires!
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: August 06, 2010, 20:55:58 PM »

...... It looks like something that should go into the Pardus Wiki. .......
I have a different opinion with respect to this.
This is only a manual when you get a "No such action_id" error when opening (your own?) user settings in System Settings > User Manager.
And until this moment I did not see a report on this subject in this forum.

.......put him in Main group: root; so, I won't.
I do not have this group-option in "Main group: ...." .
Logged
JoanRC
Pardus fellow craft
**
Posts: 39



View Profile
« Reply #9 on: August 06, 2010, 21:57:21 PM »

You are right. I took a screenshot to show what I mean.


* snapshot24.png (31.08 KB, 819x317 - viewed 106 times.)
Logged

Remember: only you can prevent forum fires!
dwightpaige79
Newbie
*
Gender: Male
Posts: 18



View Profile
« Reply #10 on: August 06, 2010, 22:10:16 PM »

Not sure if I understand the problem. But it sounds like you need to reset the KDE 4 desktop for user <uname>. If your desktop works as expected as another user or root then this is the case. To do that in KDE 4 do a console login as <uname> and run:

Code:
$ rm ~/.kde4/share/config/plasma*

Login normally. Then you should have the default Pardus/KDE desktop you would have after a fresh install. You can now reconfigure all your special user settings as before.

Logged
JoanRC
Pardus fellow craft
**
Posts: 39



View Profile
« Reply #11 on: August 06, 2010, 22:34:16 PM »

Thank you dwight.

My desktop has been restored after my disaster this weekend. The issue now is: my user account no longer has the ability to login at the graphical login screen; and it no longer has the ability to shutdown or reboot from the desktop. I can login from the konsole and I can logout to the konsole and shutdown from there. I have made appropriate choices in the Login Manager in System Settings, and have checked the configuration files to ensure that those choices were saved properly. They are; but, Pardus for some reason does not recognize that those changes were made, and does not let my user boot in from the graphical login screen. I created a new user account; and this account is able to login and shutdown via the gui and desktop. So, it looks like a privileges issue of some kind.
Logged

Remember: only you can prevent forum fires!
JoanRC
Pardus fellow craft
**
Posts: 39



View Profile
« Reply #12 on: August 07, 2010, 03:06:36 AM »

No luck. I followed the instructions in the HOWTO and still have the login/shutdown problems in the new account named after the old user. I gave him full privileges, as instructed. I opened Login Manager and unchecked and rechecked all the options I want but Pardus still ignores them during bootup.
Logged

Remember: only you can prevent forum fires!
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #13 on: August 07, 2010, 10:28:04 AM »

No luck. I followed the instructions in the HOWTO and still have the login/shutdown problems in the new account named after the old user. .....
I do not expect the User-repair-EN.odt HOWTO to repair your problem as
No, my new user does not have the login and shutdown problems  Grin .
And this ^^  proves that the problem is caused by a setting in one of the (hidden?) files in your /home directory.
(but which file is the unknown factor here and the €€€-question)
And the User-repair-EN.odt HOWTO restores all your settings and a modified version of the HOWTO will hopefully bring the solution..
« Last Edit: August 07, 2010, 10:59:33 AM by atolboo » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #14 on: August 08, 2010, 10:33:45 AM »

I no longer have Shutdown and Reboot options available as user -..........
I think I have found your problem.......
Have a look in System Settings > Advanced > Session Manager > General
  Is there a mark at "Offer shutdown options"
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!