Has anyone encountered this problem yet:
[ERROR ] 01:10:44 main:216 This version of Deluge requires libtorrent >=0.14.5.0!
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/deluge/main.py", line 209, in start_daemon
File "/usr/lib/python2.6/site-packages/deluge/core/daemon.py", line 134, in __init__
from deluge.core.core import Core
File "/usr/lib/python2.6/site-packages/deluge/core/core.py", line 36, in <module>
from deluge._libtorrent import lt
File "/usr/lib/python2.6/site-packages/deluge/_libtorrent.py", line 60, in <module>
File "/usr/lib/python2.6/site-packages/deluge/_libtorrent.py", line 53, in check_version
raise ImportError("This version of Deluge requires libtorrent >=%s!" % REQUIRED_VERSION)
ImportError: This version of Deluge requires libtorrent >=0.14.5.0!
This is because the up-to-date version of libtorrent isn't supported by deluge yet so I'm not sure why it's in the stable repo yet but here's what I did to work around the problem:
sudo nano /usr/lib/python2.6/site-packages/deluge/_libtorrent.py -w
#REQUIRED_VERSION = "0.14.5.0"
REQUIRED_VERSION = "0.14.10"
This will make Deluge think it is using a supported version and it will function again.
If anyone knows of a bugtracker or a better place that I should post this please let me know.