Welcome, Guest. Please login or register.
April 24, 2014, 00:39:21 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  enable caching of PiSi packages through command line? [solved]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: enable caching of PiSi packages through command line? [solved]  (Read 766 times)
Pardus Guru
Posts: 841

View Profile
« on: September 21, 2010, 17:35:56 PM »

Hello all,

I'm using Alpha 2011 Pardus, and got into a bit of a jam with Pisi GUI.  I had some problems with PiSi the other day, when I first tried getting updates through the GUI, and even though I had adminstrative priveleges, it asked  for my root password instead of user password to get upgrades.  After getting disconnected I closed the GUI and redialed, then started pisi through command line and got the remaining updates.  When I rebooted and tried to start PiSI GUI and check for upgrades, I got a message that, "another isntance of PiSi is running", so I closed the GUI and opened terminal and did a, sudo pisi up, and got the same message that another instance of PiSi was running.  I exited the terminal and checked to see what processes were running, and it didn't list PiSi.  So, I was stuck at not being able to get updates.  I know this is test phase of 2011, so this is to be expected.  I reinstalled Pardus, and to be safe, didn't start PiSi GUI, but used command line to get the updates.  Now to my question.   Cheesy  Is there a way to enable PiSi caching from command line?  I did try "sudo pisi upgrade -f" but this just cached the packages without installing them.   Or,does this command  also cache the packages, too?  
I appreciate any time and help with this.  
Lisa Marie

Edited to add that I am marking this as solved.  I just did a reboot and all the packages are in var/cache/pisi/packages folder.  So, I suppose that when one runs PiSi from command line, it automatically saves the packages in the cache, or adding the -f did this.  I'm just afraid to use the GUI, because it is a big buggy as in telling me I need to enter root password to run it, and also that last time I ticked "enable caching of packages" under PiSi GUI preferences, it didn't stay ticked. 
If I get that message again about "another instance of PiSi is running", then I'll try removing stale locks, and see if that solves that little problem.  Yep, if I had my husband's lap top, I'd go to a wifi hot spot in town and get the latest build as I'd probably be avoiding some of these bugs with a more recent edition.  Tongue  I am determined to work with what I've got.  Smiley
Lisa Marie
« Last Edit: September 21, 2010, 18:45:14 PM by Lisa » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!