Welcome, Guest. Please login or register.
April 16, 2014, 06:13:33 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  Pardus is very slow
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Pardus is very slow  (Read 2379 times)
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« on: November 12, 2010, 21:41:46 PM »

Pardus is a very slow linux distro. My old distro, Mandriva 2010.1, is very fast. For make faster Pardus i have disable all plugin in Firefox except Flash. In this way Firefox is fast.

Thunderbird is too slow in Pardus. it is very, very slow. I have disable Nepomuk Search module and other service in Setting>System Setting>Service Manager. In this way Thunderbird is a lot faster.

I think there are other services that i can stopped and disabled but i'm not a linux hacker. Pardus is fat.

What are the service that i can stop? I use only Hp laser printer, wi-fi (wicd), 3g internet key (with kppp).
Can i stopped all service or the system will be killed?

P.S. my hardware is Pentium IV 1.8 Ghz, 1GB ram, an old ATI rage128, 20GB HD (10 GB /), Pardus 2009.2.
Logged
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #1 on: November 13, 2010, 21:18:50 PM »

Hi,

You can use service-manager to disable useless services / servers
Logged

---
gyan000 - plus-qu'en-retard
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #2 on: November 13, 2010, 21:37:29 PM »

Hi,

You can use service-manager to disable useless services / servers
Hi,
yes, but there is a lot of autostart application, there is akonadi and a lot of useless stuff (for me). I don't know what is truly useless, so configuring a fast Pardus is complex.
Logged
electronic_punk
Newbie
*
Posts: 18


View Profile
« Reply #3 on: December 19, 2010, 18:45:13 PM »

I really realise what you feel. I think it's rather KDE fault. This desktop environment is the heaviest for computers. Yes, strigi, akonadi, I don't really need it and don't know why it is enabled by default.

Future releases definitely should have an option to choose DE during installation.
Logged
electronic_punk
Newbie
*
Posts: 18


View Profile
« Reply #4 on: December 19, 2010, 21:43:13 PM »

But on this computer even flash should work ok. I think that it could run fast but on Gnome. KDE is a resource eater and it is the fact.
Logged
sipiatti
Newbie
*
Gender: Male
Posts: 8



View Profile
« Reply #5 on: December 20, 2010, 07:32:35 AM »

I think pardus is not slow. It is quite a perfect kde distro with some, but significant problem.
- Flash player in pardus has problems. With all of the browsers, even with google chrome too what have its own builtin flash player in the pisi package. I think the reason should be searched in the X settings somewhere. I tried to find it but I have lack of knowledge to have any result
- Also there should be problem with X setting or kwin  related to nvidia drivers (any compiling param?) because e.g nvidia 8400M is extremely slow in playing videos (flickering, low framerate). Doesn't matter wich videoplayer you use. Some other nvidia cards (most of them) work perfectly.
- strigi is a problem as is. I wonder if anybody use it for long...  Shocked
- plasma: you have to live with it, it is a part of kde4 Smiley the whole concept is good for eyecandy but useless for production work. On the other hand, the kde4 desktop is much more complete and uniform than any other
Logged

Why use windows if you have open doors... to linux...
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: December 20, 2010, 21:09:04 PM »

I think pardus is not slow.
I agree with you   as I don't experience this "slow" behavior.

- Flash player in pardus has problems. With all of the browsers........
Can you give a specific website (address) with flash, so that we can concentrate on this problem.
With a general remark, it's very difficult to find out if it's a general or a 'one off' problem.

I.........even with google chrome too ......
Remember that this browser isn't an official Pardus supported browser.

........ because e.g nvidia 8400M is extremely slow in playing videos (flickering, low framerate). Doesn't matter wich videoplayer you use. Some other nvidia cards (most of them) work perfectly.
I don't have any problem with my GeForce 6200 and GeForce 210 video cards.
The only right place to report this problem is Bugzilla.

Future releases definitely should have an option to choose DE during installation.
What is DE
Logged
electronic_punk
Newbie
*
Posts: 18


View Profile
« Reply #7 on: December 20, 2010, 21:16:10 PM »

DE = desktop environment Wink
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: December 20, 2010, 21:38:41 PM »

DE = desktop environment Wink
Thanks and I don't expect this to happen as Pardus is supposed to be a KDE distribution.
Logged
sipiatti
Newbie
*
Gender: Male
Posts: 8



View Profile
« Reply #9 on: December 21, 2010, 13:46:34 PM »

- Flash player in pardus has problems. With all of the browsers........
Can you give a specific website (address) with flash, so that we can concentrate on this problem.
With a general remark, it's very difficult to find out if it's a general or a 'one off' problem.
http://www.youtube.com Smiley
With the flashplayer in pardus the CPU load is about 80%, and I have two cores (AMD Athlon X2 64). With linuxmint it is about 70-71%. Both cases I used Firefox 3.6.12. On the other hand linuxmint was the 64 bit version with the 64 bit flashplayer. I am waiting for pardus 2011 64 bit and expecting better results.
I think this behavior is not the fault of pardus developers, they made quality work, I like the distro so much. There could be some hidden reasons what will be solved after some time when they have been revealed.
........ because e.g nvidia 8400M is extremely slow in playing videos (flickering, low framerate). Doesn't matter wich videoplayer you use. Some other nvidia cards (most of them) work perfectly.
I don't have any problem with my GeForce 6200 and GeForce 210 video cards.
The only right place to report this problem is Bugzilla.
We tested two msi notebooks, one with 8400M and one with 9600M. The 8400M has problems, but 9600M works perfectly. In the meantime my brother tested debian with kde4 on the 8400M notebook and got the same result, so it is not pardus related but kwin related. 8400M with gnome+compiz does not have any problem. And yes, the problem exists with the noveau driver too.
Logged

Why use windows if you have open doors... to linux...
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #10 on: December 21, 2010, 14:39:52 PM »

With the flashplayer in pardus the CPU load is about 80%, and I have two cores (AMD Athlon X2 64).
When I watch f.i. http://www.youtube.com/watch?v=lcvsu4YMbxE&feature=aso my Pentium(R) Dual-Core E6700  @ 3.20GHz needs 17-19% according to GKrellM.
And the CPU is there to work for me and not to be in a waiting state. Grin

....... but kwin related. 8400M with gnome+compiz does not have any problem. And yes, the problem exists with the noveau driver too.
My recommendation is still
The only right place to report this problem is Bugzilla.
« Last Edit: December 21, 2010, 14:42:29 PM by atolboo » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #11 on: December 21, 2010, 17:33:36 PM »

I really realise what you feel. I think it's rather KDE fault. This desktop environment is the heaviest for computers. Yes, strigi, akonadi, I don't really need it and don't know why it is enabled by default.

Hi electronic_punk,

I was curious as to what you were talking about, as I have another distro that uses kde3.5.10 for 64 bits, and it starts much faster after log in than Pardus 2011 beta2.  Not complaining, just noticing there is definitely a difference.  I also notice  home/.x-sessions-errors file contains much less input.  When I look at same file in 2011 beta2, it has quite a bit of akonadiserver entries in it, roughly 70, and trying to reach mysql server.  Since i use dial up, I don't see the need for this service, since I'm not connected at log in, and as I don't use kmail or calender reminders.  So, I experimented and edited the home/.config/akonadi/akonadiserverrc and changed 'startserver=false'.  Log in time is faster.
I will revert back to how it was, though, as i am testing Pardus 2011 and want to give correct error outputs to team Pardus.
After reading other discussions on this on other forums, I believe it would be a good idea if programmers for Pardus and/or KDE4 could make it possible to have akonadi as a service that could easily be disabled in start up services or an entry in System Settings as is found for Desktop Search (you can disable strigi and nepomuk here), as at moment it seems integrated so one has to do tear it apart  piece-meal, which isn't the best way to do it.   I also don't like the idea of my information being stored on a server.  It may be convenient for some, but I see it as a door that can be opened and abused.   Just my opinion. Smiley

On the other hand, I believe Pardus Corporate Edition uses KDE3.5.10 and I would guess it does not use Akonadi. 
Regards, Lisa Marie
Logged
electronic_punk
Newbie
*
Posts: 18


View Profile
« Reply #12 on: December 21, 2010, 21:40:11 PM »

DE = desktop environment Wink
Thanks and I don't expect this to happen as Pardus is supposed to be a KDE distribution.

http://worldforum.pardus-linux.nl/index.php?topic=3471.0

This is hope Wink

And yes, gnome + compiz works well and fast, kwin is much slower.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #13 on: December 21, 2010, 21:55:55 PM »

Thanks.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!