Welcome, Guest. Please login or register.
April 21, 2014, 01:35:47 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Getting AltGR to work? Special characters!?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Getting AltGR to work? Special characters!?  (Read 2122 times)
prairie_dad
Newbie
*
Gender: Male
Posts: 5


View Profile
« on: January 24, 2011, 23:57:56 PM »

Hi all,

though I'm an American, I often type in other languages, mostly German, French and Spanish.  It sure would be nice to be able to use AltGR to get my special characters in place...umlauts (diaeresis) cedille, carom, etc...and since this is a Turkish distro, after all, I would think that would be especially necessary!!

thanks,

dave
Logged
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #1 on: January 25, 2011, 04:53:40 AM »

Sytemsettings>hardware>input devices>keyboard

On the advanced tab you set this up
Logged
prairie_dad
Newbie
*
Gender: Male
Posts: 5


View Profile
« Reply #2 on: January 25, 2011, 22:30:28 PM »

well, thanks, I found System Settings/Input Devices/Keyboard easily enough, and the Advanced tab.  But even if I set the "Key to choose 3rd level" to, say, backslash...nothing happens any differently.  I also tried setting "Alt/Win key behavior" to "Alt and Meta are on Alt keys," with similarly little effect...

what settings exactly would you suggest?

thanks,

dave
Logged
mpie
Pardus fellow craft
**
Posts: 133



View Profile
« Reply #3 on: January 25, 2011, 23:04:23 PM »

You also have to set the layouts to get access to the characters.
By default the keyboard is not configured for a specific layout through kde and is based on 101 keys, select your correct keyboard if available or evdev then add english, spanish and german. then keys it should work as you want.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: January 26, 2011, 00:40:08 AM »

After adding various keyboard layouts in System Settings > Input Devices > Keyboard > Layouts, they will appear (and can be selected instantaneously) in the panel next to Kmix regulator. Grin
Logged
prairie_dad
Newbie
*
Gender: Male
Posts: 5


View Profile
« Reply #5 on: January 26, 2011, 20:49:57 PM »

many thanks to you both, now it is working almost perfectly...

still a few problems on which I will report...not sure they are bugs or...my own lack of understanding?

dave
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: January 26, 2011, 21:22:37 PM »

still a few problems on which I will report...
Don't hesitate to report these few problems/inconveniences in this forum (and if applicable in a new/different thread).
Logged
prairie_dad
Newbie
*
Gender: Male
Posts: 5


View Profile
« Reply #7 on: January 27, 2011, 18:44:33 PM »

now seems to be working fine, with four keyboards as required...US, German, French and Spanish.  The trick appears to be that the checkbox "apply settings system wide" must be check for these changes to take...or so it seems.  I can't be quite sure exactly what I did in what order, but I set them up one way, then another...but they kept reverting to the first set up (not the defaults, but what I chose, wrongly, the first time...)  So I finally had to remove all the wrong settings, and go from scratch, making sure to click that checkbox each time...for the hardware tab, the layouts tab and the Advanced tab...and now it appears to be holding.

Also, a slightly different problem...the virtual onscreen keyboard does not seem to work right, that is, it does not recognize the use of the different language keyboards except with the shift key depressed...it does not react to pressing down the AltGR key at all. 

Generally, I am very pleased with Pardus, though.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: January 27, 2011, 21:17:09 PM »

that the checkbox "apply settings system wide" must be check for these changes to take...
I didn't use this checkbox in my test.

What do you mean by
...but they kept reverting to the first set up...
Huh?

....it does not react to pressing down the AltGR key at all.  
See my result made in a single Pardus session (I hope this is what you mean Huh?)


* us-keyboard.png (31.93 KB, 331x133 - viewed 111 times.)

* de-keyboard.png (33 KB, 325x132 - viewed 126 times.)
« Last Edit: January 29, 2011, 22:47:05 PM by atolboo » Logged
prairie_dad
Newbie
*
Gender: Male
Posts: 5


View Profile
« Reply #9 on: January 29, 2011, 16:03:25 PM »

shows U.S. flag for English, and Virtual Keyboard icon in tray.

shows what happens when I open VK...all correct...

shows that when I press the shift key, all is still good...

but I can't get VK to do anything at all when I press AltGR...so I never can see what is the layout of the 3rd level keys.

In fact, the behavior of the VK is flakier still...sometimes it reacts to certain keypresses, sometimes not...

thanks for sticking with this thread...

...and while I've attached the three images I refer to, how do you get them to display in your message?

dave


* newtray.png (10.14 KB, 146x67 - viewed 294 times.)

* regular.png (68.86 KB, 528x274 - viewed 121 times.)

* caps.png (60.68 KB, 520x266 - viewed 119 times.)
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #10 on: January 29, 2011, 17:32:49 PM »

You can see with my "us" and "de" marking which real keyboard, I am using.
And the keyboard changes when I select the marking with my left mouse.
I don't have and use  a virtual keyboard.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #11 on: January 29, 2011, 22:50:32 PM »

.... how do you get them to display in your message?
Actually it are two different pictures and I have updated them to (hopefully) make it better understandable. Wink
At the left side of the = sign is the used key combination, and on the right side of = is the resulting character.
« Last Edit: January 29, 2011, 22:53:54 PM by atolboo » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!